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Chapter 1. About MOEX Trade Currency
MOEX Trade Currency is the trader terminal for the Moscow Exhange FX Market.

Key functional features of MOEX Trade Currency:

• Real-time display of all the market data.

• All types of orders (market and limit orders with different execution conditions).

• Order-driven and quote-driven markets: regular orders, negotiated deal orders, SWAP orders.

• Monitoring of own current and planned positions.

Main service features:

• Dynamic export to MS Excel and databases.

• Hot keys and mouse-oriented controls for quick order entry.

• Flexible filtration and sorting options, table templates.

• Many options for desktop layout customization, including the creation of several virtual desktops.

• Intraday and historical charts with elements of technical analysis.

• Access to archive with trading results.

• Instant messaging with other traders and market administrators.

• Alerts on message and negdeal receipt.

• Auto-update.

• Technical support by Moscow Exchange staff.
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Chapter 2. What's New
("+" - new feature; "о" - modified feature of behavior; "-" - removed functionality; "!" - bug fix)

Version 3.25.60

! Error in calculation of assets withdrawal in single and multiple currencies has been fixed.

+ Added buttons "Copy connection settings to the clipboard" and "Paste connection settings from the
clipboard" to the Options dialog.

Version 3.25.50

+ Added "Microseconds" filed to the Trades table.

+ Added "Clearing Account", "Clearing firm", ""Clearing Firm Id" fields to the Trading Accounts table.

+ Added "Без расчётов в НКЦ" field to the "Assets table.

o The single currency and multiple currencies assets withdrawal query takes into account the planned rather
than the current funds position.

+ Added possibility to connect the NCC plugin on weekends through its activation by the user.

Version 3.25.40

+ Added new columns to the Auctions table.

+ Added new columns to the Client Codes table.

+ Added flags to disable checks on the Single limit or all limits in the Enter Transfer orders/Transfer to
Trading Member Entry dialogs.

! Interface errors and shortcomings have been corrected.

Version 3.24.36

! Corrections and improvements.

Version 3.24.30

o The 'Positions by Instrument' table is no longer displayed in the terminal due to the cancellation of the
publication of data on positions by instrument on the FX market. Data on positions are published in the
table 'Liabilities and claims for assets'.

o The methodology for calculating the Single Limit in the detalization window and in the single limit
calculator has been updated.

o The 'Type' field in the drop-down list in the order entry forms and in the 'Client Codes' table is now filled
not with the type number, but with its name in accordance with the directory of client code types.

o The field 'Compliance ID' in the table 'Orders' is now filled not with the alphabetic value of the type, but
with its name in accordance with the directory of orders compliance IDs.
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Version 3.24.20

+ Extra Effects field is added to the Single Limit Components form.

+ Liabilities and Claims for Pairs table is added.

+ Support for Validata cryptography tool of a new version.

Version 3.24.15

o Moscow Exchange production server (VPN) connection profile is added to the terminal.

o Description for position groups is broadcasted in Russian or English depends on interface language
chosen by user.

! Improvements for Single limit calculation and detalization.

Version 3.24.10

+ A compliance field is added to the "Orders" table.

Version 3.24.05

+ The following windaws are added to the terminal: Unsettled Trades, Enter Confirmation Trade Settlement
Report, Sent Reports, Trades of report.

Version 3.23.45

! Calculation of Effective market risk rate is fixed in the "Single Limit Components" dialog.

! Value of the Addressee alias can be changed while editing negdeal.

Version 3.23.40

+ "Single Limit Components" dialog is added. This dialog may be opened with the command from the Query
menu of the main menu.

o Users of "User-TrdAcc" type are allowed to perform operations with negotiated deals.

o The Addressee alias fiield is added to "Enter SWAP negdeal" dialog.

Version 3.23.35

+ Terminal supports Request for Stream entering with new instruments. TOD, TOM, SPT instruments of
the KZT/RUB currency pair, as well as TOD and TOM instruments of the TRY/RUB and BYN/RUB currency
pairs are available.

+ "Face value" informational field is added to the Request for Stream form.
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Version 3.23.31

! Fixed NCC module connection error.

! Error fixed: client code was not included into a packet of counterorders.

Version 3.23.30

+ The Hidden qty field is added to the Enter SWAP Order dialog. SWAP iceberg orders entering is available.

+ The "Signal events" area on the Signals tab of the program options window was supplemented with the
Received messages checkbox to manage messages from the trading system signals.

+ The "Fully covered trading limit" field is added to Assets, Interproduct spreads, Interproduct Spread
Assets. tables

+ The "Trading account" field is added to Received Negdeals table to display the trading account from which
the received negdeal was entered.

o Users who are managing trading accounts and bank accounts included into them (User-TrdAcc) have
access to commands of the "Administration" item in the "Action" menu.

Version 3.23.26

+ "Partial collateral" column for a percentage of free funds which is accepted as collateral today added to
the "Individual risk parameters (new)" table.

o Single Limit calculation updated to take into account "Partial collateral" feature of an asset.

o Hot keys for column filter setting (Ctrl+G) and to cancel filter (Ctrl+H) are added to the default hot keys
list.

! "List index out of bounds" error while calculated assets withdrawal was filed.

Version 3.23.25

o Single Limit calculation updated for the case when covered sales of an asset are ignoring in Single Limit.

Version 3.23.20

o Single Limit calculation updated to take into account instruments with special settle mode.

! Fixed error while exit terminal session after the shutdown of trading or clearing system.

Version 3.23.05

o Data Export supports the format adopted in CMA v2.16.10.

Version 3.22.30
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+ Toggle between security ID and currency pair is added to all the order entry forms.

+ The "Trade Time History" table is added to the terminal.

+ New "Book or Cancel" remainder processing mode is displayed at the order entry form.

Interfax News:

  o Fonts and colors setting available via the "Appearance" tab of the table properties dialog.

  o "Today" value for date filter is selected by default.

  o Time of the trading system is using while collectiong news.

  o News window reacts to global filtering.

! Fixed error while connecting ISS via faulty proxy server.

Version 3.22.25

+ Interfax news:

+ Filter by news publication time added.

+ Loading news for the specified date implemented.

+ Добавлены сообщения диагностики: "Loading", "There are no news at the moment.", "The Connection
to ISS is disabled ".

+ Missing elements automatic downloading.

Version 3.22.21

o Single Limit calculation updated according to the Clearing Rules.

! Interfax news: fixed error while getting news feed not using the https protocol.

Version 3.22.20

+ A separate news feed "Interfax FX market news" and filter by news feeds are added to news main window.

o Interfax news may be activate independently from historical market data provided with ISS. Activation
of the news feed does not require connection to passport.moex.com if Anonimous or Automatic  mode
was selected.

o ADO dynamic data export wizard is supplemented with the "Clear table before export" option.

o *.xlsm files are displayed at choosing file window for DDE dynamic data export.

! Chart properties: Source of "Volume" indicator may be changed to amount / value.

Version 3.22.15

+ Control of Algo-packet and iterations quantity; Confirmation request while entering algorithmic packet
and SWAP algorithmic packet of quantity more than 1,000,000 lots .
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Version 3.22.10

+ New form to accept asset as collateral is added to the terminal.

! Bug fixes in the news feed window.

Version 3.22.05

+ New window in trader terminal displays news feed. News is provided by Interfax agency and is
broadcasted via The Information Server (ISS).

+ Feature to show password is added to password fields of change password form and login form.

! Fixed an error while transfer of profiles of positions on assets or transfer of collateral, that was occured
while NCC connection set using Validata 6 profile.

Version 3.21.40

+ Terminal supports functions to participate in Opening auction.

+ System messages longer than 255 symbols will be displayed in full.

+ Header of terminal production version contains [test data]/[production data] mark.

! If there is not value of the last trade price during order validation parameters setup by price, validation
parameter will be setup to previous day last price.

Version 3.21.35

+ "Highlight user's orderbooks instead of firm's ones" option is added to the "Advanced Options" tab of
options window.

+ Additional Order control parameters for TWAP algo-packets.

+ New order control parameter "Amount" to be setup in lot currency.

Version 3.21.30

+ Negdeal entry form has option to enter negative price value for fixing orders with new USDRUB_WAPV
instrument.

+ Terminal supports prices of increased size. New maximum value to enter and display is 17 symbols.

+ Bridged connection parameters tab has new Secure connection flag to enable OpenSSL encryption for
connection channel. The flag might be set if Validata profile was not selected.

o The "Client codes" table is supplemented with the "DFI Access" column.

o The context menu of the "Users" table has commands "Change password" and "Force password change"
allowed for Firm Administrators.

o The "Users" table was supplemented with the "Change password on next logon" column.

o Bridged connection confirmation is now required directly after logon, before checks for autoupdate.
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o Data errors are ignored while loading administrative order validation file. User does not able to stop the
loading.

! Orders that have equal price are displayed in descend order of their volumes on the OTC Full Amount
orderbook.

! Hosted UAT environment connection parameters is added to connection profiles default list.

! Fixed terminal action with COD functionality. Terminal can be used for Sponsored market access Master
actions.

Version 3.21.10

+ In the selection of markets and boards dialog the following boards are always chosen by default: RFS
Negotiated deals, CCP OTC Сlearing CPCL, Large Volume Trades, OTC market, OTC Full amount, System
fixing.

+ The quick order entry panel [55] has changes: pointer appearance, option to choose color of the panel
("Fonts and colors" on the "Appearance" tab of the table properties form), tooltips for elements of the turbo
panel.

+ Securities table has new "WAP from 10:00 to 11:30" field to display value of weighted average price from
10:00 to 11:30 for USDRUB_TOM.

+ A value of the "Amount" field in "Orderbook", "Orders", "Trades", "All trades", "Negdeals sent", "Negdeals
received" is displayed as float number for securities with small lots.

+ Quick entry quantity buttons on the order entry form has special values for securities with small lots: 1,
10, 50, 100, 500, 1К;

Version 3.13.11

RFS Module:

+ "Quote RFS" and Request for Stream" forms support auctions with SWAP securities and securities on gold.

Algorithmic Module:

! Best quotes display is fixed for order entry forms.

Version 3.13.10

+ The SWAP TWAP Algo-packet entry form is added.

o The FXDesk desktop is added as a default bookmark.

o ALGO and RFS default desktops has changes.

! Firm administrator" user type is able to set SMA limits.

Version 3.13.9

+ Demo version of the Algorithmic Module.
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o Fonts properties was updated for turbo mode buttons in the Orderbook table.

! Now the RFS bookmark is more flexible.

Version 3.13.8

+ It is possible setting up pre-trade checks for SMA users.

+ The "Addressee alias" field was added to the negdeal entry form.

+ Now it is possible to minimize orderbook window without quick order entry [55] buttons.

+ Setting the Turbo flag, the orderbook window gets the red frame and the aim cursor, and auto lock mode
is activated.

+ Auto lock of orderbook window and auto turn off turbo mode options was added on the "Adv. options"
tab of "Parameters".

o MOEX VPN connection profile might be selected during the terminal installation.

o Negdeal entry form: volume buttons are displayed with 1M, 2M, 5M, 10M values for OTC full amount board.

! If the order was partially matched in "Over-the-counter market" board, the confirmation message displays
with matched quantity of the order.

Version 3.13.7

+ OTCF trading board (OTC Full amount) is added to the Terminal.

o RFS Module: best quotes indication is excluded from Quote RFS form.

o RFS Module supports "Supervisor" user type now.

Version 3.13.6

+ In relation to Request for Stream service implementation RFS menu was added to the terminal.

Version 3.13.5

+ The "oz" dimension is added to order entry forms for XAU securities.

o "Positions by Securities", "Positions by Limits", "Positions by Assets", "Liabilities and claims for assets",
"Trading Accounts", "Bank Accounts" items was moved from "Positions" submenu to the "Tables" menu.

o "Trading Accounts" and "Bank Accounts" icons was added to the "Firm tables" panel of the toolbar.

o Order entry forms: resulting order volume instead of quantity now displays on the quick entry quantity
buttons.

! Editing rate error fixed for SWAP order entry form.

! Single limit calculating now enabled for bank accounts of Trading members level 2 and 3.

! DDEServer naming error was fixed for MOEX terminals.
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! Now it is not possible to Double-click to button "Enter Order" at order entry form when "Show successful
transaction execution results" option is disabled.

! Order entry forms: Reference entry error fixed for enabled Add client code to "Broker reference" field
option.

Version 3.13.4

+ Buy/Sell quotes in the "Orderbook" table for the USDRUB_WAP0 security of the system WAP deals board
are represented with "+" sign.

! Second level bank accounts are now displayed in "Clearing bank account" column filter.

Version 3.13.3

+ The "gram" dimension is added to order entry forms for metals.

+ Commission fee warning for USDRUB_TDB orders that will be put into queue (trader=maker) is added to
order entry form with "Put into queue" flag active.

o Connection settings for regional technical centers are deleted from the default configuration file of
distribution kit. Current user settings stayed unchanged.

o "Show thousand separators in numeric fields" flag now is active by default.

! The "invalid floating point" error is fixed for charts.

Version 3.13.2

+ The "1-st Level" column (the flag of the first level bank account) is added to the following tables: "Positions
by Limits", "Positions by Assets", "Positions by Securities", "Liabilities and Claims for Assets".

+ A new column "Level 1" for the "Trading accounts" table (the flag of the first level trading account).

+ Clearing member has the option of global filtering by all it's trading members for clearing.

+ The Global filtering option is supplemented by "Show lower level bank accounts" button.

+ NCC Module: The "Second market" field and the List of changes of the Second market are optional for
the "Request for transfer of profiles of positions on assets" dialog.

Version 3.13.1

! A "Firm" (for trading account) field for accepting received negdeals by packet is filled with firm id
automatically.

Version 3.13.0

+ In relation to Individual Risk-Parameters features implementation, "Market Individual Risk-parametes
(new)", "Individual Risk-parameters (new)" tables with market individual risk parameters setting,
interproduct spread discount rate setting forms and percent risk calculation (by bank account) flag added
to the Users' Terminal.
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+ The column "Don't check SL" added to the "Bank Accounts" table.

+ To quickly set up large negdeal volume for OTCT board on OTC negdeal entry form, buttons are displayed
with 100k, 500k, 1M, 3M, 5M, 10M values.

+ Information string with lot size and total volume was added to quick order entry panel [55].

+ A "Firm" (for trading account) field on order entry, SWAP order, negdeal order entry and SWAP negdeal
forms.

+ A "Firm" (for trading account) field added to packet entry form.

+ The "Stop List of Clients" table.

+ "Enter Transfer Order to Trading Member" form.

+ "Enter Complex Negdeal" and "Enter Complex Negdeal SWAP" forms was modified.

+ "Check Collateral Sufficiency" by bank account form.

+ "Request order confirmation by this security" option on setup quotes tab : Default / Always / Never .

o The new individual risk-parameters are taken into account in the Single Limit Calculator.

Version 3.12.8

+ The field containing spread value between volume weighted average buy price and volume weighted
average sell price depending on entered volume was added to orderbook Quick entry (turbo) mode panel.

+ Order validation parameters feature was extended to orders which entered using turbo mode.

+ The "Partners" dialog to form the list of partners for Negdeal or Negdeal SWAP.

+ In relation to revision of user authentification system a password expiration warnings with suggestion to
change password were implemented in Trading System connection.

! Prohibition of trading without full pre-funding for asset and firm will be considered in the maximum number
of lots calculation.

Version 3.12.7

+ Feature to calculate comission and Single Limit was added to order enter, SWAP, negdeal enter and SWAP
negdeal forms.

+ NCC module: English and Russian support was implemented.

+ NCC module: Shortcuts for "Transfer of profile of positions on assets" (Ctrl+F6) and и "Transfer of
collateral" (Alt+F6).

+ NCC module, "Operation Log" table: "Document" word was replased to "Request".

+ NCC module, "List of requests for profiles transfer" table and "Transfer of collateral" form: column
"Request number" was renamed to "Request ID".

Version 3.12.6

o A "Firm" coulumn was added to Bankacc Filter of second and third levels.
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o The negdeal entry form was renamed to "Enter Negdeal / OTC Negdeal".

! The FIXS board was hidden from the negdeal entry form.

! The «Configuration Access Error» during connection using RSA-cryptography.

! Bug of missing information about price move limits for firm manager was fixed.

Version 3.12.5

+ Table "Interproduct spread assets" and new version of "Interproduct spreads" was added.

o Due to exclusion of trading limits the "Collateral and trading limit for operations" form was renamed to
"Calculation of Collateral for Operations". The "Required trade limit in RUB" field was removed from form.

- The "Product spreads" table was excluded.

Version 3.12.4

+ In relation to implementation of the new version of Trading and Clearing System with separate
connections to trading and clearing modules the Clearing System connection feature was added to the
terminal. Connection to CS must be established for getting clearing data and risk parameters.

+ The "Collateral sell limit" column has been added to "Liabilities and Claims for Assets".

o The "Planned T+" value of the "Liabilities and Claims for Assets" table is calculated without information
of transfer profiles.

o The "Settle" value of the "Positions by Assets" table is calculated as current settlement having "today"
settlement date.

! The Trading Accounts table will be automatically updated.

! If Trading System returns more than one message for transaction, it displays all of them.

Version 3.12.3

+ Quantity validation for the second part of SWAP order/negdeal.

+ Quantity validation for negdeals.

+ Negdeals validation parameter "Price" of type "To current Bid/Offer" use Bid and Offer values from "Best
Negdeals" table.

+ MOEX Passport authentication is added to NCC integration module.

+ The "Single pool" column is added to "Positions by Assets", "Positions by Securities", "Positions by Limits",
"Liabilities and Claims for Assets" tables.

+ The "Accounts in Settlement organizations" table has been added.

o The "Percent Risk Parameters" table load procedure is optimized by reducing the amount of data which
was received from Trading System.

! Building trades concluded at fixing price chart is fixed.
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Version 3.12.1

+ in relation to "Unified Collateral Pool" project implementation, the NCC integration module is added to
the terminal installation package;

+ the "Trading without full pre-funding limits for Bank Account" table has been added;

+ the "Set internal Bank Account limit" form has been added;

+ feature to enter order by volume-weighted average price has been added;

+ the "Show Log" (in case of the logging is turned on) button and the information about current user's ID
has been added to the "Connection Info" window.

Version 3.12.0

+ support for trading at the MOEX Fixing price: Order Entry dialog may be used to submit regular fixing
orders, Negdeal Entry form - to submit orders for negotiated deals fixing with counterparty indicated;

! Dynamic Export fix: we resolved an issue that occured in case the target table contained special characters
in column names;

Version 3.11.4

+ calculation of assets withdrawal in single or multiple currencies may be performed considering T0
collateral;

o broadcast addresses will be automatically updated due to migration to the new data center;

! we have resolved an issue that led to unexpected program freezes;

! "Central Rate" field of the Securities table is applicable only for instruments settled in RUB ("Currency"/
RUB);

! several bug fixes in Charts module.

Version 3.11.3

+ Administrative Order Validation;

+ Collateral after Risk-parameters Change form added;

+ printing functionality extended with landscape orientation and scaling;

! several changes in the "Positions for settlement" table: former "Opening balance" field renamed to "Current
balance", former "Current balance" renamed to "Unsettled liabilities", "Opening balance" field added that
contains the value from the corresponding field of "Liabilities and Claims for assets" table.

Version 3.11.2
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+ Positions by Currencies and TOM provision forms added;

+ Transfer Order and Transfer to Partner dialogs, Transfer orders and Transfers tables, "Transfer Info" in
pop-up menu of these tables;

+ Complex negdeals and Complex SWAP negdeals;

+ Interproduct Spreads table;

о Global Filter by Bank Account functionality is extended with "show/hide linked bank accounts" button;

о "Opening balance" column is added to the Liabilities and Claims for Assets table;

o "Assume that all orders are matched and trades are concluded (close position mode)" option is added to
the Collateral and trading limit for operations form;

- "Positions by Currencies" and "Postitions by Trades" tables removed;

- orders submission by WA price is currently prohibited on FX market.

! Dynamic Export to MS Excel (2007 and older versions) fix: the limitation of maximum 65535 rows
overcome.

Version 3.11.1

+ Currency Rates table added;

o "Show thousands separators in numeric fields" option added to the Actions tab of the program options
form;

о tables' filtering by column modified: multiple values in the drop-down list may be selected simultaneously;
when filter is active all the selected values are shown on the top of the drop-down list;

o TSMR connection options now can handle host names, not only IP-addresses;

o when Administrative Data Sets Control is enabled transaction parameters (security, account,
counterpatry) are checked before submitting, for example, when entering an Order Packet;

! Administrative Data Sets Management bug fixed: negdeals received from prohibited counterparty can no
longer be accepted by trader;

Version 3.11

+ installation procedure may be performed for the current user without administrative privileges;

+ support for separation of member status on Trading Member and Clearing Member;
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o assets in BYR, GBP and HKD are considered in Single Limit as currencies with partial collateral;

o tables can be filtered by several values of the "Client Code" field simultaneously;

о support for constant Heartbeat when "Cancel-On-Disconnect" mode is enabled;

! Administrative Data Sets Management bug fixed: securities that were not included into Data Set can no
longer be found with Security Finder, and Data Set can no longer be modified at Negdeal Accept;

- "Position Provision" table removed;

- "Market Maker Stats" table removed. To obtain information on Market Maker's obligations use "Market
Maker Stats (extended)" table.

Version 3.10.1

! order acceptance in the Negdealbook table fixed;

! single limit calculation error fixed in the Assets Withdrawal in Single/Multiple currencies dialog;

! data sorting issue in Risk-parameters tables resolved;

! ISS bug fix: terminal correctly handles html-reply (e.g. '404 Not Found');

! Dynamic export issues resolved.

Version 3.10

+ Changes related to the new Risk Management system on FX market:

• Setting Individual Risk Parameters;

• risk parameters from Derivatives Market are considered when calculating Unified Limit;

• Fully Covered Trading dialog for Firm Manager that can opened from Bank Accounts table;

+ new table Market Maker Stats (extended);

o Auto start export enable/disable option for Dynamic Export with configurable start delay.

Version 3.9.2

+ administrative Data Sets management;

o modification of order entry dialogs: if trading board is not selected all securities from all trading boards
will be available in the list.
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Version 3.9.1

+ client code can be used as condition for order withdrawal;

o batch order withdrawal can be processed even if for more than 99 orders selected. First 99 will be
withdrawaled at once;

o "Settlement date 1" field added to the "Securities" table (Settlement date for the 1st part of SWAP trade);

! yield for SWAP orders is calculated on basis of exact information on settlement date of the 1st part;

! in case of errors during loading configuration files, corrupted data will not affect the correct configuration
stored on the HDD.

Version 3.9

+ support for the new Risk Manamgement system on FX market (Precious metals trading);

+ following tables added to the "Query"->"Risk Parameters" menu:

• Assets;

• Individual Risk Parameters;

• Market Risk Parameters;

• Percent Risk Parameters;

+ Liabilities and Claims for Assets table added to the "Table"->"Positions" menu;

- following tables removed from the terminal:

• "Risk Estimation Ranges";

• "SWAP Indicative Rates";

• "Security Positions by Settledates";

• "Return Positions by Settledates";

! fixed error that occured in case of changing displays configuration during working with program.

Version 3.8.2

+ Yield for SWAP securities is presented:

• in order entry dialogs for:

• SWAP orders
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• SWAP negdeals

• corresponding column in the "Negdealbook" table;

+ support for a new mechanism of Market-maker liabilities calculation;

o "Mark best quotes with large font" option added to the orderbooks table properties;

- "User Cash Positions" table removed and "Setting Limit in User Positions" command is no longer available;

! fixed error that occured when closing order entry dialog while loading "Securities" table;

! sorting, filtration and searching issues on columns containing Cyrillic characters fixed.

Version 3.8.1

+ "Settlement Organizations" table added.

Version 3.8

+ support for a new Risk Management System on FX market: partial collateral in CNY;

+ base rate for SWAP negdeals can be specified by user;

o "Turn on logging" option is added to the Authentication in the Trading System dialog;

o multiple selected orders withdrawal from "Sent/Received Negdeals" tables;

o local administrator privileges is no more required for auto-update, however user must have a permission
to write to the corresponding directory.

Version 3.7

+ support for a new "Validata" certificate format and cryptography for non-residents;

+ "User-TrdAcc" table added;

+ "Prohibit breach of the limit" flag added to the "Order Validation Parameters Setup" form;

+ Direct2D support for charts;

+ distribution package and executables are signed with digital certificates;

! default printer configuration bug fixed.
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Version 3.6.3

+ in the Users table User Type is formed according to his Role;

+ Quick Order Entry buttons in the Orderbook table (turbo mode);

o charts user interface modified: new scrollbar and navigator for quick scrolling and scaling;

! Order Validation Parameters: Hidden Lots are included in the calculation;

! ISS: bug fixes.

Version 3.6.2

o an ablity to copy the content of "Calculation of Provision and Trading Limit for Operations" dialog to the
clipboard;

! dynamic export to Oracle fixed: "Cannot access field 'IS_NULLABLE' as type Boolean" problem solved.

Version 3.6.1

+ settlement code and date description added to the "Enter Order" dialog;

+ "settlement date" column added to the Securuties table;

o additional collateral calculation form modified;

o table content update interval can be specified up to 0,1 sec. The minimum update interval decreased to
0.2 sec;

o "Request" button added to the "Settlement code" list in order entry dialogs for manual code requesting;

o ability to use random settlement codes when forming order packet.

! dynamic export to .DBF fixed;

! maximum lots quantity calculation modified for Long-term SWAP orders.

Version 3.6

+ Version for 64-bit Windows;

+ "Negdealbook" and "Best Negdeals" tables;

+ "Security Positions by Settledates" and "Return Positions by Settledates" tables;

+ "SWAP Indicative Rates" table;
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+ Long-term SWAPs support added to "Calculation of Provision and Trading Limit for Operations";

o "Request" button removed from "Settlement code" list in order entry dialogs;

o In the "Enter Negdeal" dialog list of Settlement Codes can be sorted both by Settlemen Code and
Settlement Date (previously - only by Settlement Code);

! "keep stable depth" option fixed in orderbook tables;

! thousands separators removed, when copying tables' content to the clipboard;

! rows sorting fixed in orderbook tables for SWAP-securities;

- The "Positions by Settledates" table removed.
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Chapter 3. Installation and update

System requirements

Minimum system requirements:

• CPU: Intel Core or compatible, 1,4 GHz or higher;

• RAM: 4 GB;

• HDD: 1 GB free drive space;

• screen resolution: 1280х1024 or higher, 32-bit color;

• keyboard, mouse;

• network bandwidth: 128 kbps per every terminal;

• OS: Microsoft Windows 10 or newer, Windows Server 2016 or newer, 32 or 64- bit;

• Microsoft Edge.

Recommended system requirements:

• CPU: Intel Core or compatible, dual-core, 2 GHz or higher;

• RAM: 16 GB;

• HDD: 10 GB free drive space;

• screen resolution: 1920х1080 or higher, 32-bit color;

• network bandwidth: 4 Mbps per every terminal;

Installation

MOEX Trade Currency installation procedure involves the following steps:

1. Save the  moex-cur-version_number.exe  file to the local drive.

2. Double-click the file in Explorer to launch the installation wizard. The first dialog offers the installation
type: for all users (requires administrator rights) or for current user only.



Installation and update 19.09.2025

20

3. The next dialog offers the selection of the program installation interface language (the language of the
program interface can be selected in program options).

Choose the language and click OK.

4.

Default installation folders for the program are:

• for all users - Program Files\MOEX\Trade Currency

• for current user - Users\User Name\AppData\Local\Programs\MICEX\Trade Currency

If older version of the terminal was previously installed, the existing folder will be suggested. Modify, if
needed, the installation path or press Browse... to select a folder. Click Next to confirm.
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5.

Enter or select folder name for the Start menu, or mark the checkbox to skip the group creation. Click
Next to proceed to the next step.

6. Select additional tasks during the terminl installation.

Set the "NCC integration module" flag to install this module as the part of Trade Currency terminal. If
you need to uninstall the NCC module, disalble the checkbox while reinstall the terminal.
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7.

Select the connection method: through the leased line or over the Internet. Select the environment:
production or test. These choices define the set of connection parameters which can be changed later
in program options. Click Next to continue.

8.

Review the settings and click Install to start the actual program installation.
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9.

In case of issues during the installation process for all users (for example lack of administrative
permissions) then an additional window will pop-up listing the services which must be added to the
windows\system32\drivers\etc\services file by the system administrator. It will not be possible to
connect to the trading system unless these lines are added. Note: an empty line should be present at the
end of the services file. Click Next to proceed to the next step.
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10.

Click Finish to close the installation wizard.

Update

Program checks for updates automatically every time it connects to the Trading System. For stability
purposes and in order to have access to all the market features, it is highly recommended to install all the
suggested updates.

Admission to connect

In order to be able to connect to the production environment it is essential to have an appropriate technical
access to the Trading System (leased line or the Internet) and to be admitted as a trader to the Moscow
Exhange FX Market.

Support and Sales

Technical support is available on working days from 9:00 to 19:00 Moscow time.

• In case of any issues with the software, please contact our Support team:

Phone: +7 (495) 733-95-07

• To purchase additional license for the trader terminal or any other Moscow Exchange software, please
contact our Sales team:

Phone: +7 (495) 363-32-32, extention 3377

• Any questions related to Moscow Exchange software can be addressed to:

e-mail: help@moex.com [mailto:help@moex.com?subject=MOEX Trade Support]

mailto:help@moex.com?subject=MOEX Trade Support
mailto:help@moex.com?subject=MOEX Trade Support
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Chapter 4. Connecting to the Trading System

Authentication in the Trading System
After the program starts select the Login item in the Session menu. Then enter (or select from the drop-
down list) your User ID and password and click OK.

In order to change the connection settings, click Show Options button and then click the  icon to open
the connection settings dialog (or close the Login dialog and select Options in the Tools menu).

Click Show Options button to display the following flags:

• Connect to - selection of a connection profile.

•  - open the connection settings and profile management dialog.

•  - remove selected user profile from the list and delete all related user settings.

• Do not load cached tables - reload all the table data from the Trading System.

• Do not restore last used desktop settings - start the program with empty desktop and reset all the table
customization settings.

• Turn on logging - enabling this option is recommended in case of any issues when connecting to the
Trading System

Program update
If the new version of the program is ready for installation from the Trading system server, the auto-update
dialog window will appear after the successful user authentication.

If the user doesn't have enough rights on a local machine, updated components will be downloaded to the
temporary directory, but won't be installed. After that, the installation should be performed by the user with
the administrative rights, by executing the Install MOEX Trade Currency updates command, located in the
Start - Programs - MOEX - MOEX Trade Currency - Tools menu of the operating system.

To rollback the last update and downgrade to the previous version, execute the Rollback MOEX Currency
Analytic updates command, located in the Start - Programs - MOEX - MOEX Currency Analytic - Tools
menu of the operating system.

Selection of markets and boards
After the successful authentication in the Trading System the Board Selection dialog will be shown. This
dialog is used to select boards which will be available in the terminal during the working session. This set
cannot be changed without reconnection to the Trading System.
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First select market(s) in the left frame and the select boards in the right frame. Use Ctrl or Shift keys to
select several items. Press Ctrl+A to select all markets and boards.

Click OK to confirm and to start working with the program.

The next time you connect the previously selected boards will be already highlighted.

To disconnect from the Trading System select the Logout or the Exit item in the Session menu, or just
close the application.

When connecting over the Internet using an electronic signature key, the Server certificate button will be
available on the top of the Board Selection dialog to allow users view the server and client certificate details.
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Chapter 5. User Interface and its Customization
The program user interface consists of the following main areas:

Area Description

 Title
The window title includes trader's name or ID and his role
(permissions).

 Main menu
The main menu contains all the commands to work with the program
grouped by type of operations.

 Toolbar
The customizable toolbar contains icons for quick access to the most
popular commands.

 Desktop
The desktop is the place to organize and keep open tables.

 Bookmarks
The bookmarks allow users to create several virtual desktops and
quickly switch between them.

 Statusbar
The statusbar shows the time set on the Trading System server and
the connection status.

 Signal panel
The signal panel displays notifications on important events such as
receipt of a negdeal order or a message, breach of the market-maker's
liabilities, etc.

 Find panel
The security finder panel can be used to search for securities by their
name or ID.

Main Menu
The main menu contains all the commands to work with the program. Menu items are organized by type
of operations into the following groups:

• Session

• View
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• Action

• Table

• Query

• Tools

• Data

• Window

• Help

The main menu can be detached and moved as a floating window into other areas of the program interface.
To detach the menu drag the vertical dotted line on its left side.

Some items in the Table menu are placed into submenus. In the program options it is possible to switch
this grouping off to display the menu contents as the one long list.

Toolbar

The customizable toolbar contains icons for quick access to actions and tables.

If some action cannot be performed then its icon is grayed-out. For example, in order to be able to open an
orderbook it is required to open the Securities table and to select a security in it.

The main part of the toolbar consists of the three independent panels: Actions, Exchange tables and Firm
tables. Actions that can be called from the first panel depend on the currently active table. For example
the Orderbook/Negdealbook button will open the Orderbook/Negdealbook table that corresponds to the
currently selected security.

Any toolbar can be detached and moved as a floating window into other areas of the program interface. To
detach the toolbar drag the vertical dotted line on its left side.

To show or hide any toolbar select its name from the Toolbars submenu of the View menu. It is also possible
to right-click any toolbar to show the list of available toolbars and change their visibility.

To customize toolbars select the Customize item in the toolbar popup menu or in the Toolbars submenu
of the View menu;

Table 5.1. Elements of the Customize Toolbars dialog

Element Description
List of toolbars The full list of toolbars with checkboxes to switch their visibility.
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Element Description
Create Crate a new toolbar.

Rename Rename the selected toolbar. Only toolbars that have been manually
created can be renamed.

Delete Delete the selected toolbar. Only toolbars that have been manually
created can be deleted.

Reset Revert changes made to the selected toolbar.

Large images Display large icons on the toolbar.

Commands The full list of commands from the program main menu. Any command
can be added to the toolbar. If a command does not have an icon then
it will be displayed as text.

List in the right frame List of items and separators on the selected toolbar.

Select Add a selected command to the selected toolbar.

Remove Remove a selected command (or commands) from the selected
toolbar.

Insert separator Add a group separator to the toolbar.

Move selected commands to the beginning of the toolbar. Items can
be also dragged with the mouse.

Move selected commands one position up.

Move selected commands one position down.

Move selected commands to the end of the toolbar.

Bookmarks

In order to work conveniently with many tables it is possible to distribute them between several virtual
desktops (sheets) and to switch between these sheets using bookmarks.

To switch between sheets click the bookmark or press Alt+left/right arrow key or Alt+digit key.

To move a table to another virtual desktop do one of the following:

• right-click the table window title and select Move to Sheet -> Sheet name;

• select the Move to Sheet -> Sheet name command in the Window menu;

• use the sheet setup dialog as described below.

It is possible to detach the bookmarks panel and move it as a floating window into other areas of the program
interface. To detach the panel drag the vertical dotted line on its left side. The panel can be switched on
or off through the View menu.

To customize sheets and move tables between them press the  button on the bookmarks toolbar or select
the Setup Sheets item in the Tools menu or use the Ctrl+B hotkey.
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"Sheets" list on the left side of the dialog window contains names of configured virtual desktops. Drag and
drop list items to set the needed bookmarks order. Tables attached to the selected sheet are displayed on
the right side of the dialog window. One or several tables can be easily moved from one sheet to another by
dragging the corresponding item from the tables list to the preferred sheet in the "Sheets list". Check the
"On top of all sheets" box to add the particular table to all the virtual desktops.

Use Add, Delete or Modify buttons to manage sheets.

"Add/Edit Sheet" dialog provides an ability to set the sheet icon that will be displayed next to its name on
the bookmarks panel. The drop-down list contains standard terminals icons.

To upload a custom image please use the "..." button on the right side of the dialog window. Suitable file
formats are: gif, jpeg, jpg, png, bmp, tif, tiff, ico, emf, wmf. Selected image will be automatically scaled to
16 х 16 px.

Statusbar

Program statusbar displays the connection status time on the Trading and Crearing System server and the
connection status.

It is possible to detach the status and move it as a floating window into other areas of the program interface.
To detach the statusbar drag the vertical dotted line on its left side. The statusbar can be switched on or
off through the View menu.
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Table customization
All the tables have the standard Windows design, but in order to offer users more options to flexibly
customize their desktop the windows behavior has been slightly altered as described in subchapters below.

Each table keeps its own settings. If several copies of one table have been opened then the settings of the
last closed table will be saved. In order to save several sets of settings for any table, these settings can be
saved as templates.

Several copies of one table

In order to open additional copies of a table do one of the following:

• click the table icon on the toolbar or its name in the Table menu while holding the Ctrl key;

• press Ctrl+N to create a copy of the active table;

• right-click the table window title and select New window;

• select the New Window command in the Window menu.

Symbols in column headers and table titles

Besides the table name the title may contain the following symbols:

• The first number shows the total number of rows. Not displayed for orderbooks, because the orderbook
depth is fixed (and can be limited in table preferences).

• * means that the table filter has been applied.

• Orderbook title includes security and board names.

• Square brackets in Securities and Positions by Securities tables mean that the datasets are applied.

• Braces in Orderbook tables mean that the orderbook depth is specified.

• The number after the semicolon shows the number of the table when several copies are open.

Column headers my contain the following symbols:

•  – column is sorted in ascending order;

•  – column is sorted in descending order;

•  or  and a number – sorting order when several columns are sorted;

• darker column header background and the funnel icon indicate that the filter on this column is switched
on.
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Table headers

Besides the standard placement on the top of the table it is also possible to rotate the title to place it on the
left side in order to free up some additional vertical space for table rows. To move the title use the Window
Header -> Left/Top commands in the title popup menu.

In order to minimize the window title select the Window Header -> Tiny command in the title popup window.

To change all the table visualization settings it is also possible to use the table properties dialog.

Column setup

The following table lists the customization actions that can be performed using mouse or popup menu of
the column headers:

Action Menu item Mouse
Sorting rows Sort Ascending

Sort Descending

Do not Sort

Click header continuously. Hold
the Ctrl to sort by several columns.

Hide column Hide Column Drag the column header outside
the table and drop it there.

Change column width - Drag the right column border.

Adjust column width by the length
of the longest value.

Adjust columns (will be applied to
the whole table)

Double click the right column
border (will be applied to one
column).

Change column order Setup Columns Drag column header.

Fit all columns to the visible area of
the table

Fit All Columns -
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Action Menu item Mouse
Wrap column headers Wrap Words -

Hide column titles Collapse Header -

To change various column settings it is also possible to use the table properties dialog.

Moving and Resizing Tables

Any table can be moved by dragging its title and resized by dragging any of its borders.

In order to help users utilize their desktop space most efficiently, table will automatically snap to other
tables and borders when moved or resized. This behavior as well as the snap distance can be changed in
the program options.

Automatic table arrangement

To automatically arrange tables on the desktop select one of the following commands in the Arrange
Windows submenu of the Window menu:

• Tile

• Cascade

• Custom

Table Properties

To open the table properties select the Properties item in the Window menu or in the table's popup menu.

These properties are individual for every table, but the color settings can be applied to other tables through
templates.

Appearance Tab

The Appearance tab of the table properties dialog allows users to set up options related to the table design,
including colors.



User Interface and its Customization 19.09.2025

34

Table 5.2. Elements of the "Appearance" tab

Element Description
"Title" frame
Show title Uncheck the box to hide the window title, including "Close", "Minimize"

and "Maximize" buttons.

Top Title on the top of the window. This command can also been executed
from the window title context menu (double click the window title).

Left Title on the left of the window. This command can also been executed
from the window title context menu (double click the window title).

Tiny Minimize the window title. This command can also been executed from
the window title context menu (double click the window title).

"Column headers" frame
Show headers Uncheck the box to hide column headers. Disabling this option will

cause context menu, changing column width and sorting unavailability.

Collapse Minimize the column header. This command can also been executed
from the column header context menu (double click the column
header).

Word wrap Check the box to activate word wrap. This command can also been
executed from the column header context menu (double click the
column header).
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Element Description
Fit columns to width Optimize columns width to window size. This command can also been

executed from the column header context menu (double click the
column header).

"Table" frame
Indicator column Activate this option to add an indicator column, pointing to the active

row, to the left of the table.

Highlight focused row Highlight the whole row, when selecting the cell. The selected cell will
be highlighted with the alernative color.

Horizontal grid Horizontal lines between table rows.

Vertical grid Vertical lines between table columns.

Icons and colors in cells Enable cells coloring and graphical elements (for example for Order
Status).

Highlight every ... row Check the box to activate highlighting and specify the needed interval.

"Fonts and colors" frame
List of elements Select the element to customize font and color for.

Color Select standard or custom color for selected element.

Font Select font, style and size for selected element.

Click the Ok button to confirm changes and close the dialog window. Click the Apply button to confirm
changes and leave the dialog window opened. Changes will be saved for all tabs of the dialog window. Save
Settings as Template and Load... are used for saving and loading settings from the templates.

Columns Tab

The Columns tab of the table properties dialog allows users to configure the visible set and order of table
fields.



User Interface and its Customization 19.09.2025

36

Table 5.3. Buttons of the "Columns" tab

Button Description
Select Add selected available columns to the table. This operation also can

be performed by siply dragging selected columns from the left list to
the right one.

Remove Remove selected columns from the table. This operation also can be
performed by siply dragging selected columns from the right list to the
left one, or without calling the dialog window at all: by dragging the
needed column header outside the table.

Select All Add all available columns to the table.

Remove All Remove all columns from the table.

Reset Restore the default columns configuration.

Move selected fields to the top of the list.

Move selected fields up the list. This operation also can be performed
by siply dragging selected fields to the needed position, or without
calling the dialog window at all: by dragging the needed column header
to the needed position.

Move selected fields down the list. This operation also can be
performed by siply dragging selected fields to the needed position,
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Button Description
or without calling the dialog window at all: by dragging the needed
column header to the needed position.

Move selected fields to the end of the list.

Fixed Check the box to move the column to the top of the list and make it
visible while horizontal scrolling the table.

To select multiple separate fields, click them, holding the Ctrl key. To select the sequentially arranged fields,
click the first field, and then the last one, holding the Shift key.

Click the Ok button to confirm changes and close the dialog window. Click the Apply button to confirm
changes and leave the dialog window opened. Changes will be saved for all tabs of the dialog window. Save
Settings as Template and Load... are used for saving and loading settings from the templates.

Context Menu Tab
The Context Menu tab of the table properties dialog allows users to define the default action for double-
click from the list of commands available in the table popup menu.

Table 5.4. Buttons of the "Context Menu" tab

Button Description
Set as Default Use the selected item as default.
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Button Description
No Default Item Do not use the selected item as default. Disables the execution of the

command by double click or pressing "Enter" button.

Reset to Initial State Restore default setting of the context menu.

Click the Ok button to confirm changes and close the dialog window. Click the Apply button to confirm
changes and leave the dialog window opened. Changes will be saved for all tabs of the dialog window. Save
Settings as Template and Load... are used for saving and loading settings from the templates.

Orderbook Tab

The Orderbook tab of the table properties dialog allows users to customize the layout of orderbooks as well
as to add additional indicators to the table header and footer .

Orderbook tab is visible only when table properties dialog is evoked from orderbook/quotebook table. For
quick access to this dialog use the Setup Quotes command of the orderbook popup menu.

Table 5.5. Buttons of the "Orderbook" tab

Button Description
"Display mode" frame
Classic Traditional orderbook. Buy and Sell rates are located in the central

column, quantity is shown to the left and to the right of it.
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Button Description
Alternative Quantity and rates are shown in separate columns, both Buy and Sell.

Simple Buy and Sell rates and quantity are grouped in columns. Direction for
each order is shown in the separate column.

Quick order entry buttons (turbo
mode)

Enable "Turbo mode [55]" for quick order entry from 'Quotes' table.

Mark best quotes with large font Flag: Mark best quotes with large font

"Request order confirmation by this security" frame
Default Use request confirmation before transaction execution global option

from "Actions" tab of "Options" form in the "Tools" menu.

Always Request confirmation before execution every time with ignoring global
setting

Never Newer request confirmation before execution with ignoring global
setting

"Additional settings" frame
Highlight buy/sell areas Check the box to color the orderbook background. By deafault: green

for Buy orders, red for sell orders.

Show sell orders on top Sell orders will be shown on the top of the orderbook window.

Keep best quotes always visible Check the box to keep best Buy and Sell quotes visible when quotes
are updated or window is resized.

Keep stable depth Check the box to constantly show a number of rows, equal to
orderbook depth.

"Orderbook depth" frame (not available for RPS and REPO quotes and Derivatives market).

Default Default orderbook depth.

Specified Enter specific orderbook depth. If the depth is specified, the
Orderbook table header will contain braces ({}).

"Show security information" frame (not available for RPS and REPO quotes).

Show security information Check boxes and select fields to show on the top and bottom of the
orderbook table.

Click the Ok button to confirm changes and close the dialog window. Click the Apply button to confirm
changes and leave the dialog window opened. Changes will be saved for all tabs of the dialog window. Save
Settings as Template and Load... are used for saving and loading settings from the templates.

Sorting

To sort table data by any column either click its header one or two times or select a corresponding item in
the column header popup menu (Sort Ascending, Sort Descending, Do not Sort).

To sort by several columns at the same time, click their headers while holding the Ctrl key.

Symbols in column headers:

•  – sort ascending;

•  – sort descending;

•  – sort order when sorting by several columns simultaneously.

Templates

The layout of every table can be saved as a template in order to apply it later to other tables of the same type.



User Interface and its Customization 19.09.2025

40

To save the current layout select the Templates - Save item in the table popup menu.

To apply layout to the open table, select its name in the Templates submenu of the popup menu.

To edit templates select the Templates - Setup item in the table popup menu.

Filter

To set up the data filter right-click inside the table grid and select one of the following items:

Popup menu entry Action
Filter Open the complex filter dialog.

Column Filter Show the quick filter window. Not available for orderbooks.
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Popup menu entry Action
Filter Active Apply or disable the last configured or loaded filter.

Filters Show the list of filters and commands to save or edit filters.

The first three items are also available from the Data menu.

Quick Filters

Besides the actions described above, in order to open the quick filter window it is also possible to move the

mouse pointer to the column header and click the  icon that will appear.

The quick filter appearance and behavior depend on the data type in the column.

The quick filter for lists shows the full list of available values. Mark the checkboxes near the required values.
Use the checkbox near the "Selected" item to mark/unmark all the values.

Filter for numerical values contains comparison conditions and the field for a value to compare the cell data
with.

One more type is the date filter which opens a standard date selection dialog:

All the quick filter windows contain the following buttons:
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•  - switch if applicable to another filter form (for example, between list selection or value selection);

•  - cancel filter;

•  - open the complex filter dialog;

Global Filtering by Bank Account

Visible content of certain tables can be limited with Global Bank Account Filtering feature. When filtering is
enabled tables will contain only records corresponding to selected BankAcc, instead of all available in the
Trading System. Clearing member which has trading members for clearing can use the "Show lower level
bank accounts" function to show only records corresponding to selected BankAcc and bank accounts for
which the selected one is clearing bank account.

To apply the filter, select the needed BankAcc in the drop-down list in the bottom of the program window.
Global BankAcc Filter will be applied automatically.

Later on, to enable or disable the filter do one of the following:

•
click the  button near the BankAcc drop-down list;

• select Apply BankAcc Filter in the Tools menu;

• press Ctrl + F8.

Click  to show/hide linked bank accounts.

When Global Filter is applied, content of the following tables will be limited:

• "Positions by Limits";

• "Positions by Assets";

• "Positions by Securities";

• "Positions for Settlement";

• "Liabilities and Claims for Assets";

• "Trading Accounts";

• "Bank Accounts";

Securities Drag-and-Drop

It is possible to drag securities from the Securities table into any of the following tables to open information
about that particular security:

• chart;

• orderbook;

• orders by security;
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• trades by security;

Full Screen Mode

To switch between the normal and the full screen mode select the Full Screen Item in the View menu or
press the F11 key.

Saving and Migrating Settings

To save all the user settings select the Save Desktop item in the Tools menu.

User settings can be saved to a file in order to migrate all the settings to another PC.

Table 5.6. Elements of the "Save Desktop" dialog

Element Description
Existing settings List of existing settings sets. Select one of the records to save it to file,

rename, delete or overwrite the settings.

Save to File Save the selected settings to file in order to migrate all the settings to
another PC or share it with another user.

Rename Rename the selected settings set.

Delete Delete the selected settings set.

Save Save current desktop settings.

Close Close the dialog window.

Desktop name Text field to enter the setting set name.

To load the previously saved user settings select the Load Desktop item in the Tools menu.
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Table 5.7. Elements of the "Load Desktop" dialog

Element Description
Existing settings List of existing settings sets. Select one of the records to rename,

delete or load the settings.

Load from File Import settings from the previously saved file.

Samples Load one of the sample desktop layouts.

Rename Rename the selected settings set.

Delete Delete the selected settings set.

Load Load the selected desktop layout.

Close Close the dialog window.
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Chapter 6. Data Sets

Using Data Sets
Data Sets are designed to simplify work with order entry dialogs and allow users define limited sets of values
for different lists. Default values for main fields of order entry forms may also be defined using data sets.

When Data Sets are activated then drop-down lists in the order entry dialogs will only contain values
selected by the user. Also "Securities" table contents will be filtered accordingly.

Data Sets can be defined for the following lists:

• security;

• counterparty;

• settlement code;

• trading account;

• client;

• broker reference;

• matching reference;

• counterparty trading account.

To apply Data Sets do one of the following:

• select Apply Data Sets option in the Tools menu;

• select the Apply Data Sets item in the popup menu of the "Securities" table;

• press Ctrl+Shift+Space when any table is active.

When datasets are applied the contents of the "Securities" table will be filtered accordingly , and drop-down
lists on the order entry dialog will contain only selected values .

Switching off datasets is performed similarly to switch on.

Active state of datasets is indicated by square brackets in titles of the filtered tables.

To edit Data Sets do one of the following:

• select Data Sets option in the Tools menu;

• select Data Sets item in the popup menu of the Securities or Boards tables ;

• if Data Sets are already active then double click the appropriate drop-down list in the order entry dialog:
Board, Security, Trading Account, Client, Broker reference, Settlement code, Counterparty, Matching
reference.

If user submits an order with security which is not currently included into the dataset (for example, from
the Orderbook table), this security will automatically be added to the dataset.

When the Broker reference data is loaded to data set from file then the Client data set will be cleared and
it could not be changed unless those broker references are unloaded.

Data Sets Dialog
The left frame of the Data Sets dialog lists the available trading boards. The right frame contains tabs to
customize data sets for each parameter.
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Boards in Data Sets

In the Data Sets dialog boards that do not have any sets defined are displayed in grey color. Boards that
have sets defined are displayed in black. If any of the boards have got a set defined on the current tab then
there will be the word Yes to its right.

To select multiple boards simultaneously hold Ctrl or Shift key.

When several boards are selected at the same time then the data set can only be difined for those
parameters that are present on every board selected.

Working with data set tabs

Title of each tab has a dot which means one of the following depending on its color:

• grey - no data set for selected board(s) is defined for the parameter, so all the values will be visible;

• green - the selected board has a data set defined for this parameter; if several boards are selected then
all of them have the same set of values for that parameter;

• half grey half green – several boards are selected and they have different values in sets.

Table 6.1. Elements of the "Data Sets" dialog

Element Description
"Selected" list Records inculded into the dataset for the current trading board

(boards). If multiple boards are selected then this list will display only
records which are included into dataset for each of these boards.
Double-click any record to open the Edit Data Sets dialog.
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Element Description
"Edit" button Open the Edit Data Set dialog. This button is not available on

"BrokerRef", "MatchRef" and "Counterparty" tabs as its value may only
be loaded from external files.

"Clear" button Clear the current data set for all the selected boards. Down-arrow
button located to the right provides "Clear for Board" and "Clear All"
commands.

"Default value" list (except
"BrokerRef" and "Cp. Account"
tabs)

Define the default value for order entry dialogs. Default value will be
loaded in the order entry form after user selects the trading board in
the form.

Please note: if default value is specified it will be used even if data sets
are switched off.

"Delete" button (except
"BrokerRef" and "Cp. Account"
tabs)

Delete previously defined default value.

"File name" field (for "BrokerRef",
"MatchRef" and "Cp. Account"
tabs only)

Path to file with data. Click Browse to select file with data suitable to
the active tab. Please find file formats description in Appendix.

"Load automatically" flag (for
"BrokerRef", "MatchRef" and "Cp.
Account" tabs only)

Load the selected file automatically at each connection to the Trading
System.

"Unload" button (for "BrokerRef",
"MatchRef" and "Cp. Account"
tabs only)

Unload the file.

OK Save changes and close the dialog.

Cancel Discard all the changes and close the dialog.

Edit Data Sets

To edit a particular data set follow these steps:

1. open the Data Sets dialog;

2. select board(s) in the left frame;

3. select the tab with needed parameter;

4. click "Edit" button.
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When data sets are active it is also possible just double click the appropriate field in the order entry dialog
in order to edit the data set.

The left frame of the window contains a list of values available in the Trading System. The right one - values
selected by user.

"Default value" field in the bottom right corner of the dialog lets user define the default value for order entry
dialogs.

Table 6.2. Elements of the "Edit Data Sets" dialog

Element Description
Select Include selected values to the data set (move from "Available" list to

"Selected").

Remove Remove selected values from the data set (move from "Selected" list
to "Available").

Select All Include all the available recordis into the data set.

Remove All Remove all the selected records from the data set. Data sets will
remain active but won't contain any records so the corresponding
drop-down list in the order entry form will be empty.

Clear Clear the dialog and switch off the data sets for the correpsonding list.

Automatically add new records to
data set

Set this flag to automatically add new records available in the Trading
System to the data set.

Default value Select the default value in the drop-down list. Default value will be
loaded in the order entry form after user selects the trading board in
the form.

Please note: if default value is specified it will be used even if data sets
are switched off.

Х Remove the default value.

OK Apply all the changes.
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Element Description
Cancel Descard all the changes.

To select multiple records simultaneously hold Ctrl or Shift key.

Contents of the "Available" list may be sorted by one or several columns (if applicable). To do so click the
the title of the column to select the sorting method: ascending, descending or switched off.

Save and Load Data Sets

Data Sets configuration may be saved to file to re-load it later.

To perform these operations use "Save" and "Load" buttons located in the bottom of the "Data Sets" dialog
correspondingly.

Data sets configuration is stored in xml files which should be available to user for reading and modification.

Please find file format description in the Appendix.

Administrative Data Sets Management

Common description

Terminal provides an ability to manage data sets administratively for one or multiple users. This can be used
to set different types of limitations for traders of the firm, for example a selection of allowed securities for
particular trading boards, or list of counterparties to conclude trades with. Administrative order validation
is also provided.

By default data sets settings are stored in the datasets.xml configuration file, that could be found on the
following path:

\Users\USER-NAME\AppData\Roaming\MOEX\Trade Currency\Profiles\[MoexUserId]\datasets.xml.

* "AppData" folder is hidden by default. To quickly navigate to the folder, containing settings, perform " cd
%appdata% " in the command line.

Typical scenario of datasets.xml usage:

1. at connection to the Trading System terminal loads settings from datasets.xml;

2. changes made using Edit Data Set dialog during work are stored in RAM of the computer and not being
written to file until the end of the connection session;

3. at the end of the session program writes new configuration to datasets.xml.

Creating datasets xml file

Creating datasets.xml (for later use as administrative source of data sets settings) can be performed in
two ways:

• using Edit Data Set dialog in terminal GUI then copy to the shared resource;

• manually: file format description is presented in the Appendix;

Data sets xml file format

Please find file format description in the Appendix.

Prohibition of data sets modification on traders' side
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To prohibit modification and disabling data sets on traders' side, the configuration file datasets.xml should
be read-only for traders. Also a full path to this resource must be specified in the Windows Registry on
traders' computers (description is given further).

If corresponding changes are made to Windows Registry on trader's computer, in case terminal can not
load validation.csv by any reason, the user session with the trading system will be aborted.

Sharing datasets.xml

Configuration file datasets.xml may be located:

• on local machine, in the folder that is read-only for trader - terminal supports LFS-formatted paths, for
example " C:\AnyFolder\datasets.xml ";

• on shared resource, that is read-only for trader - shared folders and smb-resources should be named as:

" \\Server\SharedFolder ". Terminal supports UNC-formatted paths, and also Long UNC for 64-bit
version.

Two scenarios of access to configuration file are provided:

• shared file for all users* - single source of datasets settings for multiple users. In that case file can be
located in arbitrary folder, for example " \\Server\SharedFolder\datasets.xml ".

• individual file for a particular user* - separate subfolders with names corresponding to User IDs are
required. In that case the full path to data sets configuration file would be as follows: " \\Server
\SharedFolder\[MoexUserId]\datasets.xml ".

* Note: the term "user" refers to User ID in the ASTS Trading System, but not Windows User ID.

Necessary changes in Windows Registry on trader's computer

Administrative data sets management requires some changes in Windows Registry on traders' computers
that should be performed by user with administrative privileges. Specific values should be added to the
following Registry branch:

HKEY_LOCAL_MACHINE\SOFTWARE\MICEX\Trade Currency\

Note: Trader should not have administrative rights on computer and ability to change this Registry branch.

The following keys and values should be added:

• DatasetsPathOverride - REG_SZ - path to the folder containing datasets.xml, for example " \\Server
\SharedFolder ". If the value is specified user cannot longer modify datasets himself and terminal will
not operate in case datasets.xml is missing on the specified location. If not specified datasets settings
will be loaded from default local path and user will have an ability to change settings (see "Common
description");

• DatasetsPathIsShared - REG_DWORD - "Shared Datasets" flag. Possible values are "1" (use shared
datasets.xml in specified folder for all users) or "0" (use individual files from subfolders named as User
IDs).

Example 1:

            DatasetsPathOverride=\\Server\SharedFolder
            DatasetsPathIsShared=1
        

Settings will be loaded from " \\Server\SharedFolder\datasets.xml " for all users.

Example 2:
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            DatasetsPathOverride=H:\SharedFolder
            DatasetsPathIsShared=0
        

Settings will be loaded from individual files located in subfolders with names equal to User IDs
in the Trading System, for example H:\SharedFolder\[MoexUserId1]\datasets.xml or H:\SharedFolder
\[MoexUserId2]\datasets.xml.
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Chapter 7. Market data and trade capture

Viewing Securities

Securities Table

The Securities table lists all the securities in the Trading System (on the boards selected during the logon
process) with their static and current dynamic parameters.

To open the table perform one of the following actions:

• select the Securities item in the Table menu;

• click the  button on the toolbar.

Color marks

Rows of the "Securities" table can be marked with different colors to organize several custom categories.
To mark an instrument first select one or several rows in the "Securities" table, then select the needed color
in "Mark With..." item of the context menu or "Data" menu.

In case at least one security is marked with color the "Check mark" column will appear in the "Securities",
"Orders" and "Trades" tables, and Order Entry dialogs as well. This column also can be manually added to
these tables with table properties dialog.

Table 7.1. "Securities" table columns description

Column Description
Security Security name

Board Trading Board name for the security

Security ID Security identifier in the Trading System

Status Operations are allowed;

S - Operations are suspended;

B - Suspended for trading, settlement is allowed.

Trading status TWT - Auction: After auction trade phase

LO - Auction: Bookbuilding phase, orders are locked

OE - Auction: Orders entry phase

AM - Auction: Trade conclusion phase

B - Break

C - Closing period

DA - Discrete auction

N - Not traded right now

OA - Opening auction

O - Opening period

"-" - Trading is closed

Trading session
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Column Description
UPA - Update price auction

Bid Best bid price

Offer Best offer price

First First trade price

Maximum Maximum trade price

Minimum Minimum trade price

Last Last trade price

Last change Last change

Lots in the last Volume of the last trade, in lots

Value of the last Value, expressed in the currency of settlement

Last Close Price Price of the last trade of the previous trading day

Last to Closing change Difference between the Last Price and the Previous day Closing Price

Previous WA price The weighted average price of the previous trading session

WA Weighted-average price

WA price change Weighted-average price change

Last price to previous WA price Difference between the last price and the weighted average price of
the previous trading session

Best bid Best bid price during the trading session

Best offer Best offer price during this trading session

Trades today Number of trades concluded on current trading day

Today value Value of trades concluded on current trading day, expressed in the
currency of settlement

WAP from 10:00 to 11:30 Weighted average price from 10:00 to 11:30

WA Rate 11:30 Closing period price, calculated at 11:30

Session best bid Best buy-order at the moment of the normal trading session end

Session best offer Best sell-order at the moment of the normal trading session end

Lot size Number of securities in one lot

Settlement code Default settlement code for this security

Settlement date Trade settlement date

Validate price Validate price

FX fixing price Average value of FX fixing ME and FX fixing EBS

To prev WA price, % To previous weighted-average price, %

To prev. last, % To previous last, %

Buy orders Number of buy orders in the queue of the Trading System

Sell orders Number of sell orders in the queue of the Trading System

Time of the last Time when the last trade was concluded

Asset* Asset

Base price* Base price for SWAP instruments

Best bid depth* Total unmatched volume of all active buy orders at the current best
bid price (expressed in number of lots)

Best offer depth* Volume of all sell orders at the best price, expressed in lots
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Column Description
Board Id* Trading Board Identifier

Central rate* Central rate. Applicable only for instruments settled in RUB
("Currency"/RUB).

Check mark* Check mark field may be used to mark security with color

Currency of instrument* Currency in which security is denominated

Date of the last trading session* Date of the previous trading day

Date when the lot size changed* Date when the lot size changed last time

Face value* Face value of one Security, expressed in the currency, in which the
Security is nominated

Fully covered trading* Prohibition of short selling and buying without full pre-funding

FX fixing Curr* FX fixing by orderbook liquidity and deals evaluation method for one
second interval

FX fixing ME* Average value of FX fixing Curr calculated from 12:25 till 12:30

FX fixing Prev* FX fixing ME (of the previous trading session)

Instrument Group ID* Security Group ID

Market* Market ID

Minimum price step* The minimal step by which two prices might differ

Open change* Open change

Previous lot size* Previous number of securities in one lot

Remarks* Remarks

Settlement currency* Settlement currency

Settlement date 1* Settlement date for the 1st part of SWAP trade

Total bid depth* Total unmatched volume of all active buy orders, expressed in lots

Total offer depth* Total unmatched volume of all active sell orders (expressed in lots)

Trading status* Security trading status. During the break shows the actual status of
the trading session (never changes to "Break").

Columns marked with * are hidden by default.

Description of Securities

The Description of Securities table shows the static information about all the securities traded on boards
selected during the logon process.

To open the table perform one of the following actions:

• select the Description of Securities item in the Table > Exchange Tables menu;

• click the  button on the toolbar.

Table 7.2. "Description of Securities" table columns description

Column Description
Security Security name

Security ID Security identifier in the Trading System

Face value Face value of one Security, expressed in the currency, in which the
Security is nominated
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Column Description
Currency of instrument Currency in which security is denominated

Settlement currency Settlement currency

Columns marked with * are hidden by default.

Settlement Codes for the Instrument

"Settlement Codes" table lists all the settlement codes available for the particular instrument.

To open the table first select the needed instrument in the "Securities" table and do one of the following:

• select the Settlement Codes item in the Exchange Tables submenu of the Table menu;

• click the  button on the toolbar;

• select Settlement Codes command in the "Securities" table pop-up menu.

Table 7.3. "Settlement Codes" table columns description

Column Description
Settlement code Settlement code for the instrument.

Settlement date Settlement date for trades.

Description Settlement code description

Fixing date Date of the MOEX fixing calculation

Type of clearing Type of the clearing for the instrument: "S" - simple (quick), "C" -
central, "M" - multilateral, "E" - external, [пусто] - not identified.

Columns marked with * are hidden by default.

Viewing Orderbooks

Orderbook

The Orderbook table lists the best quotes for a chosen security on the order-driven market. Each line
represents the total volume of bids and asks (in lots) at one price.

To open this table first select a security in one of the following tables: "Securities", "Orders", "Orders by
Security", "Trades", "Trades by Security" and then perform one of the following actions:

• select the Orderbook item in the Table menu;

• click the  button on the toolbar;

• select the Orderbook item in the table's popup menu;

• double click the row in the Securities table.

In table properties it is possible to select the layout of the Orderbook table and change some of the other
display options.

Quick Order Entry (Turbo mode)

Quick Order Entry buttons let quickly submit an order with the best price automatically calculated
depending on the specified order value.

Quick Order Entry mode can be disabled/enabled in the table properties on the "Orderbook" tab.
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To enter an order from the Orderbook table fill the "Order value" field with the needed quantity of lots.
Sell and Buy buttons captions will be filled with the maximum and minimum price accordingly, enough to
satisfy specified order value. If current market demand depth/supply is not enough to completely satisfy
order value, "Buy" and "Sell" buttons will be filled with the worst displayed in table Bid/Offer price for the
current moment. In this case, the field containing spread value is highlighted in red.

There are two information fields on the form:

• Weighted Average Price;

• Aggregate Value for the Price;

• A field containing spread value between VWA (volume weighted avg.) buy price and VWA sell price for
entered volume of order.

Click Buy or Sell to open the Enter Order dialog, filled with corresponding values.

If Turbo option is activated, order entry can be performed in a single click (without calling the Enter Order
dialog). This option requires the default value for the Trading Account. Use the "Data Sets" dialog to specify
the default Trading Account.

Pay attention: if Turbo mode was activated, Order Confirmation is disabled. Setting the Turbo option,
window has the red frame and the aim cursor, the head icon changes to open lock.

To avoid errors, use the lock mode: press the  icon to lock orderbook window, then icon changes to 
closed. To setting up the auto lock time and auto turn off turbo mode use options on the "Adv. options"
tab of the "Parameters" window.

Table 7.4. "Orderbook" table columns description

Column Description
Lots Volume, expressed in lots

Rate Currency exchange rate

Own lots* Volume of own active orders at this price, expressed in lots

Own orders* Number of active own orders at this price

Own value* Value of own active orders at this price, expressed in the currency of
settlement

Quantity* Quantity, expressed in securities

Rate, %* SWAP instrument rate, % per year

Sum of the best* Sum of lots at the best price

Yield* SWAP instrument yield, % per year

Quick Order Entry (Turbo mode) controls
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Column Description
Order value Quantity of lots in the order. Use hotkeys to quickly enter digits: "00"

- H, "000" - T or "000 000" - M
Turbo mode If checked, order is submitted immediately after "Buy" or "Sell" button

is pressed, without calling "Enter order" dialog.

*Requires the default value for the Trading Account.

Sell Enter Sell order for the specified value. The price is calculated
automatically as the maximum price, enough to satisfy specified order
value. If current market demand depth is not enough to completely
satisfy order value, the Best Bid price for the current moment will be
used.

Buy Enter Buy order for the specified value. The price is calculated
automatically as the minimum price, enough to satisfy specified order
value. If current market supply depth is not enough to completely
satisfy order value, the Best Offer price for the current moment will be
used.

Weighted Average Price Weighted Average price at which specified order value will be
completely satisfied, when entering an order for this value at price
shown in "Buy" or "Sell" button caption.

Aggregate Value for the Price Total volume of lots in the visible part of orderbook at price shown in
"Buy" or "Sell" buttons captions.

If current market demand/supply depth is not enough to completely
satisfy order value, the font will turn red.

Columns marked with * are hidden by default.

Команды контекстного меню

Щелкните правой кнопкой мыши строку таблицы, чтобы открыть контекстное меню.

Команда Описание
Ввести заявку на покупку Открыть диалоговое окно ввода обычной заявки, подставив

параметры из выбранной котировки и установив направленность
заявки - на покупку.

Ввести заявку на продажу Открыть диалоговое окно ввода обычной заявки, подставив
параметры из выбранной котировки и установив направленность
заявки - на продажу.

Снять свои Снять все собственные заявки по данной цене.

Снять по условию Открыть диалоговое окно снятия заявок по условию.

Заявки по инструменту Открыть таблицу с безадресными заявками фирмы по
выбранному финансовому инструменту.

Сделки по инструменту Открыть таблицу Cделки фирмы по выбранному финансовому
инструменту.

График всех сделок Открыть график всех сделок по выбранному финансовому
инструменту.

Копировать ячейку Копировать содержимое выбранной ячейки в буфер обмена.

Фильтр Открыть диалоговое окно настройки фильтра.

Использовать фильтр Включить фильтрацию таблицы.

Фильтры Операции с фильтрами для данного типа таблиц.

Шаблоны Операции с шаблонами для данного типа таблиц.
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Команда Описание
Настроить котировки Открыть вкладку "котировки" диалогового окна настройки

таблицы.

Свойства Открыть диалоговое окно настройки таблицы.

Negdealbook
The Negdealbook table lists registered negdeal orders, in which all the trading Participants were marked as
counterparty. Each line represents the total volume of bids and asks (in lots) at one price.

To open this table first select a security in one of the following tables: "Securities", "Sent Negdeals / OTC
Negdeals", "Trades", "Trades by Security" and then perform one of the following actions:

• select the Negdealbook item in the Table menu;

• click the  button on the toolbar;

• select the Negdealbook item in the table's popup menu;

• double click the row in the Securities table.

Table 7.5. "Negdealbook" table columns description

Column Description
Firm Firm name

Settlement code Settlement code for the trade

Lots Volume, expressed in lots

Rate Currency exchange rate

Firm ID* Firm identifier in the Trading System

Order* Identifier of the order, that led to the trade conclusion

Quantity* Quantity, expressed in securities

Rate, %* SWAP instrument rate, % per year

Settlement date* Trade settlement date

Yield* SWAP instrument yield, % per year

Columns marked with * are hidden by default.

Best Negdeals
The Best Negdeals table lists best registered negdeal orders for each security, in which all the trading
Participants were marked as counterparty.

To open the table perform one of the following actions:

• select the Best Negdeals item in the Table menu;

•
click the  button on the toolbar;

Table 7.6. "Best Negdeals" table columns description

Column Description
Security Security ID

Board Board ID for the security

Settlement code Settlement code for the trade
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Column Description
Settlement date Negdeal or SWAP first leg settlement date

Bid Best bid price

Offer Best offer price

Best bid depth Total unmatched volume of all active buy orders at the current best
bid price, expressed in number of securities

Best offer depth Volume of all sell orders at the best price, expressed in lots

Total bid depth Total unmatched volume of all active buy orders, expressed in lots

Total offer depth Total unmatched volume of all active sell orders (expressed in lots)

Buy orders Number of buy orders in the queue of the Trading System

Sell orders Number of sell orders in the queue of the Trading System

Board Id* Trading Board Identifier

Security Id* Security Identifier

Columns marked with * are hidden by default.

Viewing Trades

Own Trades

The Trades table lists all the trades concluded by the user (and by other users of the same firm when there
have enough permissions).

To open the table perform one of the following actions:

• select the Trades item in the Table menu;

• click the  button on the toolbar.

Table 7.7. "Trades" table columns description

Column Description
Trade number Trade number in the Trading System

Time The time of the trade registration by the Trading System

Order number Number of order from which the trade originates

Firm ID of the trading firm in whose behalf the trade is registered

Period Period of the trading session when the trade was concluded

Security Security identifier in the Trading System

Board Trading Board name for the security

Direction Order direction - "Buy / Sell / Sell-Buy / Buy - Sell"

Rate Currency exchange rate

Lots Volume, expressed in lots

Amount Amount of the trade (securities) considering lot size

Value Value, expressed in the currency of settlement

Trading account Trading account number

Position code Account ID in the Settlement House

Client code Client code specified by the trader when entering an order

Settlement code Settlement code for the trade
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Column Description
Broker reference Additional information entered by the trading firm (usually - [client

code]/[client instruction number])

User ID ID of the user who concluded the trade

Type Trade type

Counterparty Counterparty Firm name

Total commission Total amount of commission, RUB

Clearing Firm Firm ID of Clearing Member

Clearing Position Code Clearing Account ID in the Clearing Centre

Swap rate, % SWAP instrument rate, % per year

Active/Passive Active trade - the counter-order was accepted by the Trading
System before the user's order. Passive trade - the counter-order was
accepted by the Trading System after the user's order.

Base price* Base price could be specified for SWAP negdeals

Board Id* Trading Board Identifier

Clearing commission* Amount of commission fee for clearing, RUB

Clearing firm Id* Clearing firm identifier

Counterparty order number Counterparty order nuber for this trade. Only applicable for negotiated
deals.

Cpty. Id* Counterparty Id

Currency* Currency of the instrument (asset)

Exchange commission* Amount of Exchange commission fee, RUB

External user ID* A reference field which may be used as a back-feed by an external
system. May contain, for example, a user ID of the external system user
who entered the original order into that external system.

Firm Id* Firm identifier in the Trading System

Fixing date* Date of the ME fixing calculation

Liability settlement trade Trade was concluded as liability settlement trade between Clearing
member and Trading member.

Parent trade* Parent trade number for SWAP trades

Security Id Security Identifier

Settlement currency* Settlement currency (quote currency)

Settlement date* Negdeal or SWAP first leg settlement date

Settlement organization* Settlement organization for the trade

Technical access commission* Amount of commission for Technical access, RUB

Trade by iceberg-order* Set to 'Y' if Trade originates from an iceberg-order

Trade date* Trade date

User Id* User identifier in the Trading System

Microseconds Trade registration time, microseconds

Columns marked with * are hidden by default.

Trades by Security

The Trades by Securities table lists all the trades with a particular security concluded by the user and other
users of his firm.
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To open the table first select a security in one of the following tables: "Securities", "Orderbook", "Orders",
"Sent Negdeals / OTC Negdeals", "Received negdeals" and then select the Trades by Security item in the
table's popup menu.

"Trades by security" table columns description

Table structure is similar to the "Trades" table.

All Trades

The All Trades table lists all the trades on the order-driven market concluded since the beginning of the
trading session. Trade parties are not disclosed.

To open the table perform one of the following actions:

• select the All Trades item in the Table menu;

• click the  button on the toolbar.

Table 7.8. "All Trades" table columns description

Column Description
Trade #. Trade number in the Trading System

Time The time of the trade registration by the Trading System

Security Security identifier in the Trading System

Board Trading Board name for the security

Direction Order direction - "Buy / Sell / Sell-Buy / Buy - Sell"

Rate Currency exchange rate

Lots Trade value, expressed in lots

Amount Amount of the trade (securities) considering lot size

Value Value, expressed in the currency of settlement

Settlement code Settlement code for the trade

Rate, % Rate, %

Board Id* Trading Board Identifier

Period* Period of the trading session when the trade was concluded

Security Id* Security Identifier

Settlement date* Trade settlement date

Columns marked with * are hidden by default.

'Auctions' table

Table contains the information on ongoing and previously held auctions on FX market.

To open the table select the following command sequentially in the top menu: Table > Exchange Tables
Auctions.

Table 7.9. "Auctions" table columns description

Column Description
Planned Auction Time Auction start time according to the trading schedule

Board Board ID for the security
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Column Description
Security Security ID

Auction start time Actual auction start time

Auction end time Auction auction end time

Period Trading session period

Auction price Auction price. Displays the expected price of the auction with all the
currently registered orders during the auction. Displays the actual
auction price after the auction.

Value Auction trade value, expressed in the currency of settlement. Shows
expected value during the auction and the final value once it finishes.

Trade volume Total volume of all trades, expressed in number of securities. Shows
expected volume during the auction and the final volume once it
finishes.

Trades Number of trades

Imbalance Total volume of orders that will be left unmatched if the auction ends
with currently expected price

Market Buy Total volume of market buy orders based on currently expected price,
expressed in number of securities

Market Sell Total volume of market sell orders, expressed in number of securities

Orders flag (dark pools) Flag that shows the availability of any orders on the dark pool auction.

Board Id* Board Id

Security Id* Security Id

Auction status Active

Canceled

Hidden

Not active

Undefined

Trade direction Buy (Sell/Buy)

Sell (Buy/Sell)

Firm Firm Id

Minimum buy price/swap-
difference

Auction minimum price

Maximum sell price/swap-
difference

Auction maximum price

WA Weighted average price

Auction ID/negdeal session Auction ID

Columns marked with * are hidden by default.
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Chapter 8. Working with Orders

Order-driven Market

Order Entry

To submit an order on the order-driven market do one of the following:

• press the F2 key on the keyboard;

• click the  button on the toolbar after selecting a security in the Securities table;

• select the Enter item in the Order submenu of the Action menu;

• double click a quote in the Orderbook table;

• use Quick Order Entry buttons (Turbo mode) in the "Orderbook" table;

• select the Enter Order item in the popup menu of the Securities table;

• select the Enter Buy Order or the Enter Sell Order in the popup menu of the Orderbook table;

• select one of the previous orders in the Orders table and then select the Copy item in the Order submenu
of the Action menu or in the table's popup menu.

If the Enter Order action was invoked from Securities table then "Board" and "Security" fields will be already
filled-in with the data from the table. If the action was invoked from the Orderbook table then "Price" and
"Quantity" fields will be also filled-in and the order direction will be set to the opposite of the chosen quote's
direction.

Window background is green for buy orders and red for sell orders.

The submitted order is displayed in the Orders and the Orders by Security tables. Once it's matched with a
corresponding trade will appear in the Trades and the Trades by Security tables.
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"Order Entry" dialog features

• "Buy" and "Sell" tabs at the top of the window to change order direction. Press Ctrl+Tab to quickly switch
to another tab.

• Best Bid and Offer rates as well as Last trade price are displayed to the right of the "Price" field. Click one
of these rates to fill the "Price" field with the same value.

• Click the "?" button located near the "Price" field to show the upper and lower price limits for the selected
security.

• Order volume can be quickly set up by clicking one of the numbers of securities multiple to 1, 10, 50, 100,
500, 1000 to the right of the Quantity field. Ctrl-click one of these buttons to increase the number of
lots accordingly.

• "Value" field is located on the bottom of the order specification area. Its content changes accordingly to
the content of "Price" and "Quantity" fields. Enter the desired order value and click " > quantity" button
to calculate and fill the "Quantity" field with appropriate number of lots to reach the desired order value
on the price specified.
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Table 8.1. Elements of the "Enter Order" dialog

Element Description
Buy/Sell tabs at the top Order direction: Buy or Sell.

Board Trading board name. If trading board is not selected than "Security"
list will contain all the available securities on all trading boards.

Security Select the needed security in the drop-down list containing names, IDs
and Check marks.

Use the  icon to toggle between security ID and currency pair
selection modes.

Pair Select the needed currency pair in the drop-down list and then select
trade term in the next drop-down list.

Use the  icon to toggle between security ID and currency pair
selection modes.

Price Price for one lot of the selected security. In addition to manual price
entry the following options are available:

• up and down arrow buttons to the right of the entry field;

• up and down arrow keys on the keyboard;

• mouse wheel;

• hold "Ctrl" or "Ctrl+Shift" together with one of the above described
methods to increase or decrease the price for 10 or 100 steps
accordingly;

• Press "H", "T" or "M" keys on the keyboard to enter "00", "000" or
"000 000" accordingly.

Click the "?" button located near the "Price" field to show the upper and
lower price limits for the selected security.

* When "System fixing" is selected in the "Board" drop-down list and
FIX instrument as a security than Price field is cleared and becomes
disabled, "Price mode" is obligatory set as "Split" .

Quantity Number of lots of the selected security. In addition to manual entry the
following options are available:

• up and down arrow buttons to the right of the entry field;

• up and down arrow keys on the keyboard;

• mouse wheel;

• hold "Ctrl" or "Ctrl+Shift" together with one of the above described
methods to increase or decrease the quantity for 10 or 100 steps
accordingly;

• Press "H", "T" or "M" keys on the keyboard to enter "00", "000" or
"000 000" accordingly

• click one of the digit buttons to the right of the Quantity entry field
to replace the Quantity field content with corresponding value. "Ctrl
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Element Description
+Shift" multiplies each button by a thousand. "Ctrl" key modifies
buttons' behavior: quantity will be increased for the corresponding
value instead of being replaced with it.

Lot size Information field: number of securities in one lot.

Value Order value considering price, quantity and lot size.

Hidden qty. Number of hidden lots that will be added to the visible lots during the
order gradual fulfillment (for "iceberg" orders).

Value Enter the desired order value and click " > quantity" button to calculate
and fill the "Quantity" field with appropriate number of lots to reach
the desired order value on the price specified.

Currency Information field: settlement currency for the selected security.

Type Order type:

Limit – BUY/SELL order is fulfilled at the price not higher/lower than
price that was specified.

Market – order is fulfilled at the current best price. (Price field is
disabled and remainder processing mode is "Put into queue").

VWAP - order will fulfilled so that the price specified will be not higher/
lower than volume-weighted average price by all the trades which was
executed as the result of the order.

Remainder processing mode Put into queue – (good till cancel) order to be filled to the maximum
extent possible immediately after its registration, the unfilled quantity
will be placed in queue as a Limit Order.

Withdraw – order to be filled to the maximum extent possible
immediately after its registration, any unfilled quantity will be
withdrawn from the queue.

Immediately or cancel – order to be completely filled after registration,
otherwise cancelled

Book or cancel – order to be withdrawn by trading system if it’s putting
into order queue will lead to a trade conclusion order to be completely
filled after registration

Price mode Split – order may be filled both at specified price and at the better
price.

Do not split – order may be filled at the specified price only.

By WA price Submit the order at the current weighted-average price (Price field is
disabled).

Lifetime Lifetime for unfulfilled quantity. "0:00:00" = till the end of the trading
session.

Firm Firm for the trade. Order entry by clearing member.

Trd. account Trading account for the trade.

Client Client code if the order is submitted on behalf of the client.

Clearing position code Information field: clearing position code related to the selected
Trading Account.

Reference Additional notes (broker reference).
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Element Description
Enter Order Submit the order (requires confirmation). Order Confirmation can be

disabled in the program Options

Commission and Single Limit for
the Order

Click  to calculate commission, SL delta and SL after entry for the
order.

Close Close the dialog.

Repeat Last Repeat previous order specification.

Contents of all drop-down lists on the form may be limited using "Data sets" mechanism.

SWAP Order Entry

To submit a SWAP order on the order-driven market do one of the following:

• press the F4 key on the keyboard;

• select a SWAP instrument in the Securities table and click the  on the toolbar;

• select the Enter SWAP item in the Order submenu of the Action menu;

• double click a quote in the Orderbook table of a SWAP instrument;

• select the Enter SWAP Order item in the popup menu of the Securities table after selecting a SWAP
instrument;

• select the Enter Buy Order or Enter Sell Order in the popup menu of the Orderbook table of a SWAP
instrument;

• select one of the previous orders in the Orders table and then select the Copy item in the Order submenu
of the Action menu or in the table's popup menu.

If the Enter SWAP Order action was invoked from Securities table then "Board" and "Security" fields will
be already filled-in with the data from the table. If the action was invoked from the Orderbook table then
"Price" and "Quantity" fields will be also filled-in and the order direction will be set to the opposite of the
chosen quote's direction.

Window background is green for buy orders and red for sell orders.

The submitted order is displayed in the Orders and the Orders by Security tables. Once it's matched with a
corresponding trade will appear in the Trades and the Trades by Security tables.
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"SWAP Order Entry" dialog features

• "Buy" and "Sell" tabs at the top of the window to change order direction. Press Ctrl+Tab to quickly switch
to another tab.

• Best Bid and Offer rates as well as Last trade price are displayed to the right of the "Price" field. Click one
of these rates to fill the "Price" field with the same value.

• Click the "?" button located near the "Price" field to show the upper and lower price limits for the selected
security.
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• Order volume can be quickly set up by clicking one of the numbers of securities multiple to 1, 10, 50, 100,
500, 1000 to the right of the Quantity field. Ctrl-click one of these buttons to increase the number of
lots accordingly.

Table 8.2. Elements of the "Enter SWAP Order" dialog

Element Description
Buy/Sell tabs at the top Order direction: Buy or Sell.

Board Trading board name. If trading board is not selected than "Security"
list will contain all the available securities on all trading boards.

Security Select the needed security in the drop-down list containing names, IDs
and Check marks.

Use the  icon to toggle between security ID and currency pair
selection modes.

Pair Select the needed currency pair in the drop-down list and then select
trade term in the next drop-down list.

Use the  icon to toggle between security ID and currency pair
selection modes.

Price Price for one lot of the selected security. In addition to manual price
entry the following options are available:

• up and down arrow buttons to the right of the entry field;

• up and down arrow keys on the keyboard;

• mouse wheel;

• hold "Ctrl" or "Ctrl+Shift" together with one of the above described
methods to increase or decrease the price for 10 or 100 steps
accordingly;

• Press "H", "T" or "M" keys on the keyboard to enter "00", "000" or
"000 000" accordingly.

Click the "?" button located near the "Price" field to show the upper and
lower price limits for the selected security.

Rate, % * Rate for the security expreseed in percent/year.

Rate(CURRENCY), % * Information field: percent rate for the currency.

Quantity Number of lots of the selected security. In addition to manual entry the
following options are available:

• up and down arrow buttons to the right of the entry field;

• up and down arrow keys on the keyboard;

• mouse wheel;

• hold "Ctrl" or "Ctrl+Shift" together with one of the above described
methods to increase or decrease the quantity for 10 or 100 steps
accordingly;

• Press "H", "T" or "M" keys on the keyboard to enter "00", "000" or
"000 000" accordingly



Working with Orders 19.09.2025

70

Element Description
• click one of the digit buttons to the right of the Quantity entry field

to replace the Quantity field content with corresponding value. "Ctrl
+Shift" multiplies each button by a thousand. "Ctrl" key modifies
buttons' behavior: quantity will be increased for the corresponding
value instead of being replaced with it.

Hidden qty. Number of hidden lots that will be added to the visible lots during the
order gradual fulfillment (for "iceberg" orders).

Lot size Information field: number of securities in one lot.

Value Order value considering price, quantity and lot size.

Lifetime Lifetime for unfulfilled quantity. "0:00:00" = till the end of the trading
session.

Firm Firm for the trade. Order entry by clearing member.

Trd. account Trading account for the trade.

Client Client code if the order is submitted on behalf of the client.

Clearing position code Information field: clearing position code related to the selected
Trading Account.

Reference Additional notes (broker reference).

Position changes A set of information fields describing positions changes by base and
settlement currencies.

Enter Order Submit the order (requires confirmation). Order Confirmation can be
disabled in the program Options

Commission and Single Limit for
the Order

Click  to calculate commission, SL delta and SL after entry for the
order.

Close Close the dialog.

Repeat Last Repeat previous order specification.

Contents of all drop-down lists on the form may be limited using "Data sets" mechanism.

Editing Orders

To edit an order that hasn't been fully matched yet, select an order in the Orders or the Orders by Security
table and do one of the following:

• press the Ctrl+A keys on the keyboard;

• select the Edit item in the Order submenu of the Action menu;

• click the  button on the toolbar;

• select the Edit item in the popup menu of the Orders or Orders by Security table.

"Edit Order" is similar to the Order Entry form. Window title contains order number in the Trading System.

During editing the order is withdrawn from the Trading System queue. Click Enter Order to submit
modified order. Click Restore button to submit the original order and close the dialog. It also can be done
by pressing Escape key. Click Close to leave the order withdrawn.

Entering the modified order is similar to withdrawing original and submitting a new one - order loses its
position in the Trading System orders queue and moves to the end of the queue.

Elements of the "Edit Order" dialog
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"Edit Order" dialog is similar to the "Enter Order". The following fields are available for edits:

• Price

• Quantity

• Lifetime

• Client / Reference

Click "Restore" to discard all the changes and restore the original order.

Order Withdrawal

Withdraw Particular Orders

To withdraw one or several own orders follow these steps:

1. Select orders in the Orders or the Orders by Security table.

Hold Ctrl button to select several orders and Shift to select a range of rows.

2. Do one of the following:

• select the Withdraw item in the Order submenu of the Action menu;

• click the  button on the toolbar;

• press the Del key on the keyboard;

• select the Withdraw item in the table's popup menu.

3. Confirm the order(s) withdrawal. Confirmation can be disabled in the program options.

Withdraw Orders by Condition

To withdraw orders by some condition open one of the following tables: Orders, Orders by Security or
Orderbook and then select the Withdraw by Condition item in the Order submenu of the Action menu or
in the table's popup menu.

The dialog box contains fields which can be optionally filled-in to withdraw all the orders that match the
given parameters.
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Table 8.3. Elements of the "Withdraw Orders by Condition" dialog

Field Description
Buy/Sell Select the direction of orders to be withdrawn.

Board Name of the Trading Board to withdraw orders on.
Double-click this field to open Datasets dialog.

Security Name of the security, orders for which would be
withdrawn. Double-click this field to open Datasets
dialog for Securities.

Firm Information field containing identifier of
Participant's firm.

Trader Identifier of the Participant who has submitted an
order. By default this field contains ID of the user,
who has opened the dialog. To withdraw orders of
all traders, click this field and then press the Delete
button to clear it.

Price Price and its filtering conditions:

= -withdraw orders with exact specified price;

< -withdraw orders with price lower than specified;

> -withdraw orders with price higher than specified.

Trading account Withdraw orders submitted from the selected
trading account.

Client Withdraw orders submitted with selected client
code.

Withdraw buy and sell orders Withdraw orders of both directions: buy and sell.
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If the Enter Order action was invoked from Securities table then "Board" and "Security" fields will be already
filled-in with the data from the table. If the action was invoked from the Orderbook table then "Price" and
"Quantity" fields will be also filled-in and the order direction will be set to the opposite of the chosen quote's
direction.

Click Withdraw Orders button and confirm an operation. Confirmation can be disabled in the program
options.

Withdraw Orders by Security
To withdraw all the own orders with one security, select it in the Securities table and then select the
Withdraw item in the Order submenu of the Action menu or in the table's popup menu.

Withdraw All Own Orders
To withdraw all own orders open one of the following tables: Orders or Orders by Security and then select
the Withdraw All Own item in the Order submenu of the Action menu or in the table's popup menu.

Confirm the orders withdrawal. Confirmation can be disabled in the program options.

Withdraw All Orders of the Firm
To withdraw all orders of the own firm open one of the following tables: Orders or Orders by Security and
then select the Withdraw All item in the Order submenu of the Action menu.

Confirm the orders withdrawal. These way of withdrawal cannot be disabled.

Orders Table

The Orders table lists all the orders on the order-driven market entered by the users of the firm during the
current trading session.

To open the table do one of the following:

• select the Orders item in the Table menu;

• click the  button on the toolbar.

Double click the row to open quotes table for a chosen security.

Table 8.4. "Orders" table columns description

Column Description
Order number Order ID in the Trading System

Order time The time of the order registration at the Trading System

Status Current order status:

'Act' - active;

'+' - matched;

'-CP' - rejected by counterparty;

'-TS' - rejected by the Trading System;

'-' - withdrawn

'-C' - cancelled by the Trading System;

'-D' - cancelled by the Trading System on user's disconnect (COD)
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Column Description
'Error' - Internal error occured

'Not activated. Lack of collateral' - order was not activated due to
insufficiency of collateral.

Firm ID of the trading firm on whose behalf the order is entered

Period Trading session period at which the order was entered

Security Security ID

Board Trading Board name for the security

Direction Order direction - "Buy / Sell / Sell-Buy / Buy - Sell"

Rate Currency exchange rate

Lots Volume, expressed in lots

Amount Number of securities in the order

Hidden lots Hidden lots

Lots left Volume of unmatched part of an order, expressed in lots

Value Value, expressed in the currency of settlement

Trading account Trading and clearing account identifier

Position code Account ID in the Settlement House

Client code Client code assigned by the broker

Broker reference Additional information entered by the trading firm (usually - [client
code]/[client instruction number])

Order lifetime Time when the order will be automatically withdrawn

Update time Time when the order was updated last time (matched, cancelled)

User ID ID of the user who has entered the order

Type Order type: "limit/market"

Order processing type Append to orderbook, fill or kill, withdraw remainder

Price type Order type option: "allow/not allow price split"

Entry type Price entry type - "at exchange rate/at WA price"

Market-maker Market-maker's order

Amended order number* ID of the order that was replaced by the given order

Board Id* Trading Board Identifier

Commission Amount of commission for the trade, RUB

Currency Currency of the instrument (asset)

External user ID* User ID of the external system user who entered the original order into
that external system.

Firm Id* Firm Identifier

Fixing date* Date of the ME fixing calculation

Security Id* Security Identifier

Settlement code* Settlement code for the trade

Settlement currency* Settlement currency for the security

Settlement date* Negdeal or SWAP first leg settlement date

Settlement organization* Settlement organization for the trade

Signature* Equivalent of a handwritten signature
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Column Description
Updater user ID Identifier of the User who edited or cancelled the order

User Id* Identifier of user who submitted an order

Visible quantity* Volume of unmatched part of an iceberg-order, displayed in
orderbook, expressed in lots

Тип ввода заявки* Order input method (Compliance Id). Possible values:

[empty] – Not filled in / Not defined

M – Manual input

S – As a result of the conditional request (stop-loss order)

R – As a result of the robot algorithm work

A – As a result of the auto-following algorithm

D – Covering a position as a result of an unexecuted Margin Call.

Columns marked with * are hidden by default.

Orders by Security

The Orders by Security table lists all the orders for a particular security on the order-driven market entered
by the users of the firm during the current trading session.

To open the table select a security in the Securities table or open the Orderbook and then select the Orders
by Security in the table's popup menu.

"Orders by Security" table columns description

Table structure is similar to the "Orders" table.

Own Negdeal Orders

Negdeal / OTC Negdeal Entry

In order to send a negotiated deal order to the counterparty do one of the following:

• press the F3 key on the keyboard;

• select the Enter item in the Negdeal submenu of the Action menu;

• select a security in the Securities table and click the  button on the toolbar or select the Enter Negdeal
item in the table's popup menu;

• select one of the previous orders in the Sent Negdeals / OTC Negdeals table and then select the Copy
item in the Negdeal submenu of the Action menu or in the table's popup menu.
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If the Enter Negdeal action was invoked from Securities table then "Board" and "Security" fields will be
already filled-in with the data from the table.

Window background is green for buy orders and red for sell orders.

The submitted order is displayed in the Sent Negdeals / OTC Negdeals table. Once it's matched with a
corresponding trade will appear in the Trades and the Trades by Security tables.

Table 8.5. Elements of the "Enter Negdeal / OTC Negdeal" dialog

Element Description
Buy/Sell tabs at the top Order direction: Buy or Sell.

Board Trading board name. If trading board is not selected than "Security"
list will contain all the available securities on all trading boards.

Security Select the needed security in the drop-down list containing names, IDs
and Check marks.

Use the  icon to toggle between security ID and currency pair
selection modes.

Pair Select the needed currency pair in the drop-down list and then select
trade term in the next drop-down list.
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Element Description

Use the  icon to toggle between security ID and currency pair
selection modes.

Settlement code Settlement code for the trade. When selected the additional
information field "Settlement date" is displayed.

Counterparty Name of the firm the negdeal is addressed to.

Addressee alias Alias of the counterparty firm.

Price Price for one lot of the selected security. In addition to manual price
entry the following options are available:

• up and down arrow buttons to the right of the entry field;

• up and down arrow keys on the keyboard;

• mouse wheel;

• hold "Ctrl" or "Ctrl+Shift" together with one of the above described
methods to increase or decrease the price for 10 or 100 steps
accordingly;

• Press "H", "T" or "M" keys on the keyboard to enter "00", "000" or
"000 000" accordingly.

Click the "?" button located near the "Price" field to show the upper and
lower price limits for the selected security.

* When "Negotiated fixing" is selected in the "Board" drop-down
list and FIX instrument as a security than Price field is cleared and
becomes disabled.

Quantity Number of lots of the selected security. In addition to manual entry the
following options are available:

• up and down arrow buttons to the right of the entry field;

• up and down arrow keys on the keyboard;

• mouse wheel;

• hold "Ctrl" or "Ctrl+Shift" together with one of the above described
methods to increase or decrease the quantity for 10 or 100 steps
accordingly;

• Press "H", "T" or "M" keys on the keyboard to enter "00", "000" or
"000 000" accordingly

• click one of the digit buttons to the right of the Quantity entry field
to replace the Quantity field content with corresponding value. "Ctrl
+Shift" multiplies each button by a thousand. "Ctrl" key modifies
buttons' behavior: quantity will be increased for the corresponding
value instead of being replaced with it.

Lot size Information field: number of securities in one lot.

Value Order value considering price, quantity and lot size.

Firm Firm for the trade. Order entry by clearing member.

Trd. account Trading account for the trade.
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Element Description
Client Client code if the order is submitted on behalf of the client.

Clearing position code Information field: clearing position code related to the selected
Trading Account.

Reference Additional notes (broker reference).

Match ref. Matching reference for counter-orders.

Enter Order Submit the order (requires confirmation). Order Confirmation can be
disabled in the program Options

Comission and Single Limit for the
Order

Click  to calculate commission, SL delta and SL after entry for the
order.

Close Close the dialog.

Repeat Last Repeat previous order specification.

Contents of all drop-down lists on the form may be limited using "Data sets" mechanism.

Complex Negdeal Entry

Complex Negdeal entry dialog provides the ability to send the Negotiated deal order to be concluded
between clearing member and its trading member firm for clearing or to send the Negotiated deal order to
be concluded between Trading Accounts of one firm.

To open the Enter Complex Negdeal dialog select the following commands sequentially in the top menu:
Action > Negdeal > Enter complex.
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Table 8.6. Elements of the "Enter Complex Negdeal" form

Element Description
Buy/Sell tabs at the top Order direction: Buy or Sell.

Board Trading board name. If trading board is not selected than "Security"
list will contain all the available securities on all trading boards.

Security Select the needed security in the drop-down list containing names, IDs
and Check marks.

Use the  icon to toggle between security ID and currency pair
selection modes.

Pair Select the needed currency pair in the drop-down list and then select
trade term in the next drop-down list.

Use the  icon to toggle between security ID and currency pair
selection modes.

Settlement code Settlement code for the trade. When selected the additional
information field "Settlement date" is displayed.

Price Price for one lot of the selected security. In addition to manual price
entry the following options are available:
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Element Description
• up and down arrow buttons to the right of the entry field;

• up and down arrow keys on the keyboard;

• mouse wheel;

• hold "Ctrl" or "Ctrl+Shift" together with one of the above described
methods to increase or decrease the price for 10 or 100 steps
accordingly;

• Press "H", "T" or "M" keys on the keyboard to enter "00", "000" or
"000 000" accordingly.

Click the "?" button located near the "Price" field to show the upper and
lower price limits for the selected security.

Quantity Number of lots of the selected security. In addition to manual entry the
following options are available:

• up and down arrow buttons to the right of the entry field;

• up and down arrow keys on the keyboard;

• mouse wheel;

• hold "Ctrl" or "Ctrl+Shift" together with one of the above described
methods to increase or decrease the quantity for 10 or 100 steps
accordingly;

• Press "H", "T" or "M" keys on the keyboard to enter "00", "000" or
"000 000" accordingly

• click one of the digit buttons to the right of the Quantity entry field
to replace the Quantity field content with corresponding value. "Ctrl
+Shift" multiplies each button by a thousand. "Ctrl" key modifies
buttons' behavior: quantity will be increased for the corresponding
value instead of being replaced with it.

Lot size Information field: number of securities in one lot.

Value Order value considering price, quantity and lot size.

"Buy to account" / "Sell from
account"

Fields are arranged according order direction.

Trd. account Trading account for the trade.

Clearing position code Information field: clearing position code related to the selected
Trading Account.

Client Client code if the order is submitted on behalf of the client.

Reference Additional notes (broker reference).

Firm Name of the counterparty firm which the negdeal is addressed to.

Match ref. Matching reference for counter-orders.

Enter Order Submit the order (requires confirmation). Order Confirmation can be
disabled in the program Options

Close Close the dialog.

Repeat Last Repeat previous order specification.

Contents of all drop-down lists on the form may be limited using "Data sets" mechanism.
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Negdeal SWAP Order Entry

In order to send a negotiated deal SWAP order to the counterparty do one of the following:

• press the F6 key on the keyboard;

• select the Enter SWAP item in the Negdeal / OTC Negdeal  submenu of the Action menu;

• select a SWAP instrument in the Securities table and click the  button on the toolbar or select the Enter
SWAP Negdeal item in the table's popup menu;

• select one of the previous orders in the Sent Negdeals / OTC Negdeals table and then select the Copy
item in the Negdeal / OTC Negdeal  submenu of the Action menu or in the table's popup menu.
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If the Enter Order action was invoked from Securities table then "Board" and "Security" fields will be already
filled-in with the data from the table.

Window background is green for buy orders and red for sell orders.

The submitted order is displayed in the Sent Negdeals / OTC Negdeals table. Once it's matched with a
corresponding trade will appear in the Trades and the Trades by Security tables.

Table 8.7. Elements of the "Enter SWAP Negdeal" dialog

Element Description
Buy/Sell tabs at the top Order direction: Sell/Buy or Buy/Sell.

Board Trading board name. If trading board is not selected than "Security"
list will contain all the available securities on all trading boards.

Security Select the needed security in the drop-down list containing names, IDs
and Check marks.

Use the  icon to toggle between security ID and currency pair
selection modes.

Pair Select the needed currency pair in the drop-down list and then select
trade term in the next drop-down list.

Use the  icon to toggle between security ID and currency pair
selection modes.

Settlement code Settlement code for the trade. When selected the additional
information field "Settlement date" is displayed.

Counterparty Name of the firm the negdeal is addressed to.

Addressee alias Alias of the counterparty firm.

Price Price for one lot of the selected security. In addition to manual price
entry the following options are available:

• up and down arrow buttons to the right of the entry field;

• up and down arrow keys on the keyboard;

• mouse wheel;

• hold "Ctrl" or "Ctrl+Shift" together with one of the above described
methods to increase or decrease the price for 10 or 100 steps
accordingly;

• Press "H", "T" or "M" keys on the keyboard to enter "00", "000" or
"000 000" accordingly.

Click the "?" button located near the "Price" field to show the upper and
lower price limits for the selected security.

Rate, % * Rate for the security expreseed in percent/year.

Rate(CURRENCY), % * Information field: percent rate for the currency.

Please note:

"Price" and "Rate, %" fields are interrelated. When one of these fields
are filled, the other one is filled with the automatically calculated value.
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Element Description
Quantity Number of lots of the selected security. In addition to manual entry the

following options are available:

• up and down arrow buttons to the right of the entry field;

• up and down arrow keys on the keyboard;

• mouse wheel;

• hold "Ctrl" or "Ctrl+Shift" together with one of the above described
methods to increase or decrease the quantity for 10 or 100 steps
accordingly;

• Press "H", "T" or "M" keys on the keyboard to enter "00", "000" or
"000 000" accordingly

• click one of the digit buttons to the right of the Quantity entry field
to replace the Quantity field content with corresponding value. "Ctrl
+Shift" multiplies each button by a thousand. "Ctrl" key modifies
buttons' behavior: quantity will be increased for the corresponding
value instead of being replaced with it.

Lot size Information field: number of securities in one lot.

Value Order value considering price, quantity and lot size.

Firm Firm for the trade. Order entry by clearing member.

Trd. account Trading account for the trade.

Client Client code if the order is submitted on behalf of the client.

Clearing position code Information field: clearing position code related to the selected
Trading Account.

Reference Additional notes (broker reference).

Match ref. Matching reference for counter-orders.

Position changes A set of information fields describing positions changes by base and
settlement currencies.

Enter Order Submit the order (requires confirmation). Order Confirmation can be
disabled in the program Options

Comission and Single Limit for the
Order

Click  to calculate commission, SL delta and SL after entry for the
order.

Close Close the dialog.

Repeat Last Repeat previous order specification.

Contents of all drop-down lists on the form may be limited using "Data sets" mechanism.

Complex Negdeal SWAP Entry

Negdeal SWAP entry dialog provides the ability to send the Negotiated SWAP deal order to be concluded
between clearing member and its trading member for clearing or to send the Negotiated SWAP deal order
to be concluded between Trading Accounts of one firm.

To open the Enter Complex SWAP Negdeal dialog select the following commands sequentially in the top
menu: Action > Negdeal > Enter Complex SWAP.
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Table 8.8. Elements of the "Enter Complex Negdeal SWAP" dialog

Element Description
Buy/Sell tabs at the top Order direction: Sell/Buy or Buy/Sell.

Board Trading board name. If trading board is not selected than "Security"
list will contain all the available securities on all trading boards.

Security Select the needed security in the drop-down list containing names, IDs
and Check marks.

Use the  icon to toggle between security ID and currency pair
selection modes.
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Element Description
Pair Select the needed currency pair in the drop-down list and then select

trade term in the next drop-down list.

Use the  icon to toggle between security ID and currency pair
selection modes.

Settlement code Settlement code for the trade. When selected the additional
information field "Settlement date" is displayed.

Price Price for one lot of the selected security. In addition to manual price
entry the following options are available:

• up and down arrow buttons to the right of the entry field;

• up and down arrow keys on the keyboard;

• mouse wheel;

• hold "Ctrl" or "Ctrl+Shift" together with one of the above described
methods to increase or decrease the price for 10 or 100 steps
accordingly;

• Press "H", "T" or "M" keys on the keyboard to enter "00", "000" or
"000 000" accordingly.

Click the "?" button located near the "Price" field to show the upper and
lower price limits for the selected security.

Quantity Number of lots of the selected security. In addition to manual entry the
following options are available:

• up and down arrow buttons to the right of the entry field;

• up and down arrow keys on the keyboard;

• mouse wheel;

• hold "Ctrl" or "Ctrl+Shift" together with one of the above described
methods to increase or decrease the quantity for 10 or 100 steps
accordingly;

• Press "H", "T" or "M" keys on the keyboard to enter "00", "000" or
"000 000" accordingly

• click one of the digit buttons to the right of the Quantity entry field
to replace the Quantity field content with corresponding value. "Ctrl
+Shift" multiplies each button by a thousand. "Ctrl" key modifies
buttons' behavior: quantity will be increased for the corresponding
value instead of being replaced with it.

Lot size Information field: number of securities in one lot.

Value Order value considering price, quantity and lot size.

Rate, % * Rate for the security expreseed in percent/year.

Rate(CURRENCY), % * Information field: percent rate for the currency.

Please note:

"Price" and "Rate, %" fields are interrelated. When one of these fields
are filled, the other one is filled with the automatically calculated value.
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Element Description
"Buy to account" / "Sell from
account"

Fields are arranged according order direction.

Trd. account Trading account for the trade.

Clearing position code Information field: clearing position code related to the selected
Trading Account.

Client Client code if the order is submitted on behalf of the client.

Reference Additional notes (broker reference).

Firm Name of the counterparty firm the negdeal is addressed to.

Match ref. Matching reference for counter-orders.

Position changes A set of information fields describing positions changes by base and
settlement currencies.

Enter Order Submit the order (requires confirmation). Order Confirmation can be
disabled in the program Options

Close Close the dialog.

Repeat Last Repeat previous order specification.

Contents of all drop-down lists on the form may be limited using "Data sets" mechanism.

Editing Sent Negdeal Orders

To change a negdeal order which hasn't been accepted by the counterparty yet, select it in the Sent
Negdeals / OTC Negdeals table and do one of the following:

• select the Edit item in the Negdeal / OTC Negdeal  submenu of the Action menu or in the table's popup
menu;

• press the  button on the toolbar;

"Edit Order" is similar to the Order Entry form. Window title contains order number in the Trading System.

During editing the order is withdrawn from the Trading System queue. Click Enter Order to submit
modified order. Click Restore button to submit the original order and close the dialog. It also can be done
by pressing Escape key. Click Close to leave the order withdrawn.

Entering the modified order is similar to withdrawing original and submitting a new one - order loses its
position in the Trading System orders queue and moves to the end of the queue.

Negdeal Order Withdrawal

Withdraw Particular Orders

To withdraw a negdeal order which hasn't been accepted by the counterparty yet, first select an order in
the Sent Negdeals / OTC Negdeals table and then do one of the following:

• select the Withdraw item in the Negdeal / OTC Negdeal  submenu of the Action main menu;

• click the  button on the toolbar;

• press the Del key on the keyboard;

• select the Withdraw item in the table's popup menu.

Withdraw all orders of the firm



Working with Orders 19.09.2025

87

To withdraw all the negdeal orders of the firm that haven't been accepted by counterparties, open the
Sent Negdeals / OTC Negdeals table and then select the Withdraw All item in the Negdeal / OTC Negdeal
submenu of the Action menu.

Withdraw all own orders

To withdraw all the own negdeal orders that haven't been accepted by counterparties, open the Sent
Negdeals / OTC Negdeals table and then select the Withdraw All Own item in the Negdeal / OTC Negdeal
submenu of the Action menu or in the table's popup menu.

Withdraw orders by condition

To withdraw orders by some condition open the Sent Negdeals / OTC Negdeals and then select the
Withdraw by Condition item in the Negdeal / OTC Negdeal  submenu of the Action menu or in the table's
popup menu.

The dialog box contains fields which can be optionally filled-in to withdraw all the orders that match the
given parameters.

Table 8.9. Elements of the "Withdraw Orders by Condition" dialog

Element Description
Buy/Sell Direction of orders to be withdrawn.

Board Trading board to withdraw orders on. Double-click
this field to open the Datasets dialog.

Security Select the security to withdraw orders for this
particular instrument. Double-click this field to open
the "Edit Datasets" dialog for securities.

Firm Information field: Firm name.

Trader ID of the user who has submitted the order. By
default this field contains ID of user who opened
the "Withdrar Orders" dialog. To withdraw orders of
all users of the firm, clear the field using Delete or
Backspace key.

Price Exact price value and condition:

= -withdraw orders with exact price specified;

< -withdraw orders with price less than specified;

> -withdraw orders with price greater than specified.

Trading account Withdraw orders submitted with the particular
Trading Account.

Client Withdraw orders submitted with the particular Client
Code.

Withdraw buy and sell orders Withdraw both Buy and Sell orders.

Click Withdraw Orders to proceed to withdrawal confirmation dialog. Order Confirmation can be disabled
in the program Options.

Partners

To form a partners list that might be used while Negdeal or Negdeal SWAP enter, select the Partners item
in the Administration submenu of the Action menu.
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Table 8.10. Elements of the "Partners" dialog

Element Description
Board Specify the board for which the list of partners is used.

Available Firms available to be added as partners.

Select Add selected available columns to the list of partners.

Remove Remove selected columns from the list.

Selected Current list.

Close Save the list and close dialog.

Sent Negdeals / OTC Negdeals Table

The Sent Negdeals / OTC Negdeals table lists all the negotiated deal orders that have been send by the
firm users since the beginning of the trading session.

To open this table do one of the following:

• select the Sent Negdeals / OTC Negdeals item in the Table menu;

• click the  button on the toolbar.

Table 8.11. "Sent Negdeals" table columns description

Column Description
Order No. Negotiated deal order number (ID) in the Trading System

Time Time when the negdeal order was registered by the Trading System
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Column Description
Status Current negdeal order status:

'Act' - active;

'+' - matched;

'-CP' - rejected by counterparty;

'-TS' - rejected by the Trading System;

'-' - withdrawn

'-C' - cancelled by the Trading System;

'-D' - cancelled by the Trading System on user's disconnect (COD)

'Error' - Internal error occured

'Not activated. Lack of collateral' - order was not activated due to
insufficiency of collateral.

Firm Firm on which behalf the order was entered

Security Security identifier

Board Trading Board name for the security

Direction Order direction - "Buy / Sell / Sell-Buy / Buy - Sell"

Rate Currency exchange rate

Base price Base price could be specified for SWAP negdeals

Lots Volume, expressed in lots

Amount Amount of the order (securities) considering lot size

Lots left Volume of unmatched part of an order, expressed in lots

Value Value, expressed in the currency of settlement

Trading account Trading account from which the order was entered

Position code Account ID in the Settlement House

Client code Short client code which was indicated when entering the trade

Broker reference Additional information entered by the trading firm (usually - [client
code]/[client instruction number])

Update time Time when the order was updated last time (matched, cancelled)

Counterparty Firm the order is addressed to

Matching reference Identical text value entered by both trade sides

User ID Trader who entered the order

Settlement code Settlement code for the trade

Settlement date Negdeal or SWAP first leg settlement date

Swap rate, % SWAP instrument rate, % per year

Board Id* Trading Board Identifier

Commission* Amount of commission for the trade, RUB

Cpty. Id* Counterparty Id in the Trading System

Currency* Currency of the instrument (asset)
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Column Description
External user ID* A reference field which may be used as a back-feed by an external

system. May contain, for example, a user ID of the external system user
who entered the original order into that external system.

Firm Id* Firm identifier

Fixing date* Date of the MOEX fixing calculation

Period* Trading session period in which the order was entered

Security Id Security Identifier*

Settlement currency* Settlement currency for the instrument

Settlement organization* Settlement organization for the trade

User Id* ID of the user who submitted the order

Columns marked with * are hidden by default.

Received Negdeal Orders

Accepting the Received Negdeal Orders

To accept a received negdeal order select it in the Received Negdeals table and then do one of the following:

• select the Accept item in the Received Negdeals submenu of the Action menu or in the table's popup
menu;

• double click the row in the table;

• click the  button on the toolbar;

When the dialog box opens (similar to the Enter Negdeal / OTC Negdeal dialog) provide, if needed, client
code and reference and press the Enter Order button.

Editing the Received Negdeal Orders

To edit a received negdeal order and to send it back to the counterparty, select an order in the Received
Negdeals table and do one of the following:

• select the Edit item in the Received Negdeals submenu of the Action menu or in the table's popup menu;

• click the  button on the toolbar;

"Edit Order" is similar to the Order Entry form. Window title contains order number in the Trading System.

During editing the order is withdrawn from the Trading System queue. Click Enter Order to submit
modified order. Click Restore button to submit the original order and close the dialog. It also can be done
by pressing Escape key. Click Close to leave the order withdrawn.

Entering the modified order is similar to withdrawing original and submitting a new one - order loses its
position in the Trading System orders queue and moves to the end of the queue.

Rejecting the Received Negdeal Orders

Rejecting particular orders

To reject a received negdeal orders, select it in the Received Negdeals table and then do one of the following:
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• press the Del key on the keyboard;

• select the Reject item in the Received Negdeals submenu of the Action menu or in the table's popup
menu;

• click the  button on the toolbar.

Rejecting All the Received Negdeal Orders

To reject all the received negdeal orders, open the Received Negdeals table and then select the Reject All
item in the Received Negdeals submenu of the Action menu or in the table's popup menu.

Rejecting Negdeal Orders by Condition

To reject the received negdeal orders by certain condition, open the Received Negdeals table and then
select the Reject All item in the Received Negdeals submenu of the Action menu or in the table's popup
menu.

The dialog box contains fields which can be optionally filled-in to withdraw all the orders that match the
given parameters.

Table 8.12. Elements of the "Reject Negdeals by Condition" dialog

Element Description
Buy/Sell Direction of received negdeals to be rejected.

Board Trading board to reject received negdeals on.
Double-click this field to open the Datasets dialog.

Security Select the security to reject negdeals for this
particular instrument. Double-click this field to open
the "Edit Datasets" dialog for securities.

Trader Reject negdeals addressed to selected Trader

Counterparty Reject negdeals submitted by selected
counterparty.

Reject buy and sell orders Reject both Buy and Sell orders.

Received Negdeals Table

The Received Negdeals table lists all the negotiated deal orders received by the firm from counterparties
since the beginning of the trading session that haven't been accepted yet.

To open the table do one of the following:

• select the Received Negdeals item in the Table menu;

• click the  button on the toolbar.

Table 8.13. "Received Negdeals" table columns description

Column Description
Order No. Negotiated deal order number (ID) in the Trading System

Time The time of the trade registration by the Trading System

Status Status of the received negdeal order

Security Security ID
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Column Description
Board Trading Board name for the security

Direction Order direction - "Buy / Sell / Sell-Buy / Buy - Sell"

Rate Currency exchange rate

Base price Base price could be specified for SWAP negdeals

Lots Volume, expressed in lots

Amount Amount of the order (securities) considering lot size

Lots left Volume of unmatched part of an order, expressed in lots

Value Value, expressed in the currency of settlement

Counterparty Firm from which the negdeal order was received

Matching reference Identical text value entered by both trade sides

Settlement code Settlement code for the trade

Settlement date Negdeal or SWAP first leg settlement date

Swap rate, % SWAP instrument rate, % per year

Board Id* Trading Board Identifier

Commission Amount of commission for the trade, RUB

Cpty. Id* Counterparty Id in the Trading System

Currency* Currency of the instrument (asset)

Firm* Firm on which behalf the order was entered

Firm Id* Firm Identifier

Fixing date* Date of the MOEX fixing calculation

Period* Trading session period in which the order was entered

Security Id Security Identifier

Settlement currency* Settlement currency for the security

Trading account* Trading account from which the order was entered

User ID* ID of the user who submitted the order

Columns marked with * are hidden by default.

Transfer orders

Transfer Order Entry

Transfer Orders can be used to perform money transfers between own accounts during the trading session.

To open the Transfer Order Entry dialog perform one of the following actions:

• Select the following commands sequentially in the top menu: Action > Transfer Order > Enter.

• Open the context menu of Transfers table and then click Enter

"Order Packet" entry form can be used to submit multiple transfer orders simultaneously.

Transfer Order accepted by the Trading System will appear in the "Transfer Orders" table. Details on
successfully executed transfer will appear in the "Transfers" table.
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Table 8.14. Elements of the "Enter Transfer Order" dialog

Element Description
Board Name of the trading board or technical board to perform the transfer.

Security Security (currency) name.

Value Transfer value in units of currency.

Transfer available amount, but no
more than the specified one

Set the flag to transfer all the available amount in case the available
amount is less then value specified. Leave the checkbox empty to get
the the error message in such case.

Normal transfer, do not check
Single Limit

Set the flag to disable Single Limit verification.

Normal transfer, do not check any
limits

Set the flag to disable any limits verification.

Withdraw from / Assign to • Trd. account - trading account identifier to withdraw from / assign
to.

Clearing position code - information field: clearing position code
related to the selected Trading Account.

• Client - Client code if the order is submitted on behalf of the client.

• Reference - Additional notes (broker reference).

Enter Order Submit the order (requires confirmation). Order Confirmation can be
disabled in the program Options

Close Close the dialog.
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Element Description
Repeat Last Repeat previous order specification.

Transfer to Trading Member Entry

Transfers to Partner let Clearing member to transfer collateral to/from the counterparty Trading Member's
position code.

To open the "Transfer to Partner" dialog perform one of the following actions:

• Select the following commands sequentially in the top menu: Action > Transfer Order > Enter to trading
member.

• Open the context menu of Transfers table and then click Enter to trading member

"Order Packet" entry form can be used to submit multiple transfer orders simultaneously.

Transfer Order accepted by the Trading System will appear in the "Transfer Orders" table. Details on
successfully executed transfer will appear in the "Transfers" table.

Table 8.15. Elements of the "Enter Transfer to trading member" dialog

Element Description
Buy/Sell tabs at the top Transfer direction: Buy or Sell.

Board Name of the trading board or technical board to perform the transfer.

Security Security (currency) name.

Value Transfer value in units of currency.

Transfer available amount, but no
more than the specified one

Set the flag to transfer all the available amount in case the available
amount is less then value specified. Leave the checkbox empty to get
the the error message in such case.
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Element Description
Normal transfer, do not check
Single Limit

Set the flag to disable Single Limit verification.

Normal transfer, do not check any
limits

Set the flag to disable any limits verification.

Do not check Single Limit
in clearing/trading member
segregation scheme

Set the flag to cancel SL check.

Assign to / Withdraw from • Trading member - name of the trading member firm.

• Trd. account - trading account identifier to withdraw from / assign
to.

Clearing position code - information field: clearing position code
related to the selected Trading Account.

• Client - Client code if the order is submitted on behalf of the client.

• Reference - Additional notes (broker reference).

Enter Order Submit the order (requires confirmation). Order Confirmation can be
disabled in the program Options

Close Close the dialog.

Transfer Orders table

"Transfer Orders" table lists all the orders for transfers between own accounts.

To open the table select the following commands sequentially in the top menu: Table > Firm Tables >
Transfer Orders.

Table 8.16. "Transfer Orders" table columns description

Column Description
Order number Order ID in the Trading System

Order time Order registration time

Status Current transfer order status:

'Act' - active;

'+' - matched;

'-CP' - rejected by counterparty;

'-TS' - rejected by the Trading System;

'-' - withdrawn

'-C' - cancelled by the Trading System;

'-D' - cancelled by the Trading System on user's disconnect (COD)

'Error' - Internal error occured

'Not activated. Lack of collateral' - order was not activated due to
insufficiency of collateral.

Firm Trading firm on whose behalf the order is submitted
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Column Description
Security Security ID

Board Board name

D/W Order direction - "deposit to account / withdraw from account"

Lots Volume, expressed in lots

Trading account Trading account number

Position code Bank Account identifier

Matching reference Matching reference text

Client code Client code assigned by the broker

Broker reference Additional information entered by the trading firm (usually - [client
code]/[client instruction number])

Counterparty Counterparty firm ID

Withdrawal time Withdrawal time

User ID ID of the user who has entered the order

Transfer details Additional information

Board Id* Trading Board Identifier

Cpty. Id* Counterparty Identifier

External user ID* A reference field which may be used as a back-feed by an external
system. May contain, for example, a user ID of the external system user
who entered the original order into that external system.

Firm Id* A reference field which may be used as a back-feed by an external
system. May contain, for example, a user ID of the external system user
who entered the original order into that external system.

Security Id* Security Identifier

Settlement currency* Settlement currency for the instrument

Settlement organization* Settlement organization

User Id* User Identifier

Columns marked with * are hidden by default.

Transfers table
"Transfers" table lists all successfully executed transfers between own accounts and between firm and
partners.

To open the table select the following commands sequentially in the top menu: Table > Firm Tables >
Transfers.

Table 8.17. "Transfers" table columns description

Column Description
Transfer # Number of the transfer

Time The time of the trade registration by the Trading System

Order number Number of order which led to the trade conclusion

Firm Firm name

Security Security ID

Board Board name for the security

C/D Credit/Debit
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Column Description
Lots Volume, expressed in lots

Value Transfer value, expressed in currency of settlement

Trading account Trading and clearing account identifier

Position code Position code

Client code Client code assigned by Broker

Broker reference Additional information entered by the trading firm (usually - [client
code]/[client instruction number])

User ID ID of the user who concluded the trade

Counterparty Counterparty Firm ID

Transfer details Additional information on transfer

Type of Transfer "Tran" type digit code

Amount* Amount of asset in the transfer

Board Id* Trading Board Identifier

Clearing commission* Amount of commission fee for clearing, RUB

Clearing firm* Firm Id of Clearing Member

Clearing position code* Clearing Account ID in the Clearing Centre

Counterparty order number* Number of the order submitted by counterparty

Cpty. Id* Counterparty identifier

Currency* Currency of the instrument (asset)

Exchange commission* Amount of Exchange commission fee, RUB

External user ID* A reference field which may be used as a back-feed by an external
system. May contain, for example, a user ID of the external system user
who entered the original order into that external system.

Firm Id* Firm identifier

Fixing date* Date of the ME fixing calculation

Period* Period of the trading session when the trade was concluded

Security Id Security Identifier

Settlement code* Settlement code for the trade

Settlement currency* Settlement currency for the instrument

Settlement date* Date of the settlement

Settlement organization* Settlement organization for the trade (transfer)

Status* Status of the transfer

'+' - matched/confirmed (included into off-line settlement)

'Unsettled' - No settlement instruction has been sent yet

'Waiting' - included into settlement instruction;

'-C' - cancelled by the Tradin

System reference* Additional information

Technical access commission* Amount of commission for Technical access, RUB

Total commission* Total amount of commission, RUB

Trade date* Trade date



Working with Orders 19.09.2025

98

Column Description
User Id* User Identifier

Columns marked with * are hidden by default.

Batch Order Entry

Creating an Order Packet

To open the dialog to create, edit or submit the order packet, select the Enter Packet item in the Action
menu or press the Ctrl+F2 hotkeys.

Tabs on the top of the dialog let user switch between different types of orders: Order, SWAP Order, Negdeal,
SWAP Negdeal, Transfer to Trading Member. All buttons of the dialog window affect orders of the selected
type only.

Table 8.18. Elements of the "Enter Packet" dialog:

Button Description
Add Open an order entry dialog that corresponds to

active window tab: Order, SWAP Order, Negdeal,
SWAP Negdeal, Transfer to Partner.

Edit Open "Edit Order" dialog for corresponding order
type.

Delete Delete selected orders from the list.

Clear Clear the order list.

Load Load packet from file. Supported file formats are
CSV (separator symbol depends on OS settings and
locale), TXT (tab-separated) and files compatible
with CMA terminals.
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Button Description
Save Save order packet to file. Supported file formats are

CSV (separator symbol depends on OS settings and
locale) and TXT (tab-separated).

Enter Whole Packet Submit all the orders on active window tab.

This action requires an additional confirmation in the
dialog.

The confirmation dialog contains counters for total
orders processed ("Done"), succesfully registered
orders ("Registered") and Errors.

The following orders execution options are available
via confirmation dialog:

• Delete orders from the list after successfull
execution;

• Execute sucessfully executed orders again;

• Validate orders parameters;

• Require orders entry confirmation;

• Show successful execution results;

Click "Enter" to start the order entry process.

Enter Selected Orders Submit orders selected on the active window tab.

The confirmation dialog is similar to "Enter Whole
Packet" confirmation.

Close Close dialog window. The packet contents is stored
until the end of the session.

Double-click one of the table rows to edit the particular order.

"Shift" and "Ctrl" buttons can be used to select multiple orders. Use "Ctrl + A" combination to select all the
orders in the table.

"Enter packet" confirmation form

To confirm packet enter, open the Enter packet form, then create a list of orders and press the Enter whole
packet button or the Enter selected orders button.

Table 8.19. Elements of the "Enter packet" confirmation form

Element Description
Processed orders counter Contains counters for total orders processed ("Done"), successfully

registered orders ("Registered") and Errors.

Delete from the list after
successful execution

If this flag is set up, every order successfully registered by the trading
system will be deleted from the list.

Execute again successfully
executed

If this flag is set up and order packet have orders with "Success" status,
these orders will be sent to the trading system again during the packet
enter.

Validate parameters To control parameters set up on the order validation form.
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Element Description
Require entry confirmation If this flag is set up, every order from the packet will be sent to the

trading system after manual confirmation in the dialog.

Show successful execution results Show successful execution results in the dialog.

Click "Enter" to start the order entry process.

Adding Existing Orders to the Packet

To copy all the orders with a particular security to the packet do the following:

1. open the Orders or the Sent Negdeals / OTC Negdeals table and select any order with a security of
interest;

2. press the Shift+Ctrl+F2 hotkey or select the Save to Order Packet item in the Action menu or in the
table's popup menu;

3. in the dialog box select whether to save order to the packet or to the file which can be later loaded into
the packet.

Batch Order Acceptance

In order to create a packet of counterorders to the received negotiated deal orders, open the Recieved
Negdeals table and the select the Accept Order Packet in the table's popup menu. A packet of
counterorders can be created for one board only.

This packet can be either added to the active packet or saved to a file to be loaded later.

Dual Order Entry Dialogs

On the Adv.Actions tab of the program options it is possible to set up the "Dual order dialogs" in order for all
the order entry dialogs to have two frames to enter both buy and sell orders simultaneously. It would also
become possible to set a corresponding flag at order entry time in order to withdraw active orders.
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Chapter 9. Algorithmic trading

The Algorithmic Orders Module (algo-module) is implemented to form a packet of linked orders that are
entered into the Trading System at the due time. Time intervals are calculated by the user's specified
algorithm.

Activation and establishing the connection

To activate Algo-trading menu and establish the connection to the service of Algorithmic trading open the
Tools > Options menu, then proceed to the Connection and then to the Algo-trading service tab, and set
the Connect enabled flag.

Table 9.1. Elements of the "Algo-trading service" tab

Element Description
Connect enabled Set the "Connect enabled" flag to activate Algo-trading menu and

establish the connection to the service of Algorithmic trading.

Direct connection via TSMR:

Broadcast List of networks addresses (bridges) where searching for available
access servers (gateways) will be performed.

Server Algo-trading server identifier. Note: this field is case-sensitive.

Service Algo-trading TCP and UDP services name.

Preferred gateway (network)
address

Address of the Algo-trading service network (bridge) where search for
available access servers (gateways) will be performed first.

Internet connection:

Host list List of access servers (gateways) for connecting to the Algo-trading
service.

Server ID Algo-trading server identifier. Note: this field is case-sensitive.

Request connection confirmation Additional confirmation required for Internet connection.

To reset all changes which was made on form use Cancel button.
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TWAP Entry

To submit an algorithmic TWAP (Time Weighted Average Price) order packet to trading system, do one
of the following:

• select the Enter TWAP item in the Algo-trading menu of the main menu;

• select the Enter TWAP item in the popup menu of the "Orderbook" table;

• select one of the previous orders in the "Order Algo-packets", then select the Enter TWAP item in the
Algo-trading menu of the main menu or the table's popup menu.

If the Enter Order action was invoked from Securities table then "Board" and "Security" fields will be already
filled-in with the data from the table.

Window background is green for buy orders and red for sell orders.

The submitted order is displayed in the "Order Algo-packets" table. Linked orders of the algo-packet are
displayed in the "Order Algo-packet Iterations" table.

"Enter TWAP Order Algo-packet" dialog features
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• "Buy" and "Sell" tabs at the top of the window to change order direction. Press Ctrl+Tab to quickly switch
to another tab.

• Best Bid and Offer rates as well as Last trade price are displayed to the right of the "Limit price" field.
Click one of these rates to fill the "Limit price" field with the same value.

• Click the "?" button located near the "Limit price" field to show the upper and lower price limits for the
selected security.

• Order volume can be quickly set up by clicking 1K, 10K, 50K, 100K, 500K or 1M to the right of the "Total
quantity" field. Ctrl-click one of these buttons to increase the number of lots accordingly. Shift-click to
increase the number of lots 1000 times.

• "Value" field is located on the bottom of the order specification area. Its content changes accordingly to
the content of "Limit price" and "Total quantity" fields. Enter the desired order value and click " -> qty"
button to calculate and fill the "Quantity" field with appropriate number of lots to reach the desired order
value on the price specified.

Table 9.2. Elements of the "Enter TWAP Order Algo-packet"

Element Description
Buy/Sell tabs at the top Order direction: Buy or Sell.



Algorithmic trading 19.09.2025

105

Element Description
Board Trading board name. If trading board is not selected than "Security"

list will contain all the available securities on all trading boards.

Security Select the needed security in the drop-down list containing names, IDs
and Check marks.

Price Price for one lot of the selected security. In addition to manual price
entry the following options are available:

• up and down arrow buttons to the right of the entry field;

• up and down arrow keys on the keyboard;

• mouse wheel;

• hold "Ctrl" or "Ctrl+Shift" together with one of the above described
methods to increase or decrease the price for 10 or 100 steps
accordingly;

• Press "H", "T" or "M" keys on the keyboard to enter "00", "000" or
"000 000" accordingly.

Click the "?" button located near the "Limit price" field to show the
upper and lower price limits for the selected security.

Total quantity Total number of lots of the selected security to BUY/SELL during the
algorithm work time. In addition to manual entry the following options
are available:

• up and down arrow buttons to the right of the entry field;

• up and down arrow keys on the keyboard;

• mouse wheel;

• hold "Ctrl" or "Ctrl+Shift" together with one of the above described
methods to increase or decrease the quantity for 10 or 100 steps
accordingly;

• Press "H", "T" or "M" keys on the keyboard to enter "00", "000" or
"000 000" accordingly

• click one of the digit buttons to the right of the Quantity entry field
to replace the Quantity field content with corresponding value. "Ctrl
+Shift" multiplies each button by a thousand. "Ctrl" key modifies
buttons' behavior: quantity will be increased for the corresponding
value instead of being replaced with it.

Lot size Information field: number of securities in one lot.

Value Information field: order value considering price, quantity and lot size.

Value Enter the desired order value and click " -> qty" button to calculate and
fill the "Quantity" field with appropriate number of lots to reach the
desired order value on the price specified.

Currency Information field: settlement currency for the selected security.

Linked orders Limit – BUY/SELL linked orders are fulfilled at the price not higher/
lower than price that was specified.

Market – linked orders are fulfilled at the current best prices. "Limit
Price", "Price shift type", "Price shift value".
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Element Description
Price shift type - select the desired shift from the current best bid/ask
price type (percent or money value) in the drop-down list.

Price shift value - enter the acceptable value of the linked orders price
shift, as percent or as terms of currency.

Algorithm work time Set the algorithm start and end time:

From: algorithm start time;

From current time - click on the checkbox to set algorithm start time
from the current time; the "From:" field is disabled;

To: algorithm end time.

Interval parameters select one of the timing methods from the drop-down list. Set the
desired parameter in the next field accordingly:

Number of orders – select this parameter to set the number of
iterations for which it is required to fulfill total quantity of algo-packet.

Time between orders - select this parameter to split the algorithm
work time into N iterations. Set the time interval to be keep for linked
orders.

Randomization coefficient Use the slider with step 0,1 and boundary values from 0 to 1 to set the
random time and volume shift. Value of 1 on the slider corresponds to
maximum allowable random shift = 50%, value of 0 corresponds to
equal distribution of linked orders among time intervals and volume.

Firm Firm for trades. Order entry by clearing member.

Trd. account Trading account for trades.

Client Client code if the algo-packet is submitted on behalf of the client.

Clearing position code Information field: clearing position code related to the selected
Trading Account.

Reference Additional notes (broker reference).

Enter Order Submit the algo-packet of linked orders (requires confirmation). Order
Confirmation can be disabled in the program Options

Close Close the dialog.

Repeat Last Repeat previous order specification.

Contents of all drop-down lists on the form may be limited using "Data sets" mechanism.

SWAP TWAP entry
To submit a SWAP TWAP algorithmic order on the order-driven market do one of the following:

• select the Enter SWAP TWAP item in the Algo-trading menu of the main menu;

• select the Enter TWAP Order Algo-packet item in the "Orderbook" table's popup menu for the required
SWAP security;

• select one of the previous algo-packets from "Order Algo-packets" table and then select the Enter SWAP
TWAP item in the table's popup menu.

If the Enter SWAP Order action was invoked from Securities table then "Board" and "Security" fields will be
already filled-in with the data from the table.

Window background is green for sell/buy orders and red for buy/sell orders.
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The submitted order is displayed in the "Order Algo-packets" table. inked orders of the algo-packet are
displayed in the "Order Algo-packet Iterations" table.

"Enter SWAP TWAP Order Algo-packet" dialog features

• "Buy" and "Sell" tabs at the top of the window to change order direction. Press Ctrl+Tab to quickly switch
to another tab.

• Best Bid and Offer rates as well as Last trade price are displayed to the right of the "Limit price" field.
Click one of these rates to fill the "Limit price" field with the same value.

• Click the "?" button located near the "Limit price" field to show the upper and lower price limits for the
selected security.
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• Order volume can be quickly set up by clicking 100K, 1M, 5M, 10M, 50M or 1B to the right of the "Quantity"
field. Ctrl-click one of these buttons to increase the number of lots accordingly. Shift-click to increase
the number of lots 1000 times.

Table 9.3. Elements of the "Enter SWAP TWAP Order Algo-packet"

Element Description
Buy/Sell tabs at the top Order direction: Buy or Sell.

Board Trading board name. If trading board is not selected than "Security"
list will contain all the available securities on all trading boards.

Security Select the needed security in the drop-down list containing names, IDs
and Check marks.

Limit price Maximum price for one lot of the selected security. In addition to
manual price entry the following options are available:

• up and down arrow buttons to the right of the entry field;

• up and down arrow keys on the keyboard;

• mouse wheel;

• hold "Ctrl" or "Ctrl+Shift" together with one of the above described
methods to increase or decrease the price for 10 or 100 steps
accordingly;

• Press "H", "T" or "M" keys on the keyboard to enter "00", "000" or
"000 000" accordingly.

Click the "?" button located near the "Limit price" field to show the
upper and lower price limits for the selected security.

Rate, % * Rate for the security expreseed in percent/year.

Rate(CURRENCY), % * Information field: percent rate for the currency.

* Remark:

"Total price" and "Rate, %" fields are interconnected. If one of them is
filled the another one will be filled automatically.

Total quantity Number of lots of the selected security to fulfill during the algorithm
work time. In addition to manual entry the following options are
available:

• up and down arrow buttons to the right of the entry field;

• up and down arrow keys on the keyboard;

• mouse wheel;

• hold "Ctrl" or "Ctrl+Shift" together with one of the above described
methods to increase or decrease the quantity for 10 or 100 steps
accordingly;

• Press "H", "T" or "M" keys on the keyboard to enter "00", "000" or
"000 000" accordingly

• click one of the digit buttons to the right of the Quantity entry field
to replace the Quantity field content with corresponding value. "Ctrl
+Shift" multiplies each button by a thousand. "Ctrl" key modifies
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Element Description
buttons' behavior: quantity will be increased for the corresponding
value instead of being replaced with it.

Lot size Information field: number of securities in one lot.

Value Total algo-packet value considering price, quantity and lot size.

Linked orders Limit is for BUY/SELL linked orders are fulfilled at the price not higher/
lower than price that was specified.

Market is disabled for SWAP orders algo-packets.

Price shift type - select the desired shift from the current best bid/ask
price type (percent or money value) in the drop-down list.

Price shift value - enter the acceptable value of the linked orders price
shift, as percent or as terms of currency.

Algorithm work time Set the algorithm start and end time:

From: algorithm start time;

From current time - click on the checkbox to set algorithm start time
from the current time; the "From:" field is disabled;

To: algorithm end time.

Interval parameters select one of the timing methods from the drop-down list. Set the
desired parameter in the next field accordingly:

Number of orders – select this parameter to set the number of
iterations for which it is required to fulfill total quantity of algo-packet.

Time between orders - select this parameter to split the algorithm
work time into N iterations. Set the time interval to be keep for linked
orders.

Randomization coefficient Use the slider with step 0,1 and boundary values from 0 to 1 to set the
random time and volume shift. Value of 1 on the slider corresponds to
maximum allowable random shift = 50%, value of 0 corresponds to
equal distribution of linked orders among time intervals and volume.

Firm Firm for trades. Order entry by clearing member.

Trd. account Trading account for trades.

Client Client code if the algo-packet is submitted on behalf of the client.

Clearing position code Information field: clearing position code related to the selected
Trading Account.

Reference Additional notes (broker reference).

Position changes A set of information fields describing positions changes by base and
settlement currencies.

Enter Order Submit the order (requires confirmation). Order Confirmation can be
disabled in the program Options

Close Close the dialog.

Repeat Last Repeat previous algo-packet specification.

Contents of all drop-down lists on the form may be limited using "Data sets" mechanism.
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Orders volume control at TWAP algorithmic module

Algorithmic packet entered the algorithmic trading module will be checked by an algo-packet total quantity
and by quantity of every iteration order associated with an algo-packet. Control under operational errors is
applied under both market and limit order types.

Restritions and warnings described below are applied for both "Enter TWAP Order Algo-packet" dialog and
"Enter SWAP TWAP Order Algo-packet" dialog.

• If the full quantity of the algorithmic order packet is more than 1,000,000 lots, the terminal will display
warning message and will prompt to confirm algo-packet entering.

• If quantity calculated for any of iteration orders of algorithmic packet is more than:

- 1000 lots, the terminal will display informational message.

- 10,000 lots, the entire algo-packet will be withdrawn by the system and error message will be displayed.
User will be prompted change parameters of the algo-packet and re-enter it.

Editing Algorithmic orders

To edit an algo-packet of linked orders that hasn't been fully matched yet, select an algo-packet in the
"Order Algo-packets" table and then do one of tthe following:

• select the Edit item in the Algo-trading menu of the main menu;

• select the Edit item in the "Order Algo-packets" table's popup menu.

During editing all the unmatched linked orders are withdrawn from the Trading System queue. Click Enter
Order to submit modified algo-packet of linked orders. Click Restore button to submit the original packet
of linked orders and close the dialog. It also can be done by pressing Escape key. Click Close to leave the
order withdrawn.

Entering the modified algo-packet is similar to withdrawing original and submitting a new one - linked orders
lose them positions in the Trading System order queue and moves to the end of the queue.

Elements of the "Change TWAP Order Algo-packet"

"Change TWAP Order Algo-packet" dialog is similar to "Enter TWAP Order Algo-packet". The following
fields are unavailable for edits:

• Board

• Security

Click "Restore" to discard all the changes and restore packet of linked orders.

Withdraw Particular Order Algo-packets

To withdraw one or several own algo-packets follow these steps:

1. Select algo-packets in the Order Algo-packets table.

Hold Ctrl button to select several algo-packets and Shift to select a range of rows.

2. Do one of the following:

• select the Withdraw item in the Algo-trading menu;

• press the Del key on the keyboard;
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• select the Withdraw item in the table's popup menu.

3. Confirm the order(s) withdrawal. Confirmation can be disabled in the program options.

Withdraw All Own Order Algo-packets

To withdraw all own pack of linked orders open one of the following tables: Order Algo-packets and then
select the Withdraw All Own item in the Algo-trading menu or in the table's popup menu.

Confirm the orders withdrawal. Confirmation can be disabled in the program options.

Withdraw All Order Algo-packets of the Firm

To withdraw all order algo-packets of the own firm open one of the following tables: Order Algo-packets
and then select the Withdraw All item in the Algo-trading menu.

Confirm the orders withdrawal. These way of withdrawal cannot be disabled.

Order Algo-packets

The "Order Algo-packets" table lists all the algorithmic packets of linked orders entered by the users of the
firm during the current trading session.

To open the "Order Algo-packets" table, select the Order Algo-packets item in the Algo-trading menu of
the main menu.

Double click the row to open order algo-packet iterations table for a chosen order.

Table 9.4. "Order Algo-Packets" table columns description

Column Description
Order # Algo-order ID in the Algorithmic Module

Order time Algo-order registration time in the Algorithmic Module

Status Status of a linked order

Firm Firm ID

Algorithm Algorithmic order type

Security Security ID

Board Board ID for the security

Direction Order direction - "Buy / Sell / Sell-Buy / Buy - Sell"

Limit price Algorithmic order limit price

Total quantity Algorithmic order total quantity, expressed in lots

Lots left Volume of unmatched part of an order, expressed in lots

Matched, lots Volume of matched part of an order, a difference between "Total
quantity" and "Lots left"

WA price Algorithmic order weighted-average execution price

Trading account Trading account number

Client code Client code assigned by the broker

Broker reference Additional information entered by the trading firm (usually - [client
code]/[client instruction number])

User ID User ID

Type Linked order type: "limit/market"
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Column Description
Price shift type Limit algorithmic order price shift type

Price shift Limit algorithmic order price shift value, according to "Price shift type"
specified

Start time Algorithmic order start time

Stop time Algorithmic order stop time

Total iterations Algorithmic order total expected number of iterations

Current iteration Algorithmic order current iteration number

Interval Interval between algorithmic order iterations

Randomization coef. Linked order value/interval randomization coefficient. Valid value in
range 0..1 with step 0,1.

Interval type TWAP algorithmic order interval type

Algo-order start* Algorithmic order start moment type

Board Id* Board Id

Firm ID* Firm ID

Order date* Order Algo-packet registration date in the Algorithmic Module

Security Id* Security Id

User ID* User ID

Withdraw date* Algorithmic order withdraw date

Withdraw time* Algorithmic order withdraw time

Columns marked with * are hidden by default.

Order Algo-packet Iterations
The "Order Algo-packet Iterations" table lists the information about parameters and status in the trading
system of linked orders in the specified order algo-packet from the "Order Algo-packets" table.

To open the "Order Algo-packet Iterations" table, select the row in the "Order Algo-packets" table, and then
do one of the following:

• select the Order Algo-packet Iterations item in the Algo-trading menu of the main menu;

• select the Order Algo-packet Iterations item in the "Order Algo-packets" table's popup menu;

• double click the row in the "Order Algo-packets" table;

• drag a row in the "Order Algo-packets" table and drop it to the open instance of the "Order Algo-packet
Iterations".

Table 9.5. "Order Algo-packet Iterations" table columns description

Column Description
Iteration Algorithmic order iteration number

Excepted time Scheduled time when the iteration should fire (send linked order to the
Trading System)

Iteration type Algorithmic order iteration type

Iteration status Algorithmic order iteration status

Expected quantity, lots Scheduled volume of the iteration,expressed in lots

Execution time Iteration actual execution time
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Column Description
Executed Linked order execution status, success or not

Price Currency pair price

Executed quantity, lots Algorithmic order actually executed quantity, expressed in lots

Error/message code Iteration execution return code

Message Iteration execution result message

Linked order Linked order ID in the Trading System

Amend time* Amend time

Board* Board ID for the security

Board Id* Board Id

Direction* Order direction - "Buy / Sell / Sell-Buy / Buy - Sell"

Execution price* Actual execution price of the iteration

Order #* Order Algo-packet ID in the Algorithmic Module

Security* Security ID

Security Id* Security ID

Type* Linked order type: "limit/market"

Columns marked with * are hidden by default.
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Chapter 10. Request for stream

Request for stream auction is a process of setting the transaction price for a security in the quantity
declared at an auction. A Liquidity Consumer initiates RFS auction. Providers publish quotes to auction
competitively. Consumer can get all the quotes at each moment and has an option to send order. As the
result, counter-order is submitted on behalf of the liquidity provider. RFS board assumes the satisfaction
of the demand for fulfill huge lots and no negative influence on main quotebooks in the Trading system.

Activation and establishing the connection

To activate RFS menu and establish the connection to the Request for Stream system open the Tools >
Options menu, then proceed to the Connection and then to the RFS Service tab, and set the Connect
enabled flag.

Table 10.1. Elements of the "RFS Service" tab

Element Description
Connect enabled Set the "Connect enabled" flag to activate RFS menu and establish the

connection to the Request for Stream system

Direct connection via TSMR:

Broadcast List of networks addresses (bridges) where searching for available
access servers (gateways) will be performed.

Server RFS server identifier. Note: this field is case-sensitive.

Service RFS TCP and UDP services name.

Preferred gateway (network)
address

Address of the RFS service network (bridge) where search for available
access servers (gateways) will be performed first.

Internet connection:

Host list List of access servers (gateways) for connecting to the RFS service.

Server ID RFS server identifier. Note: this field is case-sensitive.

Request connection confirmation Additional confirmation required for Internet connection.

To reset all changes which was made on form use Cancel button.
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RFS Auction start

Liquidity consumer initiates new RFS auction using "Request For Stream" form. Initiated auction is
displayed in "RFS auctions" table and "Active RFS auctions"(active auction is displayed to all users except
its initiator).

At the bottom of the form there is a timer (HH:MM:SS) and progress bar shows how much time left before
auction end.

To open the form choose Request for Stream command in the RFS menu of the main menu.
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Table 10.2. Elements of the "Request for Stream" form

Element Description
Deal type Choose the deal type: SPOT or SWAP

Security Choose the identifier of the Security in the Trading System

Settlement date Information field: date of settlement by the security

Face value Information field: face value for the security

Trading Account Choose the trading account identifier that will be used for settlement

Client code Choose the client code

Comments Additional information entered by the trading firm (usually - [client
code]/[client instruction number])

Amount Choose the requested volume, expressed in millions of lots

Duration, sec. Choose the duration (time value measured in seconds that will be
allotted for auction process before its expiration)

Group: Buy, Sell, Both Choose the direction of auction: Buy, Sell or 2 way

Anonymous Anonymous checkbox is disabled and shows that auctions are held
anonymously.

Full Amount Sen the flag to specify that the initiator intends to take liquidity just
once

Buy Best bid price at the moment is displayed. Click the button to take the
price and initiate the trade conclusion.

Sell Best offer price at the moment is displayed. Click the button to take
the price and initiate the trade conclusion.

Get Price Click "Get price" to start the RFS auction
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Auction Quote Stream
Liquidity Providers send quotes to the active auction using the "Quote RFS" form.

At the bottom of the form there is a timer (HH:MM:SS) and progress bar shows how much time left before
auction end. At the auction time expiration the "Quote RFS" form is closed automatically.

Values in "Buy", "Sell" and "Spread" fields are available for change using arrows around. When "Spread" field
value is changed, "Sell" field value is changed too (the opposite is also true). Changes in "Buy" and "Spread"
fields do not affect each other. To switch between these three fields use Tab key. To change prices for buy
and sell simultaneously use right and left arrows:

• LEFT arrow (both prices for buy and sell are decreased by one step), hot key Ctrl + 

• RIGHT arrow (both prices for buy and sell are increased by one step), hot key Ctrl + 

To open the "Quote RFS" form do one of the following actions:

• Choose Quote RFS item in the RFS submenu of the main menu;

• Choose Quote RFS command in the Active RFS Auctions table's context menu.

• Choose Quote RFS command in the RFS Auctions table's context menu (command is enabled only for
active auctions).

• Use the Enter hot key when RFS Auctions or Active RFS Auctions table is opened.

Table 10.3. Elements of the "Quote RFS"

Element Description
Tag Code name of the liquidity provider

Contract Identifier of the Security to quote

Full Amount A guarantee that consumer intends to take liquidity just once
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Element Description
Amount Information field: Volume, expressed in lots to quote

Trading Account Choose the trading account identifier that will be used for settlement

Client code Choose the client code

Comments Additional information entered by the trading firm (usually - [client
code]/[client instruction number])

Buy only Set the "Buy only" flag to send only the bid price

Sell only Set the "Sell only" flag to send only the offer price

Buy Enter the bid price

Spread Enter the spread between buy and sell prices

Sell Enter the offer price

Best "Best" line displays currently the best prices for buy (green color) and
sell (red color). Own user's quotes are displayed in bold.

Stop Click the "Stop" button to cancel the send quote

Send Click the "Send" button, to place the quote to the selected RFS auction.

Active RFS Auctions
"Active RFS Auctions" table contains detailed information about currently active RFS auctions that are
available for sending quotes. Auctions initiated by user are excluded. If the auction status changes value
to any except "Active" (expired by time or cancelled), the record about auction is removed from the table
automatically.

To open the table perform one of the following actions

• choose the Active RFS Auctions item of the item of the RFS menu of the main menu.

• click the  button on the toolbar.
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Table 10.4. "Active RFS Auctions" table columns description

Field Description
Auction ID Auction identifier

Security Security ID

Lots Volume, expressed in lots

Start Auction start time

Duration, sec. Time value measured in seconds that will be allotted for auction
process

Remaining time Remaining time counter H:MM:SS shows how much time left before
auction ends

Status RFS status: "Active"

Tag Code name of the liquidity provider

FA Full Amount. A guarantee that consumer intends to take liquidity just
once.

Direction RFS auction direction:

• "B" - Buy

• "S" - Sell

• Space - both directions

Bid Best bid price

Offer Best offer price

Anonymous* Do not discover RFS initiator's name

Firm* Firm ID

Quote number* Quote ID number in RFS trading system

Security Id* Security Id

Settlement currency* Settlement currency

Stop* Auction stop time

Trade #* Trade number in the Trading System

Trade direction* Quote direction for the trade

Trade price* Trade price

Best quote shift counter* Counter of the best quote shifts since the auction start

Firm* Firm ID

User ID* User ID

RFS Auctions

The table contains detailed information about all initiated RFS auctions during the trading day.

To open the table choose the RFS Auctions item of the RFS menu of the main menu.

Table 10.5. "RFS Auctions" table columns description

Field Description
Auction ID Auction identifier

Security Security ID
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Field Description
Lots Volume, expressed in lots

Start Auction start time

Duration, sec. Time value measured in seconds that will be allotted for auction
process

Remaining time Remaining time counter H:MM:SS shows how much time left before
auction ends. Field is empty if the auction has not "Active" status.

Status RFS Auction status:

• "A" - Auction started

• "M" - Matched / Deal done

• "C" - Auction cancelled

• "V" - Auction validated

• "R" - Auction rejected

• "F" - Auction Finished

Tag Code name of the liquidity provider

FA Full Amount. A guarantee that consumer intends to take liquidity just
once.

Direction RFS auction direction:

• "B" - Buy

• "S" - Sell

• Space - both directions

Bid Best bid price

Offer Best offer price

Firm Firm ID

Trading account Trading account

Client code Client code assigned by the broker

Broker reference Additional information entered by the trading firm (usually - [client
code]/[client instruction number])

User ID User ID of the auction owner

Anonymous* Do not discover RFS initiator's name

External user ID* A reference field which may be used as a back-feed by an external
system. May contain, for example, a user ID of the external system user
who entered the original order into that external system.

Firm ID* Firm ID

Quote number* Quote ID number in RFS trading system

Security Id* Security Id

Settlement currency* Settlement currency

Stop* Auction stop time

Trade #* Trade number in the Trading System

Trade direction* Quote direction for the trade
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Field Description
Trade price* Trade price

Best quote shift counter* Counter of the best quote shifts since the auction start

User ID* User ID

RFS Securities

The RFS Securities table lists all the securities in the RFS Trading System.

To open the table choose the RFS Securities item of the RFS menu of the main menu.

Table 10.6. "RFS Securities" table columns description

Field Description
Board Board ID for the security

Security ID Security ID

Name Name of the security

Face value Face value of one Security, expressed in the currency, in which the
Security is nominated

Currency of instrument Currency in which security is denominated

Remarks Remarks

Security Security short name

Lot size Number of securities in one lot

Order's minimum price step Minimum price increment for orders, not applicable to orders at WA
price

Status Flag: "Trading operations allowed/not allowed"

Number of decimals Number of decimals in the Value field (is used to format PRICE-type
fields)

Settlement currency Settlement currency

Settlement date Trade settlement date

Settlement code Settlement code for the trade

Trading status Security trading status:

• N - Not traded right now

• B - Break

• T - Trading session

• Q - Quotes

Minimum value Minimum auction value, lots

Lower rate bound Lowest possible price for the security

Upper rate bound Highest possible price for the security

Base price Base price could be specified for SWAP negdeals

Sent RFS Quotes

Table contains detailed information about user's own quotes.

To open the table choose the Sent RFS Quotes item of the RFS menu of the main menu.
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Table 10.7. "Sent RFS Quotes" table columns description

Field Description
Quote number Quote ID number in RFS trading system

Order time Time when the order was registered at the Trading System

Microseconds Time when the order was registered at the Trading System,
microseconds

Status Current order status:

• "Act" - Active

• "-" - Withdrawn

• "-TS" - Rejected by the Trading System

• "-C" - Cancelled by the Trading System

• "-M" - Error

• "+К" - Buy

• "+П" - Sell

• "?" - Order validated

• "*" - Order handled

• "-F" - Finished by time

Auction ID Auction identifier

Security Id Security Identifier

Security Security ID

Direction Quote direction: Buy/Sell

Buy price Instrument buy price

Sell price Instrument sell price

Lots Volume, expressed in lots

Firm ID of the trading firm on whose behalf the order was entered

Trading account Trading account

User ID ID of the user who has entered the order

Settlement currency Settlement currency

Settlement date Trade settlement date

Client code Client code assigned by the broker

Broker reference Additional information entered by the trading firm (usually - [client
code]/[client instruction number])

Order lifetime Time when the order will be automatically withdrawn

External user ID A reference field which may be used as a back-feed by an external
system. May contain, for example, a user ID of the external system user
who entered the original order into that external system.

RFSM trade information RFSM trade information from ASTS

Update time Time when the order was updated last time (matched, cancelled)
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Field Description
Update time microseconds Time when the order was updated last time (matched, cancelled),

microseconds

Active/Passive User's role flag: active or passive

Security ID Security ID

Firm ID Firm ID

User ID User ID

Update time microseconds Time measured in microseconds when the order was updated last time
(matched, cancelled)

RFS Trades

Table contains detailed information about trades concluded by user after RFS auctions during the trading
day.

To open the table choose the RFS Trades item of the RFS menu of the main menu.

Table 10.8. "RFS Trades" table columns description

Field Description
Trade number Trade number in the Trading System

Direction Quote direction: Buy or Sell

Order number Number of order from which the trade originates

Time Time when the trade was registered at the Trading System

Microseconds Time when the trade was registered at the Trading System,
microseconds

Auction ID Auction identifier

User ID ID of the user who concluded the trade

Firm ID of the trading firm on whose behalf the trade is registered

Trading account Trading account

Security Security ID

Settlement currency Settlement currency

Price Currency exchange rate

Lots Trade volume, expressed in lots

Settlement date Trade settlement date

External user ID A reference field which may be used as a back-feed by an external
system. May contain, for example, a user ID of the external system user
who entered the original order into that external system.

Client code Client code specified by the trader when entering an order

Broker reference Additional information entered by the trading firm (usually - [client
code]/[client instruction number])

Security ID Security ID

Initiated RFS Auctions

The table contains detailed information about all initiated by user RFS auctions during the trading day.

To open the table choose the Initiated RFS Auctions item of the RFS menu of the main menu.
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Table 10.9. "Initiated RFS Auctions" table columns description

Field Description
Auction ID Auction identifier

Security Security ID

Lots Volume, expressed in lots

Start Auction start time

Duration, sec. Time value measured in seconds that will be allotted for auction
process

Remaining time Remaining time counter H:MM:SS shows how much time left before
auction ends. Field is empty if the auction has not "Active" status.

Status RFS Auction status:

• "A" - Auction started

• "M" - Matched / Deal done

• "C" - Auction cancelled

• "V" - Auction validated

• "R" - Auction rejected

• "F" - Auction Finished

Tag Code name of the liquidity provider

FA Full Amount. A guarantee that consumer intends to take liquidity just
once.

Direction RFS auction direction:

• "B" - Buy

• "S" - Sell

• Space - both directions

Bid Best bid price

Offer Best offer price

Trading account Trading account

Client code Client code assigned by the broker

Broker reference Additional information entered by the trading firm (usually - [client
code]/[client instruction number])

Security Id* Security Id

Settlement currency* Settlement currency

Stop* Auction stop time

Best quote shift counter* Counter of the best quote shifts since the auction start

External user ID A reference field which may be used as a back-feed by an external
system. May contain, for example, a user ID of the external system user
who entered the original order into that external system.

Firm* Firm ID

User ID* User ID
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Chapter 11. Clearing information

Positions by Limits
The Positions by Limits table lists firm positions by collateral and by the various types of limits.

To open the table select the Positions by Limits item in the Table menu or click the  icon on the toolbar.

Table 11.1. "Positions by Limits" table columns description

Column Description
Firm Firm name

Position Position code

Currency of settlements Currency Code of the Settlements

Position code Account ID in the Settlement House

Description Group description

Opening balance Balance at the beginning of the day. The value is set in accordance
with the data supplied by an electronic System of the settlement
organization.

Current balance Current balance during the day. Equals to Opening balance plus debit
value since the beginning of the Trading Session minus credit value
since the beginning of the Trading Session.

The exchange commission and accrued interest are included in the
totals calculation.

Planned balance Planned balance after the settlement including participant's liabilities
and claims on trades which will be settled today. The exchange
commission and accrued interest are included in the totals calculation.

Net balance Netto balance during the day. Equals to Current balance plus Total
unmatched value of all active sell-orders minus Total unmatched value
of all buy-orders (CURRENTPOS + ORDERSELL - ORDERBUY).

Debit Debit volume during the day

Credit Credit volume during the day

Max. limit The maximum of all limits set

1-st Level* First level Bank Account flag (Yes / No)

Control balance * Control balance during the day. Equals to Opening balance minus
Planned buy balance, included into quick (simple) settlement

Ext. limit* External limit, set by Settlement House

Firm Id* Firm identifier

Int. limit* Internal limit, set by user

Sell limit* Sell limit during the day

Unmatched buy total* currently not used

Unmatched sell total* currently not used

User current* Current user position

User limit* Limit for User set by Firm manager

User planned* Planned user position

Single pool * The flag is indicating whether a settlement code is related to the Single
pool
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Columns marked with * are hidden by default.

Positions by Assets

The Positions by Assets table lists the aggregate firm positions for every currency being traded".

To open the table select the Positions by Assets item in the Table menu or click the  icon on the toolbar.

Table 11.2. "Positions by Assets" table columns description

Column Description
Firm Firm name

Position Position code

Currency of settlements Currency Code of the Settlements

Position code Account ID in the Settlement House

Description Group description

Opening balance Balance at the beginning of the day. The value is set in accordance
with the data supplied by an electronic System of the settlement
organization.

Current balance Current balance during the day. Equals to Opening balance plus debit
value since the beginning of the Trading Session minus credit value
since the beginning of the Trading Session.

The exchange commission and accrued interest are included in the
totals calculation.

Planned balance Planned balance after the settlement including participant's liabilities
and claims on trades which will be settled today.

Debit Debit volume during the day

Credit Credit volume during the day

Max. limit The maximum of all limits set

1-st Level* First level Bank Account flag (Yes / No)

Control balance* Control balance during the day. Equals to Opening balance minus
Planned buy balance, included into quick (simple) settlement

Firm Id Firm identifier

Net balance Netto balance during the day. Equals to Current balance plus Total
unmatched value of all active sell-orders minus Total unmatched value
of all buy-orders (CURRENTPOS + ORDERSELL - ORDERBUY).

Unmatched buy total* For T0 orders only. Total unmatched value in all active buy-orders
entered by the trading firm

Unmatched sell total* For T0 orders only. Total unmatched value in all active sell-orders
entered by the trading firm

User current* Current user position

Settle* Current settlement having "today" settlement date. Asset profile is
excluded.

User planned* Planned user position

Single pool * The flag is indicating whether a settlement code is related to the Single
pool

Columns marked with * are hidden by default.
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Liabilities and Claims for Assets

Table lists firm's liabilities and claims for assets for different trading accounts.

To open the table select the Liabilities and Claims for Assets item in the Table menu or click the  icon
on the toolbar.

Table 11.3. "Liabilities and Claims for Assets" table columns description

Column Description
Firm Firm name

Trading account Trading account number

Position code Account ID in the Settlement House

Asset Asset code

Settlement date Date of settlements

Opening balance Calculated as "Opening claims" - "Opening liabilities"

Liabilities Liabilities during the day: value in buy trades

Claims Claims during the day: value in sell trades

Netto Netto

Value in buy orders Value in active buy orders

Value in sell orders Value in active sell orders

Planned T+ Planned position during the day, except information of profile transfer.

1-st Level* First level Bank Account flag (Yes / No)

Firm * Firm identifier

Opening claims * Claims at the beginning of the trading day

Opening liabilities * Liabilities at the beginning of the trading day

Single pool * The flag is indicating whether a settlement code is related to the Single
pool

Collateral sell limit* Planned position during the day. Information of profile transfer is
included.

Columns marked with * are hidden by default.

Liabilities and Claims for Pairs

Table lists firm's liabilities and claims for currency pairs for different trading accounts.

To open the table select the Liabilities and Claims for Pairs item in the Table menu.

Table 11.4. "Liabilities and Claims for pairs" table columns description

Column Description
Firm Firm ID

Trading account Trading account number

Bank account Settlement account/code ID in the settlement house

Asset1 (security) Asset1 (security)

Asset2 (for settlement) Asset2 (for settlement)
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Column Description
Settlement date Settlement date

Opening balance (asset1) Opening balance (asset1)

Opening claim (asset1) Opening claim (asset1)

Opening liability (asset1) Opening liability (asset1)

Claim today (asset1) Claim today (asset1)

Liability today (asset1) Liability today (asset1)

Nett (asset1) Value, expressed in the currency of settlement

Claim (asset1) Claim (asset1)

Liability (asset1) Value, expressed in the currency of settlement

Claims in orders (asset1) Claims in orders (asset1)

Liabilities in orders (asset1) Liabilities in orders (asset1)

Opening balance (asset2) Opening balance (asset2)

Opening claim (asset2) Opening claim (asset2)

Opening liability (asset2) Opening liability (asset2)

Claim today (asset2) Claim today (asset2)

Liability today (asset2) Liability today (asset2)

Nett (asset2) Value, expressed in the currency of settlement

Claim (asset2) Claim (asset2)

Liability (asset2) Value, expressed in the currency of settlement

Claims in orders (asset2) Claims in orders (asset2)

Liabilities in orders (asset2) Liabilities in orders (asset2)

Firm Id* Firm Id

Columns marked with * are hidden by default.

Setting Limit on Firm's Positions

To set a limit on the Firm's positions, first select a position in any table and then do one of the following:

• select the Change Firm Limit item in the Administration submenu of the Action menu;

• select the Change Firm Limit item in the table's popup menu.
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Table 11.5. Elements of the "Change Firm Limit" dialog

Element Description
Firm Information field: name of the Firm

Position Position name.

Currency Currency ID.

Position code Account Identifier.

External limit External limit for money.

Internal limit Internal limit for money.

Check Enable limit verification.

The planned positions can break
limits

Set the flag to allow internal limit that doesn't meet planned balance
at the current moment.

Trading Accounts
The Trading Accounts table lists all the firm's accounts that can be used in various transactions on the
market.

To open the table select the Trading Accounts item in the Table menu or click the  icon on the toolbar.

Table 11.6. "Trading Accounts" table columns description

Column Description
Firm Firm name

Trading account Trading account number

Trading account type Trading account type

Description Description

Position code Code of an additional money position

Status Flag: "Trading operations allowed/not allowed"

Order types Permitted order types

Level 1 First level Trading Account flag (Yes / No)

Clearing Account Clearing account's number

Clearing firm Name of the clearing firm

Clearing Firm Id Clearing firm Identifier

Firm Id* Firm Identifier

Columns marked with * are hidden by default.

Bank Accounts
The Bank Accounts table lists all the firm's bank accounts with their permissions and statuses.

To open the table select the Bank Accounts item in the Table menu.

Table 11.7. "Bank Accounts" table columns description

Column Description
Firm Firm name

Bank account Settlement account/code ID in the settlement house

Description Description
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Column Description
Status Flag: "Trading operations allowed/not allowed"

Additional Session Flag: "Additional Session"

Early Settle Flag: "Early Settle"

Trading Closed Flag: "Trading Closed"

Don't check SL Transactions without single limit check

Fully covered trading for CM Prohibition of trading without full pre-funding flag.  Firm manager may
change this setting through the Fully Covered Trading dialog.

Client code Client code assigned by the broker.

Clearing Firm Clearing Member Firm name.

Clearing bank account Clearing account ID in the settlement house

Type Bank account type:

- Client's funds

- 2,3 lev. clients

- Collective collateral

- Funds transferred to TM

- Own funds

- Stress collateral

- Technologic

1-st level First level Bank Account flag

Single pool Flag: "Single pool"

Apply percent risk Flag: "Apply percent risk". Might be changed with Percent risk
calculation form

Clearing firm Id* Identifier of the Clearing firm

Client information to CM* Show client information to clearing member

CM controls 3-rd lev.* Clearing member controls third level

Commission bank account* Bank account ID in the settlement house to charge variable
commission fee from

Details* Client taxpayer number or other document

Early settlement time* Early settlement time

Firm Id* Firm Identifier

Legal clearing model* Legal clearing model

Protected client* Protected client

Subdetails* Client taxpayer number or passport number or other document

Trading closed time* Trading closed time

Columns marked with * are hidden by default.

Trading Without Full Pre-funding Limits for Bank Accounts

The Trading Without Full Pre-funding Limits for Bank Accounts lists all the active limits acts currently bound
to the certain bank account.



Clearing information 19.09.2025

131

To open the table select the Trading Without Full Pre-funding Limits for Bank Accountsitem in the Position
submenu of the Table menu.

Table 11.8. Trading Without Full Pre-funding Limits for Bank Accounts table columns
description

Column Description
Firm Id Firm Id

Bank Account Settlement account/code ID in the settlement house

Asset code Asset code

Ext. limit External limit for bank account, that is set by Clearing Centre.

Int. limit Internal limit for bank account, that is set by firm manager.

Max. limit The maximum of internal and extrnal limits

Firm Firm Name

Asset Asset

Set External Bank Account Limit

To set the limit for bank accounts first select the certain account in the Trading Without Full Pre-funding
Limits for Bank Accounts table and then

select the Change External Bank Account Limit item in the Adminitsration submenu of the Action menu or

select Change External Bank Account Limit in the popup menu of the Trading Without Full Pre-funding
Limits for Bank Accounts table.

Table 11.9. Elements of the "Set External Bank Account Limit" dialog

Column Description
Bank Account Settlement account/code ID in the settlement house.

Asset The asset code

External limit External limit for bank account, that is set by Clearing Centre.

Internal limit Internal limit for bank account, that can be set by firm manager.

Check Enable limit verification.

The planned positions can break
limits

Set the flag to allow internal limit that doesn't meet planned balance
at the current moment.

Check Collateral Sufficiency

To check collateral sufficiency for bank account first select the certain account in the Bank Accounts table
and then

select the Check Collateral Sufficiency item in the Adminitsration submenu of the Action menu or

select Check Collateral Sufficiency in the popup menu of the Bank Accounts table.

Table 11.10. Elements of the "Confirmation" dialog

Column Description
Bank Account Settlement account/code ID in the settlement house to check

collateral.
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Column Description
I confirm the action Flag: user is aware of cancel of active orders in case of insufficient

collateral.

Fully Covered Trading
This dialog provides Firm Manager an ability to prohibit trading without full pre-funding for a particular
Bank Account.

To open the dialog first select the needed Account in the Bank Accounts table and then choose Fully
Covered Trading item in the table's context menu or in Administration submenu of the Action menu.

Check or uncheck the "Prohibition of trading without full pre-funding" checkbox for the selected Bank
Account and click "Yes" to proceed to confirmation dialog.

Bank Accounts table contains the "Fully covered trading" field indicating whether trading without full pre-
funding is available for account or not.

Accounts in Settlement Organizations
"Accounts in Settlement Organizations" table displays the correspondence between Bank Accounts
identifiers and real accounts numbers in Settlement House.

To open the table select Accounts in Settlement Organizations item in the Positions submenu of the Table
menu.

Table 11.11. "Accounts in Settlement Organizations" table columns description.

Column Description
Firm Id Firm Identifier

Firm Firm name

Position code Settlement account/code ID in the Settlement house

Settlement Organization Settlement Organization name

Currency of settlements Currency code of the settlements

Account in settlement house Number of the corresponding account in the settlement house

Collateral account Collateral account

Description Description of the account

Calculate Assets Withdrawal in single or multiple currencies
These dialogs are designed for calculation of assets amount available for withdrawal from the Clearing
System in single or multiple currencies for a particular Bank account.

To open the dialog select "Calculate Assets Withdrawal in Single Currency" or "Calculate Assets
Withdrawal in Multiple Currencies" in the Query menu.

Table 11.12. Window fields descrition

Field Description
Bank account Bank account identifier.

Including T0 collateral Calculation will be performed considering T0 collateral (obligations
with settlement date already occured).

Currency List of all currencies available for withdrawal.

Amount The amount of money, that can be withdrawaled from the Clearing
System in case of withdrawal in single currency. In case of withdrawal
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Field Description
in one currency, the amount of money, available for withdrawal in other
currencies, decreases accordingly.

Table  11.13.  "Calculate Assets Withdrawal in Multiple Currencies" window fields
descrition"

Field Description
Bank account Bank account identifier.

Including T0 collateral Calculation will be performed considering T0 collateral (obligations
with settlement date already occured).

Currency List of currencies, available for multiple entry.

Maximal amount Maximum amount available for withdrawal from trading system.

Required amount Required amount of money for withdrawal (cells should be filled with
values).

The required amount must be specified for all currencies except one,
that would be used as collateral.

Available amount Amount available for withdrawal. Calculated after filling "Required
amount" field for two of three currancies and pressing "Calculate"
button.

Calculate (F9) Calculate amount, available for withdrawal. Calculation can be
processed after filling required amount for two of three currancies.
Also calculation can be processed by pressing F9 hot key.

Clear Clear cells in "Required amount" column.

Calulation of Collateral for Operations
"Calculation of Collateral for Operations" form provides functionality to calculate amount of collateral that
is required to perform planned trading operations.

To open the dialog select Collateral for operations in the Query menu.

Table 11.14. Window fields description

Field Description
Bank account Bank account used for calculating collateral.

"Planned operations" checklist Select the operations, to be used for calculating collateral. Press the
Edit button to open the Enter order packet dialog window.

Required additional collateral in
RUB

Absolute value of Single Limit negative value, calculated from "Planned
operations" checklist contents.

Assume that all orders are
matched and trades are concluded
(close position mode)

Set the flag to perform Collateral calculation assumping that all of the
planned orders will lead to the trades conclusion

Choose additional collateral
currencies, assets

Assets, specified in USD,EUR,RUB,CNY/GLD/SLV. Values are used for
calculating Single Limit.

Lack of additional collateral in
RUB / Excess of collateral in
trading system in RUB

Single Limit absolute value calculated considering "Planned
operations" checklist contents and values of additional collateral in
different currencies. The field name varies depending on the Single
Limit value. If Single Limit value is negative, field will be named "Lack
of additional collateral in RUB". In other cases, "Excess of collateral in
trading system in RUB:".
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Field Description
Considered in trading system,
orders..., negdeals...

Number of active orders and negdeals in Orders and Sent Negdeals /
OTC Negdeals tables.

Positions by Currencies

"Positions by Currencies" dialog is

"Positions by Currencies" dialog is designed to calculate current currency positions by different Bank
accounts.

To open the dialog select the following commands sequentially in the top menu Query > Calculate Positions
by Currencies.

Table 11.15. Elements of the "Positions by Currencies" dialog

Element Description
Bank account Bank account, positions by currencies are calculated for.

Currency Currency Identifier

Current position Equals to Opening balance plus Total value of Sell-trades, minus Total
value of Buy-trades.

Calculate (F9) Calculate current position values by currencies for selected Bank
account, considering trades concluded since the previous calculation.

Close Close the dialog window

Calculate TOM collateral

"TOM collateral" refers to amount of requirement for FX market Clearing Member's collateral for trades
with future settlement dates per each Bank account.

To open the "TOM collateral" dialog select the following commands sequentially in the top menu: Query >
Calculate TOM collateral.

The dialog contains "Bank account" drop-down list, and "Calculate" and "Close" buttons.

Collateral after Risk-parameters Change

Collateral after Risk-parameters Change is an amount of requirement for Clearing Member's collateral
for trades concluded on FX market in case of Risk-parameters change. This amount is calculated for the
particular BankAcc considering Risk-parameters values loaded from a file.

To open the dialog select the following commands sequentially in the top menu: Query > Collateral after
Risk-parameters Change.

The prospective risk-parameters values are loaded from plain text *.csv file with arbitrary name and
location. First line of the file contains column headers devided by separator symbol (depends on OS
settings, usually "," for American Windows versions and ";" for European Windows version), other lines refer
to market risk-parameters values for particular asset devided by separator symbol.

Sample file structure

ASSET;DISCOUNT1;DISCOUNT2;DISCOUNT3
USD;20.373;25.0;29.0
BYN;8.5;20.344;21
EUR;8.021;14.120;20.007
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Table 11.16. Columns description

Column Description
ASSET Asset ID. Corresponds to "Asset ID" column of the Assets table. Other

values are not supported.

Maximum 12 symbols.

DISCOUNT1/2/3 Market risk rate [Range 1/2/3].

Real numbers. Maximum 3 symbols in integer part, maximum 3
symbols in fractional part. The decimal mark symbol depends on
operating system locale ("." or ",") Possible values range is from 0 to
100 percent (% symbol should not be used).

In case the risk-parameters values is not specified for one or several assets, calculation will be performed
using current values from the FX market trading system.

Collateral requirement is calculated considering current percent risk-parameters from the FX market
trading system.

Table 11.17. Elements of the "Collateral after Risk-parameters Change" dialog

Element Description
Risk-parameters file Path to the risk-parameters file. Click "Browse" to select the file.

Bank account BankAcc ID, the collateral requirement will be calculated for.

Collateral The calculated requirement for collateral considering risk-parameters
values specified in the file.

Calculate (F9) Calculate requirement considering trades concluded after the previous
calculation.

Close Close the dialog. No data will be saved.

Single Limit Components
The "Single Limit Components" dialog is implemented to assess the input of positions of Clearing member's
portfolio in Single Limit. Single Limit components are described for Current Single Limit.

To open the Single Limit Components dialog select the following commands sequentially in the top menu:
Query > Single Limit Components.
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Table 11.18. Elements of the "Single Limit Components" dialog

Element Description
Bank Account Bank Account for which Single Limit components will be described.

Components by asset Table columns are listed below.

• Asset;

• Asset ID;

• Account;

• Balance - filled in with Current balance value from "Positions by
Assets" or "Positions by limits";

• Profiles – filled in with value of asset profiles transferred to other
markets;

• Trades total – net sum based on trades by any date;

• Transfers – the field is filled in for currency as Current balance from
Positions by Assets" table;

• Collateral value;

• Portfolio value – aggregated net value by asset by any settlement
date;

• Market risk – market risk value calculated by asset and used for
Single Limit;

• Percent risk – market risk value calculated by asset by any
settlement date and used for Single Limit;

• Effective market risk rate – field with calculated value based
on market risk, collateral on asset, trades with asset total, and
calculated asset price;

• UL effect – field with calculated value based on Collateral value,
portfolio value, market and percent risks.

Interproduct spread discounts • Group – name of interproduct spread group;

• Account - trading and clearing account;

• Rate, % - Rate of discount expressed in percent;

• Discount – Discount value calculated for interproduct spread group
that are used for Current Single Limit calculation.

Extra Effects • Commission fee;

Overall Single Limit value

Calculate (F9) Update calculated values in dialog fields

Close Close dialog window

Unsettled Trades
Table lists concluded but not yet settled trades on negotiated deals and orders.

To open the table:
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• choose the Unsettled Trades command in the Table menu of the main menu;

• click the  button on the toolbar.

Trades that must be settled "today" or "tomorrow" are highlighted with red or orange.

Table 11.19. "Unsettled trades" table columns description

Column Description
Trade ID Trade number in the Trading System

Trade date Trade date

Settlement date Trade settlement date.

Firm Firm ID

Security Security ID

Board Board ID for the security

Settlement code Settlement code for the trade

Direction Order direction - "Buy / Sell / Sell-Buy / Buy - Sell"

Rate Currency exchange rate

Lots Volume, expressed in lots

Precise quantity Precise quantity

Trade balance Volume of unmatched part of an order, expressed in lots

Value Trade value, expressed in the currency of settlement

Bank account Settlement account/code ID in the settlement house

Settlement organization Settlement organization

Trading account Trading account number

Client code Code of a client on whose behalf the order was entered

Broker reference Additional information entered by the trading firm (usually - [client
code]/[client instruction number])

Unsettled trade type Unsettled trade type

Counterparty Counterparty firm

Counterparty trading account Counterparty trading account ID

Settlement instruction ID ID of a settlement instruction sent by the firm to settle this trade

Status Unsettled trade status

Counterparty settlement
instruction ID

ID of a settlement instruction sent by the counterparty firm to settle
this trade

REPO trade ID ID of the first REPO part for REPO without CCP. For REPO with CCP:
ID of the second trade part in the record for the first trade part and
vice versa.

REPO price 1 Price of the first REPO leg

REPO price 2 Buyback price for the second REPO leg

Term REPO term expressed in calendar days. The term starts on the next day
after the first REPO leg settlement and ends on the day of the second
REPO leg settlement inclusive.

Rate, % REPO rate (fixed rate mode) or spread (floating rate mode), expressed
in %
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Column Description
Value / REPO value REPO value calculated in the currency of settlement for the current

date

Total amount Total value of the trade expressed in rub. Can be positive or negative,
depending on the trade type (sell or buy). For "ordinary" trades – the
same as the trade value.

REPO return value Value due to be paid during settlement of the second (buy-back) REPO
leg

Discount Initial discount for the first REPO leg and current discount for the
second REPO leg

Low limit of REPO discount, % Low limit of REPO discount, %

Upper limit of REPO discount, % Discount, expressed in %

Settlement time Settlement time

Settle today The "Must be settled today" flag

Settle next day The "Settle next day" flag

Order Number of order, from which the trade originates

Type of clearing Clearing type:

C - Central

E - External

M - Multilateral

Not identified

S - Simple

Settlement status Settlement status

Report commission Value of commission fee for sending a quick settlement instruction, in
rub.

Clearing time Time when clearing was finished

ID of confirmation instruction ID of the confirmation instruction for an OTC trade

Time of confirmation Time of confirmation

Counterparty confirmation status Counterparty confirmation status

Compensation value Compensation value, expressed in the currency of the trade

Type of settlement trade Type of settlement trade:

N - Negotiated deal

T - Money/Securities transfer

Balance of the REPO buy-back
value*

Current value of the 2nd (buy-back) REPO leg calculated for the
settlement date, expressed in the currency of settlement

Block collaterals* Block collaterals on a special account for REPO trades

Board Id* Board Id

Clearing account* Clearing account number

Clearing bank account* Clearing account ID in the settlement house

Clearing firm* Firm ID of clearing member

Clearing firm Id* Clearing firm Id
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Column Description
Commission* Trade commission, rub.

Counterparty settlement
instruction ID for early settlement*

ID of a settlement instruction for a REPO with CCP trade sent by the
counterparty firm

Coupon payment* Value of coupon payment since the last security trading day

Coupon payment date* Date of the last coupon payment

Cpty. Id* Cpty. Id

Date of conslusion* For margin calls only. Date of REPO trade conclusion. Empty in other
cases.

Date of principal debt payment* Date of the last principal debt (amortization) payment

Discount after deposit, %* Discount after deposit, expressed in %

Due date* Trade due date

Early settle* Status of early settled REPO with CCP trade

External user ID* A reference field which may be used as a back-feed by an external
system. May contain, for example, a user ID of the external system user
who entered the original order into that external system.

Firm Id* Firm Id

Operation* Operation type: deposit/withdraw

Parent trade* Parent trade number in the Trading System for REPO trades

Principal debt payment* Value of the principal debt (amortization) payment since the last
security trading day

Quantity after deposit* Quantity after deposit, expressed in lots

Repurchase value after deposit* Value of the 2nd (buy-back) REPO leg after deposit, expressed in the
currency of settlement

Return value after deposit* REPO return value after deposit, expressed in the currency of
settlement

Security Id* Security Id

Settlement currency* Settlement currency

Settlement instruction ID for early
settlement*

ID of a settlement instruction for a REPO with CCP trade sent by the
firm

Value after deposit* REPO value after deposit calculated in the currency of settlement

Columns marked with * are hidden by default.

Enter Confirmation Trade Settlement Report

To enter the settlement report for a conformation trade, choose the needed trade record in the "Unsettled
Trades" table and then do one of the following:

• choose the Enter confirmation trade settlement report command in the Report item of the Action menu
in the main menu;

• choose the Enter confirmation trade settlement report command in the context menu of the "Unsettled
Trades" table.

The dialog contains confirmation trade parameters to be verified by user.

After the Enter Report button clicked there will be action confirmation dialog. Action confirmation can be
disabled in the program Options.
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Sent confirmation trade settlement reports are listed in the "Sent Reports" table.

Table 11.20. Elements of the "Enter Confirmation Trade Settlement Report" dialog

Element Description
Trade ID Trade number in the Trading System

Clearing Firm Firm name of clearing member

Counterparty Counterparty firm name

Board Board name for the security

Security Security name

Precise quantity Precise quantity/ expressed in a number of securities

Total amount Total value of the trade

Sent Reports

Table lists settlement reports sent to counterparties on negotiated trades.

To open the table:

• choose the Sent Reports command in the Table menu of the main menu;

• click the  button on the toolbar.

Table 11.21. "Sent Reports" table columns description

Column Description
Instruction number ID of a settlement instruction sent by the firm to settle this trade

Time Time when the instruction was entered into the Trading System

Status Settlement instruction status

Counterparty Counterparty firm ID

Withdraw time Time at which the settlement instruction was withdrawn

User ID User ID

Settlement instruction type Settlement instruction type

Type of the settlement instruction Settlement instruction execution type

Compensation* Compensation direction

Compensation value* Compensation value, expressed in the currency of the trade

Cpty. Id* Cpty. Id

Date* Date

Firm* ID of the trading firm on whose behalf the instruction was entered

Firm* ID of the trading firm on whose behalf the instruction was entered

Number of trades* Number of trades

User ID* User ID

Columns marked with * are hidden by default.

Trades of report

To see the list of trades included into the settlement report, choose the needed record in the "Sent Reports"
table and do one of the following:
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• choose the View report trades command in the Report menu of the Action menu in the main menu;

• choose the View report trades command in the context menu of the "Sent Reports" table.

Table 11.22. Elements of "Trades of report" dialog

Element Description
Trade ID Trade number in the Trading System

Board Board name for the security

Security Security name

Type of settlement trade Type of settlement trade:

N - Negotiated deal

T - Money/Securities transfer

Settle today The "Must be settled today" flag

Settlement date Trade settlement date.

Precise quantity Precise quantity, expressed in number of securities

Total amount Total value of the trade

Trading Account Trading account ID for the trade

REPO trade ID ID of the first REPO part for REPO without CCP. For REPO with CCP:
ID of the second trade part in the record for the first trade part and
vice versa.

Counterparty Counterparty firm

Counterparty trading account Counterparty trading account ID

Broker reference Additional information entered by the trading firm (usually - [client
code]/[client instruction number])

Close Close the dialog window.
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Chapter 12. General Market Information

Indexes
The Indices table shows the current values of all the indices available on the market.

To open the table select the Indexes item in the Table > Exchange Tables menu or click the  button on
the toolbar.

Table 12.1. "Indexes" table columns description

Column Description
Index Index

Index ID Exchange Index ID

Close Last value of the previous trading session

Current Current index value

Last change Last change

To close To close

To close, % To close, %

Calculation time Calculation time

Opening value Value of the Index at the opening of the current trading day

To open To open

To open, % To open, %

Maximum* Maximum index value

Minimum* Minimum index value

Trade volume* Value of all the trades included into an index, expressed in Rubles

Columns marked with * are hidden by default.

Turnover by Exchange
The Exchange Turnover lists turnover values for trading boards.

To open the table select the Exchange Turnover item in the Exchange Tables submenu of the Table menu
or click the  button on the toolbar.

Table 12.2. "Exchange Turnover" table columns description

Column Description
Boards Name of the trading board.

Exchange Name of the Exchange.

Buy Turnover on "buy" trades.

Sell Turnover on "sell" trades.

Turnover Total turnover ("buy" + "sell").

Currency Rates
"Currency Rates" table lists all the currencies available in the Trading/Clearing System and their exchange
rates agains Russian ruble.

To open the table select Currency Rates item in the Exchange Tables submenu of the Table menu.
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Table 12.3. "Currency Rates" table columns description

Column Description
Currency of settlement Code of the settlement currency

Name Currency name

Exchange rate Exchange rate against Russian ruble with 4-digits precision.

Asset* Corresponding asset code.

Columns marked with * are hidden by default.

Board Totals

The Board Totals dialog box lists the trading values per boards on the market.

To open this dialog select the Board Totals item in the Query menu.

"Board Totals" table contains full names of the boards, identifiers and values of trades per each board in
rubles. Value of selected boards and total value are displayed below the table.

Use Ctrl or Shift keys to select several boards. Press Ctrl+A to select all rows in the table.

Security by Board Totals

The Security by Board Totals dialog lists the trading values per security on a chosen board.

To open this dialog first select a line in any table that contains the board identification (orders, trades, etc.)
and then select the Security by Board Totals item in the Query menu.
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Table 12.4. Elements of the "Security by Board Totals" dialog

Element Description
Board Trading board name.

Board total value Total value of trades per board, in rubles.

Securities List of available securities for board totals. Use Ctrl
and Shift buttons to select multiple securities. Press
Ctrl+A to select all the securities of the trading
board.

Selected securities List of securities to obtain values on.

Total value Total value of trades per selected securities in rubles.

History by Market

To show market trade results for a particular date first open a table which identifies the market (such as
Securities, Trades, Orders, Orderbook) and then select the History by Market item in the Query menu.
When the History by Market dialog opens select the desired date and press OK.

This function requires connection to the informational and statistical server (ISS).

The default date in this dialog corresponds to the last date for which there are trade results available. The
data can be selected in the drop-down menu at the top of the dialog.
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History by Security

To show trade results for a particular security on a particular board first select the security in one of the
following tables: Securities, Trades, Orders, Orderbook. Then select the History by Security item in the
Query menu. When the History by Security dialog opens select the desired date range and press OK.

This function requires connection to the informational and statistical server (ISS).

The default range of dates in this dialog corresponds to the earliest and the latest dates of the trade results
availability.

Delisted Securities

To show all the securities that are no longer traded first open a table which identifies the market (such as
Securities, Trades, Orders, Orderbook) and then select the Delisted Securities item in the Query menu.

This function requires connection to the informational and statistical server (ISS).

News feed

Attention: If you want to view news from Interfax in trader's terminal you need to use ISS connection.

To activate Interfax News window, open the Tools > Options menu, then proceed to the ISS tab and set the
"Display news" enabled flag. Configure Information server connection settings.

The new element News will appear in the top menu.

To open the "ISS: Interfax" window with news feed select the Interfax item in the News menu of the main
menu.

Table 12.5. Elements of the "ISS: Interfax" window

News feed
Quick view

News feeds Mark checkboxes near
the required feed to
display needed news
below.

Click the calendar icon to
choose the date for which
you need to display news.
By default, today date is
chosen.

Publication time Headline
Date and time of
publication DD:MM:YYYY
HH:MM:SS format. Use
filtration feature to get
the news feed from
specified time period.

News headline. Important
news are highlited with a
red font. Click a headline
to display news in the
quick view area (right
of the feed). Double-
click headline to open
news text in the separate
window..

Selected news item from the list is displayed in the
quick view area.

Securities tickers in the news text are clickable. To display list of news related to the security, click the ticker.
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To search through news text, press the Ctrl+F.

Trading Boards
The Boards table lists all the boards that have been selected during the logon procedure.

To open the table select the Boards item in the Table > Exchange Tables menu or click the  button on
the toolbar.

Table 12.6. "Boards" table columns description

Column Description
Board Trading board name

Trading board ID Trading board ID

Status Flag: "Trading operations allowed/not allowed"

Currency of settlements Currency Code of the Settlements

Market Market ID this board belongs to

Value, rubles Value, rubles

Columns marked with * are hidden by default.

Trade Time
The Trade Time table lists all the events in the Trading System for the current trading session.

To open the table select the Trade Time item in the Exchange Tables submenu of the Table menu or click

the  button on the toolbar.

Table 12.7. "Trade Time" table columns description

Column Description
Time Time of the event.

Event group Event group/category

Event Event name

Status [blank] – active;

"-" – carried out;

cancelled;

confirmation required.

Market Market ID

Board ID of the trading board the event is concerned with.

Group ID of a security group the event is concerned with.

Security Security identifier.

Trade Time History
The Trade Time History table lists all records about committed trading status changes by any security due
to an event occurrence from the trading schedule in the Trading System for the current trading session.
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To open the table select the Trade Time History item in the Exchange Tables submenu of the Table menu.

Table 12.8. "Trade Time History" table columns description

Column Description
Time Event Time

Security Security name

Board Board ID for the security

Trading status Security trading status

Event Event type. For list of all types see the
TRDTIMETYPES table.

Trading session Trading session number

Board Id* Board ID

Security Id* Security ID

Trading Status TWT - Auction: After auction trade phase

LO - Auction: Bookbuilding phase, orders are locked

OE - Auction: Orders entry phase

AM - Auction: Trade conclusion phase

B - Break

C - Closing period

DA - Discrete auction

N - Not traded right now

OA - Opening auction

O - Opening period

"-" - Trading is closed

Trading session

UPA - Update price auction

Firms

The Firms table lists all the firms (dealers) that are present on the market.

To open the table select the Firms item in the Exchange Tables submenu of the Table menu or click the

 button on the toolbar.

Table 12.9. "Firms" table columns description

Column Description
Firm Short Firm name.

Firm code Firm Identifier.

Firm type Firm type: Firm, Investor, Technical Center, Exchange, Central Bank.

Status Status:
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Column Description
[blank] – trading operations allowed

= – trading operations are suspended.

Clearing access* The firm has an access to the Clearing organization's services.

• "Yes" - the firm has access;

• "No " - the firm has no access;

• Suspended;

• Unspecified.

Trading access* The firm has an access to MOEX trading.

• "Yes" - the firm has access;

• "No " - the firm has no access;

• Suspended;

• Unspecified.

TIN* Taxpayer identification number.

Liquidation netting* Liquidation netting has been initiated in relation of the firm.

• "Yes" - Yes;

• " " - No.

Exchange* Regional Exchange ID.

Price Move Limits

The Price Move Limits window displays the current values of maximum and minimum allowed exchange
rate for a currency pair.

To open this dialog select a currency pair in the Securities table and then select the Price Move Limits item
in the Query menu.

It is also possible to see the exchange rate limits in any order entry dialog by clicking the "?" button located
to the right of the Price field.
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Chapter 13. Risk Parameters

Assets

"Assets" table lists basic information on assets available in the Trading System.

To open the table, select the Assets item in the Risk Parameters submenu of the Query menu.

Table 13.1. "Assets" table columns description

Column Description
Asset ID Asset code

Asset name Asset name

Central rate Central rate

Risk rate for price decrease, % Percentage value of Risk rate for price decrease

Risk rate for price increase, % Percentage value of Risk rate for price increase

Accepted as collateral The Asset is accepted as collateral

Central bank rate, % Percentage value of risk rate, defined by Central Bank

Fully covered trading Flag displaying prohibition of trading without full pre-funding

Asset Asset short name

Central rate, rub* Central rate of the current trading day, used to determine risk range
limits, RUB.

Covered Sell* Covered Sell

English name* English name

Fully covered trading limit* Fully covered trading limit

Partial collateral* The value as a percentage of free funds, which is accepted as collateral

Penalty rate for asset transfer, %* Penalty rate for asset transfer, %

Penalty rate for rub. transfer, %* Penalty rate for rub. transfer, %

Quoted for, unit* Quantity for which the asset is quoted

Special mode of settlement* Special mode of settlement

Без расчетов в НКЦ Без расчетов в НКЦ

Columns marked with * are hidden by default.

Market Risk Parameters

Table contains values of market risk parameters defined for the currenct trading day by Clearing Center
for particular assets. Market risk parameters are used for calculating Single limit for trading with partial
prefunding.

To open the table select Market Risk Parameters item in the Risk Parameters submenu of the Query menu.

Table 13.2. "Market Risk Parameters" table columns description

Column Description
Asset Asset code

Range Range number

Range beginning Range beginning
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Column Description
Range end Range end

Risk rate for price decrease, % Percentage value of risk rate for price decrease

Lower rate bound Lower rate bound

Upper rate bound Upper rate bound

Range beginning, rub Range beginning, rub

Range end, rub Range end, rub

Risk rates change time Last time of Risk rates change.

Central rate* Central rate of the current trading day used by Clearing Center to
determine rate bounds.

Risk rate for price increase, % Percentage value of risk rate for price increase

Columns marked with * are hidden by default.

Individual Risk Parameters

Table contains values of risk parameters for firm's trading accounts defined by Clearing Center.

To open the table select Individual Risk Parameters item in the Risk Parameters submenu of the Query
menu.

Table 13.3. "Individual Risk Parameters" table columns description

Column Description
Firm Firm name

Position code Account ID in the Settlement House

Trading account Trading account number

Asset Asset

NCC coefficient National Clearing Centre coefficient

NCC coefficient for tomorrow National Clearing Centre coefficient for tomorrow

User coefficient User coefficient

User coefficient for tomorrow User coefficient for tomorrow

Firm* Firm Identifier

Columns marked with * are hidden by default.

Percent Risk Parameters

Table contains values of percent risk parameters defined for the currenct trading day by Clearing Center
for particular assets. Percent risk parameters are used for for calculating Single limit for trading with partial
collateral.

To open the table, select the following commands sequentially in the top menu: Query > Risk Parameters
> Percent Risk Parameters.

Table 13.4. "Percent Risk Parameters" table columns description

Column Description
Asset Asset code

Settlement date Settlement date
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Column Description
Range Range number

Range start, units Range beginning expressed in units of currency

Range end, units Range end expressed in units of currency

Lower rate bound Lower rate bound

Central rate Central rate

Upper rate bound Upper rate bound

Range beginning, rub Range beginning, rub

Range end, rub Range end, rub

Risk rates change time* Time of the last rate change

Columns marked with * are hidden by default.

Interproduct spreads

The table contains discount values for currency pairs interproduct spreads. The discount is calculated for
the planned position and added to the single limit.

To open the table, select the following commands sequentially in the top menu: Query > Risk Parameters
> Interproduct Spreads.

Table 13.5. "Interproduct Spreads" table columns description

Column Description
Spread name Short spread name

Spread code Spread identifier

Asset name Name of asset that are contained in spread

Discount Rate, % Rate of discount expressed in percent

Covered Sell* Covered Sell

English name* English name

Fully covered trading limit* Fully covered trading limit

Partial collateral* The value as a percentage of free funds, which is accepted as collateral

Quoted for, unit* Quantity for which the asset is quoted

Special mode of settlement* Special mode of settlement

Columns marked with * are hidden by default.

Interproduct spread assets

The table contains information about interproduct spreads which are composed of groups of assets.

To open the table, select the following commands sequentially in the top menu: Query > Risk Parameters
> Interproduct Spread Assets.

Table 13.6. "Interpoduct spread assets" table culumns description

Column Description
Spread name Short spread name

Spread code Spread identifier
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Column Description
Asset Name of asset that are contained in spread

Asset ID Asset identifier that are contained in spread

Covered Sell* Covered Sell

Fully covered trading limit* Fully covered trading limit

Partial collateral* The value as a percentage of free funds, which is accepted as collateral

Quoted for, unit* Quantity for which the asset is quoted

Special mode of settlement* Special mode of settlement

Columns marked with * are hidden by default.

Individual Risk Parameters (new)

Table contains values of risk parameters for firm's trading accounts defined by User controls second or
third level bank account.

Setting of individual risk parameters is available dynamically during the trading day with the corresponding
recalculation of the Single Limit / T + planned positions.

To open the table select Individual Risk Parameters (new) item in the Risk Parameters submenu of the
Query menu.

Table 13.7. "Individual Risk Parameters (new)" table columns description

Column Description
Firm Firm ID

Bank account Settlement account/code ID in the settlement house

Trading account Trading account number

Asset Asset

Discount rate, % Discount rate, %; might be changed with "Set interproduct spread
discount rate" form

Accepted as collateral Flag: may be accepted as collateral.

Zero RtL Flag of zeroing the lower limit

Accepted as collateral for TOM* Asset can be included into collateral for tomorrow

Asset code* Asset code

Firm Id* Firm Id

Partial collateral* The value as a percentage of free funds, which is accepted as collateral

Columns marked with * are hidden by default.

Market Individual Risk Parameters (new)

Table contains values of market risk parameters for firm's trading accounts defined by User controls second
or third level bank account.

Setting of market individual risk parameters is available dynamically during the trading day with the
corresponding recalculation of the Single Limit / T + planned positions.

To open the table select Market Individual Risk Parameters (new) item in the Risk Parameters submenu
of the Query menu.
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Table 13.8. "Market Individual Risk Parameters (new)" table columns description

Column Description
Firm Firm ID

Bank account Settlement account/code ID in the settlement house

Trading account Trading account number

Asset Asset

Range Range number

Range, units Value, expressed in the currency of settlement

Risk rate for price decrease, % Risk rate for price decrease, %

Risk rate for price increase, % Risk rate for price increase, %

Lower limit, rub. Lower limit, rub.

Upper limit, rub. Upper limit, rub.

Asset code* Asset code

Firm Id* Firm Id

Range end, units* Value, expressed in the currency of settlement

Range start, units* Value, expressed in the currency of settlement

Columns marked with * are hidden by default.

Setting Individual Risk-parameters

"Set Individual Risk-parameters" dialog provides an ability to specify individual risk-parameters for Trading
accounts and Assets for the next day after the current date.

To open the dialog first open the Individual Risk-parameters table (Query > Risk Parameters > Individual
Risk-parameters) and then select Set Individual Risk-parameters command in the table's context menu or
in Administration submenu of the Action menu.

As a result new values appear in the Individual Risk Parameters table.

Set market individual Risk-parameters

Set market individual Risk-parameters dialog for Firm's User .

To open the dialog first open the Market Individual Risk-parameters (new) table (Query > Risk Parameters
> Market Individual Risk-parameters (new)) and then select Set market individual Risk-parameters
command in the table's context menu or in Administration submenu of the Action menu.

As a result new values appear in the Market Individual Risk-parameters (new) table.
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Table 13.9. Elements of the "Set market individual Risk-parameters" dialog

Element Description
Firm Firm name

Trading account Trading account identifier

Asset Select the asset to set risk-parameters

Set market individual risk-parameters Set the flag to enter values of parameters

Concentration limit Information field: coefficient value set for the
current date. Not limited for the third level.

Risk rate for price decrease, % Information field: rate value set for the current date.

Risk rate for price increase, % Information field: rate value set for the current date.

Yes Accept changes of market individual risk-
parameters from current date.

Close Cancel all changes and close the dialog.
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Set Interproduct spread discount rate

Set Interproduct spread discount rate for Firm's User .

To open the dialog first open the Individual Risk-parameters (new) table (Query > Risk Parameters >
Individual Risk-parameters (new)) and then select Set Interproduct spread discount rate command in the
table's context menu or in Administration submenu of the Action menu.

As a result new values appear in the Individual Risk-parameters (new) table.

Table 13.10. Elements of the "Set Interproduct spread discount rate" dialog

Element Description
Firm Firm name

Trading account Trading account identifier

Asset Select the asset to set risk-parameter

Bank Account Information field: bank account for which parameter
is setting

Discount rate, % Information field: rate value set for the current date.

Yes Accept changes of risk-parameters from current
date.

Close Cancel all changes and close the dialog.

Accept Asset as Collateral

Set Accept Asset as Collateral flag for Firm's User .

To open the dialog first open the Individual Risk-parameters (new) table (Query > Risk Parameters >
Individual Risk-parameters (new)) and then select Accept Asset as Collateral command in the table's
context menu or in Administration submenu of the Action menu.

Please note, that status of asset as collateral will change starting from the next trading day.

As a result new values appear in the Individual Risk-parameters (new) table.

Table 13.11. Elements of the "Accept Asset as Collateral" dialog

Element Description
Firm Firm name

Trading account Trading account identifier

Asset Select the asset to set risk-parameter

Bank Account Information field: bank account for which parameter
is setting

Accept Asset as Collateral Set the flag to accept asset as collateral starting
from next trading day

Yes Accept changes from current date.

Close Cancel all changes and close the dialog.

Percent Risk Calculation

Percent risks calculation by bank account flag for Firm's User .
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To open the dialog first open the Bank Accounts table (Table > Positions > Bank Accounts) and then select
Percent Risk Calculation command in the table's context menu or in Administration submenu of the Action
menu.

As a result new value appear in the Bank Account table.

Table 13.12. Elements of the "Accept Asset as Collateral" dialog

Element Description
Bank Account Select the bank account to set the flag

Calculate percent risks Set the flag to calculate percent risks from current
date

Yes Accept changes from current date.

Close Cancel all changes and close the dialog.
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Chapter 14. Users and Clients of the Firm

Users

The Users table lists all the traders of own firm that have access to this market.

To open the table select the Users item in the Table menu or click the  button on the toolbar.

Table 14.1. "Users" table columns description

Column Description
Firm Firm short name

User name User name.

User ID User identifier in the Trading System.

User type Type of the user

Status User status:

[empty] – operations allowed;

= – not allowed.

Trading operations Flag: "Trading operations allowed/not allowed".

Active Flag indicating whether the user is currently logged-on.

Workstation Workstation IP-address.

Gateway Gateway IP-address.

Client code* Client code assigned by the broker and linked to this user ID

CODCD mode* Status of Cancel on Drop-Copy Disconnect mode.

COD-Mode* Status of Cancel on Disconnect mode.

COD-Mode Subscr.* Type of Cancel on Disconnect mode subscription (COD-mode). COD-
mode - cancel active orders on disconnect or logoff from Trading
System. Available types are "Not used", "Always" and "On Demand".

External ip address* User's external IP address

Firm ID Firm identifier in the Trading System.

Group* Group ID the user belongs to.

Master This user is Sponsored Master Access Master

Master User ID 1 First Master User ID for Sponsored Master Access

Master User ID 2 Second Master User ID for Sponsored Master Access

Role* User's role.

Change password on next logon* User is required to change they password on next logon to the trading
system

• Yes - User is reqired,

• ' ' - No.

Users (clear.sys)

The Users (clear. sys.) table lists all the traders of own firm that have access to Clearing System.

To open the table select the Users (clear. sys.) item in the Table menu or click the  button on the toolbar.
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Table 14.2. "Users (clear.sys)" table columns description

Column Description
Firm Firm short name

User name User name.

User ID User identifier in the Trading System.

User type Type of the user

Status User status:

[empty] – operations allowed;

= – not allowed.

Trading/clearing operations Flag: "Trading/Clearing operations allowed or not allowed" by firm
manager.

Active Flag indicating whether the user is currently logged-on.

Workstation Workstation IP-address.

Gateway Gateway IP-address.

Client code* Client code assigned by the broker and linked to this user ID

External ip address* User's external IP address

Firm ID Firm identifier in the Trading System.

Group* Group ID the user belongs to.

Role* User's role.

Client Codes

The "Client Codes" table lists clients, registered as members of the firms.

To open the table perform one of the following actions:

• select the Client Codes item in the Firm Tables submenu of the Table menu;

• click the  button on the toolbar.

Table 14.3. "Client Codes" table columns description

Column Description
Firm Firm name

Client code Client code assigned by the broker

Type Form of client identification

Details Client taxpayer number or other document

Firm Id* Firm Identifier

Clearing firm Clearing firm ID

Cross trading Client has allowance to cross / passive trading (Yes/No/Passive)

DFI Access Client has access to Derivatives financial instruments

Qualified Investor Client is a qualified investor (yes/no)

Status Status: client active or suspended

Subdetails Details: client taxpayer number or passport number or other document

Trading blocked Flag of block access to trading



Users and Clients of the Firm 19.09.2025

159

Column Description
Clientcodes category Clientcodes category

Columns marked with * are hidden by default.

Stop List of CLients

The "Stop List of CLients" table lists clients, who is denied service by trading member.

To open the table select the Stop List of CLients item in the Firm Tables submenu of the Table menu;

Table 14.4. "Stop List of Clients" table columns description

Column Description
Firm Firm ID

Details Client taxpayer number or passport number or other document

Subdetails Client taxpayer number or passport number or other document

Firm Id* Firm Id

Columns marked with * are hidden by default.

User-TrdAcc

"User-TrdAcc" table provides an information on dependencies between users and trading accounts.

To open the table select User-TrdAcc item in the Firm Tables submenu of the Table  menu;

Table 14.5. "User-TrdAcc" table columns description

Column Description
Firm Firm name

User ID User ID

User Id User Id

Trading account Trading account number

Firm Id* Firm Identifier

Columns marked with * are hidden by default.

Suspend and unsuspend trading for user

Firm Manager has privileges to suspend and unsuspend trading for users of the firm. To do that select
one or several records in the Users table, and then execute the needed command: Unsuspend Trading or
Suspend Trading from the table's pop-up menu or from Administration submenu of the Action menu.

Confirmation dialog provides an option to withdraw orders of the selected user.
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Chapter 15. NCC integration module (Unified Collateral Pool project)
NCC integration module allows user to interact with the National Clearing Centre system directly from the
MOEX Trade Currency terminal interface.

Installation, update, Uninstall
Installation

NCC integration module is included into MOEX Trade Currency installation package.

To install the module set the NCC integration module flag at the "Select Additional Tasks" step of the
terminal installation.

Please note that NCC module installation is not available during the terminal auto update.

Update

Once installed the NCC integration module may be updated automatically similarly to core terminal
functionality.

Program checks for updates automatically every time it connects to the Trading System. For stability
purposes and in order to have access to all the market features, it is highly recommended to install all the
suggested updates.

Uninstall

To uninstall the NCC integration module please run MOEX Trade Currency installation file again and
uncheck the NCC integration module flag at the "Select Additional Tasks" step.

Activation and establishing the connection
To activate NCC integration module and establish the connection to the National Clearing Centre system
open the Tools > Options menu, then proceed to the NCC tab and set the NCC client enabled flag.

Table 15.1. Elements of the NCC tab on Options form

Element Description
NCC Server name and port
(optional)

NCC server system address and port number (if it is needed) which will
de used to establish connection.

NCC authentication Server name
and port (optional)

NCC server system address and port number (if it is needed) which will
de used to authenticate user.

Use MOEX Passport
authentication

Authorization for MOEX Internet services users.

To this function process properly, make sure that there is network
access to https://passport.moex.com (443 port).

Validata profile Select created at Sertificate Store profile that provides cryptographic
keys and sertificates that support authoirity to operation in NCC
system.

Use specific login/password

• User

• Password

Specify Login ID and password for passport.moex.com, if it is needed.

Click OK to save changes. The new NCC item will apear in the top menu.

To reset all changes which was made on form use Cancel button.
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Transfer of profile of positions on assets

"Request for transfer of profiles of positions on assets" dialog may be used to compose and submit the
request for profiles of assets transfer.

Profile of assets is a part of member's collateral which is accounted on the Unified Collateral Settlement
Account (BankAcc). This part of collateral is used to settle member's liabilities on markets ivolved into
Unified Collateral Pool project. Transfer of assets profiles is performed within one Settlement Account
between different markets.

The submitted request is displayed in the Operation log and then after being received by the NCC system
- in the List of requests for profiles transfer.

Request may be successfully executed only in case its execution doesn't lead to negative Single Limit value
and collateral insufficiency on Unified Collateral Settlement Account for the corresponding market.

To open the dialog do one of the following:

• Select following commands sequentially in the top menu: NCC > Request for transfer of profiles of
positions on assets;

• Press Ctrl+F6.

Table  15.2.  Elements of the "Request for transfer of profiles of positions on assets"
dialog

Element Description
Document date Current date in the trading and clearing systems.

Request ID Request (document) number assigned by the terminal. This number is
unique within one trading day.

Trading account Identifier of the trading/clearing account, Unified Collateral
Settlement Account is bound to.

Bank account Information field: Unified Collateral Settlement Account (BankAcc)
which is bound to selected trading/clearing account.

Participant code Clearing participant code (identifier) on whos behalf the request is
submitted.

First market / Second market Specify first market (from which the assets profile will be withdrawn)
and second market (assets profile will be transferred to).

List of changes A list of changes on clearing registers of the first and second markets.

Click "Add change" to specify changes on a particular assets/positions:

• Clearing register - identifier of the clearing register.

For Derivatives market - clearing register section code (7
characters). Obligatory parameter.

For FX market - 2nd level bank account (settle code). Optional
parameter.

For Equities market list of changes must be explicitly specified.

• Asset - asset that will be transferred.

• Value - specify positive or negative value on which position on the
selected asset will be changed.
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Element Description
• Х - delete the row.

ОК Submit the request (requires confirmation). Transactions confirmation
can be disabled in the program options.

Cancel Discard all changes and close the dialog.

Transfer of collateral

"Request for transfer of collateral" dialog may be used to compose and submit the request for collateral
transfer between participant's settle codes.

Securities, commodities, cash (Russian rubles and foreign currencies) and precious metals may be accepted
as a collateral for the "Unified Pool" project. Collateral may be transferred between different settle codes
(Bank accounts).

The submitted request is displayed in the Operation log and then after being received by the NCC system
- in the List of requests for transfer of collateral.

To open the dialog do one of the following:

• Select following commands sequentially in the top menu: NCC > Request for transfer of collateral;

• Press Alt+F6.

Table 15.3. Elements of the "Request for transfer of collateral" dialog

Element Description
Document date Current date in the trading and clearing systems.

Request ID Request (document) number assigned by the terminal. This number is
unique within one trading day.

First market Specify the market from which collateral will be withdrawn.

Second market Specify the market, collateral will be transferred to.

Asset Asset (currency, precious metal) identifier.

Sum / Amount Sum or amount of cash/precious metals that should be transferred.

First bank account (debit) Unified Collateral Settlement Account from which the selected assets
will be withdrawn.

Second bank account (credit) Unified Collateral Settlement Account, the selected assets will be
transferred to.

List of changes (for first/second
settle code)

Optional parameter. Click "Add change" to specify changes on a
particular clearing register:

• Clearing register - identifier of the clearing register.

For Derivatives market - clearing register section code (7
characters).

For FX market - 2nd level bank account (settle code).

For Equties market - empty.

• Value - specify a positive value on which position on the selected
asset will be changed.

• Х - delete the row.
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Element Description
ОК Submit the request (requires confirmation). Transactions confirmation

can be disabled in the program options.

Cancel Discard all changes and close the dialog.

Operation Log

Operation log displays a list of operations (requests) submitted by participant to the NCC system and their
basic detalis: date, status, time etc.

The detailed information on requests received by the NCC system is presented in the Return and transfer of
profiles of positions on assets and Return and transfer of collateral tables depending on the operation type.

To open the table select the following commands sequentially in the top menu: NCC > Operation Log .

Table 15.4. "Operation Log" table columns description

Column Description
Unique identifier Unique identification number of the operation.

Request date Date of the request (trading day).

Request number Number of the request assigned by the terminal. This number is unique
within one trading day.

Request type ID "AssetTransfer" - collateral transfer. "ProfileTransfer" - transfer of
profiles of positions.

Status Operation (request) current state:

• RS_SGNW - Waiting for signature;

• RS_SGNC - Verification of signature;

• RS_RJCT - Rejected;

• RS_CNCL - Canceled;

• RS_RCVD - Received;

• RS_PROC - Processing;

• RS_EXEC - Executed;

• RS_FAIL - Failed.

Time to received requerst Time when request was received by the NCC system.

Processing time Time when request was processed by the NCC system.

Reply code Reply code

Reply message Additional information on operation

Recieved in Clearing system Flag: request recieved in Clearing system

List of requests for profiles transfer

This table displays the current state of requests for profiles transfer submitted by participant to the NCC
system.

To open the table select the following commands sequentially in the top menu: NCC > Return and transfer
of profiles of positions on assets .
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Table  15.5.  "Return and transfer of profiles of positions on assets" table columns
description

Column Description
Request number Request number.

Ducument state Current state of the request: registered / processing / executed /
rejected.

Ducument date Date of the document

Document number Document number assigned by the terminal. This number is unique
within one trading day.

Reply code Reply code

Reply message Additional information on operation

Bank account Bank account (Unified Collateral Settlement Account) identifier

Trade clearing account Identifier of the trading and clearing account (TrdAcc)

List of requests for collateral transfer

This table displays the current state of requests for collateral transfer submitted by participant to the NCC
system.

To open the table select the following commands sequentially in the top menu: NCC > Return and transfer
of collateral .

Table 15.6. "Return and transfer of collateral" table columns description

Column Description
Request number Request number.

Ducument state Current state of the request: registered / processing / executed /
rejected.

Document date Date of the document

Document number Document number assigned by the terminal. This number is unique
within one trading day.

Reply code Reply code

Reply message Additional information on operation

Write-off bank account Bank account (Unified Collateral Settlement Account) from which
collateral is withdrawn

Write-off market Market from which collateral is withdrawn: FU (derivatives), CU (FX),
EQ (equties), CO (commodities).

Enrollment bank account Bank account (Unified Collateral Settlement Account) collateral is
transferred to.

Enrollment market Market, collateral is transferred to: FU (derivatives), CU (FX), EQ
(equties), CO (commodities).

Asset code Asset (currency, precious metal) identifier

Sum/count of assets Amount of asset in transfer
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Chapter 16. Market-Maker Obligations

Market Maker Stats (extended)
Table contains detailed information on Market Maker's obligations on the market.

To open the table perform one of the following actions

• select the Market Maker Stats (extended) item in the Firm Tables group of the Table menu

• select Market Maker Stats (extended) item in the Signals list.

Table 16.1. "Market Maker Stats (extended)" table columns description

Column Description
Firm Id Firm Identifier

Firm Firm name

Board Board ID for the security

Security Security ID

Scheme Name of the market-making scheme

Agreement number Number (ID) of a market-making agreement

Agreement date Date of the market-making agreement conclusion

MGF 1 Minimal volume of market-maker's order in lots.

MGF 2 Additional minimal volume of market-maker's order in lots.

Threshold value, lots When the threshold value of trades is exceeded then the market-
maker's obligations either change from two-sided to one-sided or he/
she is released from obligations. Expressed in lots.

Threshold value, rub. When the threshold value of trades is exceeded then the market-
maker's obligations either change from two-sided to one-sided or he/
she is released from obligations. Expressed in Rubles.

Max spread 1, % Maximum spread allowed for the market-maker, %

Max spread 2, % Second maximum spread allowed for the market-maker, %

Max spread 3, % Third maximum spread allowed for the market-maker, %

Max spread Max spread, RUB

Min % of fulfillment Minimal percentage of fulfillment

Spread, % Current market-maker's spread expressed in percent

Spread Current market-maker's spread, Rubles

Best bid price Best bid price

Best ask price Best ask price

Minimum allowed Minimum allowed price of active limit buy order

Maximum allowed Maximum allowed price of active limit sell order

Buy volume Total volume of active limit buy-orders, expressed in lots

Sell volume Total volume of active limit sell-orders, expressed in lots

Total breach time Total time during the current Trading Session when the market-maker
was not complying with his/her obligations

Compliance time Total time during the current Trading Session when the market-maker
was complying with his/her obligations

Volume Current total volume of trades, in lots
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Column Description
Value, rub. Current total value of trades, in Rubles

% of fulfillment Fulfillment percentage

Left time to fulfillment Time left to fulfill obligations

Update time Update time

Obligations fulfilled Flag showing if obligations are being fulfilled

Spread Type Type of the spread

Board Id* Trading Board Identifier

Security Id* Security Identifier

Columns marked with * are hidden by default.
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Chapter 17. Tools and Additional Functions

Bank Account Filter

The trader terminal has feature for bank account global filtration applies to all displayed information (orders,
trades, positions etc.)

Select the required settlement ID from the drop-down list in BankAcc Filter panel on the Statusbar to apply
Bank Account filter:

BankAcc panel can be disabled by command in the Toolbars item of the View menu in the main menu.

To enable bank account filtration do one of the following:

• run Apply BankAcc Filter command in the Tools menu of the main menu;

• select row in "Bank Accounts" table and run Apply Bank Account command in the context menu;

• press the Ctrl+F8 keyboard shortcut.

Do one of the above actions again to disable bank account filtration.

Charts

All Trades Chart

To open the chart for all trades first select a security in one of the following tables: "Securities" "Trades",
"All Trades" (by board) , "Trades by Security", "Orderbook" and then do one of the following:

• click the  button on the toolbar;

• select the "All Trades Chart" command in the "Table" menu;

• select the "All Trades Chart" item in the context menu of the table.
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If connection to the information and statistical server is enabled in program options then the chart will
include historical data.

To change the chart interval use the chart popup menu or + and - hotkeys. To change the scale also use the
popup menu or Ctrl +/Ctrl - or Ctrl+mouse wheel hotkeys.

The chart can be scrolled either using the mouse wheel or with click-and-drag mouse action.

Scrolling and scaling also can be performed with a scrollbar and navigator at the bottom of the form. To
scroll through the chart, move the navigator, dragging it on the middle. To scale the chart move the borders
of the navigator.

All the chart customization options are available in the Properties dialog.

Using the View - Toolbar - Charts command it is possible to show the separate toolbar for charts.

Chart properties

Appearance

Table 17.1. "Appearance" tab elements

Element Description
"Title" frame
Show title Uncheck the box to hide the window title, including "Close", "Minimize"

and "Maximize" buttons.
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Element Description
Top Title on the top of the window. This command can also been executed

from the window title context menu (double click the window title).

Left Title on the left of the window. This command can also been executed
from the window title context menu (double click the window title).

Tiny Minimize the window title. This command can also been executed from
the window title context menu (double click the window title).

"Chart" frame
Interval Select the needed chart interval.

Zoom Horizontal zoom.

Show axis Show the value axis. If checked - select "Left" or "Right".

Show time Show the time axis.

Show grid Show grid on the chart

Show legend (except All Trades
Chart)

Show legend of the chart

Style (only for All Trades Chart) Select the needed chart style: Candles, Bars, Lines

"Fonts and colors" frame
List of elements Select the element to customize font and color for.

Color/para Select standard or custom color for selected element.

Font Select font, style and size for selected element.

Technical Analysis Indicators

Average Directional Movement

The Average Directional Movement index (ADX) is an indicator of trend strength in a series of prices of a
financial instrument.

Bollinger Bands

Bollinger Bands can be used to measure the highness or lowness of the price relative to previous trades.
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Commodity Channel Index

Commodity Channel Index (CCI) is a versatile indicator that can be used to identify a new trend or warn
of extreme conditions.

DeMarker

An indicator that compares the most recent price action to the previous period's price in an attempt to
measure the demand of the underlying asset.
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Envelope

Envelope Technical Indicator is formed with two Moving Averages one of which is shifted upward and
another one is shifted downward. The selection of optimum relative number of band margins shifting is
determined with the market volatility: the higher the latter is, the stronger the shift is..

MACD (Moving Average Convergence/Divergence)

Moving Average Convergence/Divergence indicator is used to spot changes in the strength, direction,
momentum, \ and duration of a trend in a stock's price.
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Momentum

The Momentum indicator is a rate of change indicator, that is designed to identify the strength of a price
movement.

Moving Average

The Moving Average Technical Indicator shows the mean instrument price value for a certain period of time.
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Parabolic SAR

The parabolic SAR is a technical indicator that is used to determine the direction of an asset's momentum
and the point in time when this momentum has a higher-than-normal probability of switching directions.

Price Oscillator

The Price Oscillator displays the difference of two moving averages in percentages.

Rate of Change

The Rate of Change (ROC) is a simple technical indicator that shows the percentage difference between
the current price and the price n periods ago.
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Relative Strength Index

Relative Strength Index is a technical momentum indicator that compares the magnitude of recent gains
to recent losses in an attempt to determine overbought and oversold conditions of an asset.

Standard Deviation

Standard Deviation measures volatility statistically. It shows the difference of the values from the average
one.
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Stochastic Oscillator

A technical momentum indicator that compares a security's closing price to its price range over a given
time period.

William's Percent Range

Williams’ Percent Range Technical Indicator (%R) is a dynamic technical indicator, which determines
whether the market is overbought/oversold. Williams’ %R is very similar to the Stochastic Oscillator. The
only difference is that %R has an upside down scale and the Stochastic Oscillator has internal smoothing.
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"SMA Limits" dialog
Sponsored Market Access (SMA) functionality includes pre-trade checks that firm administrator
(Master_ID) sets for SMA-users (SMA_ID) of the firm.

SMA users and firm administrator have view access only to security codes restrictions, white and black lists
of client codes for users.

To open the dialog perform one of the following actions:

• Select following actions sequentially in the main menu:

Action > Administration > SMA limits;

• Select "SMA limits" item in the context menu of the "Users" table;

• press Shift+Ctrl+L hotkeys.
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It is possible to manage SMA limits both for a user and for a User Group. Use the selector on the left frame
to set limits managing method "User" or "User Group".

Also it is possible to restrict user or group of users by maximum transaction rate. Use the "Transaction rate
limit" field on the left frame of the dialog. "Turn on restrictions" check box allows the firm administrator
to manage all the active restrictions, including those set with client's Personal Cabinet. All of the current
active restrictions are marked with the green  marker.

The right frame displays the limits list of the current type. Firm administrator only is able to edit these lists.
Other users have view access only to these lists.

To edit lists of limits, check the "Turn on restrictions" flag. Turning down restrictions leads to deleting all
the records in the specified list. Administrator will be informed with additional dialog. Restrictions that have
not set yet are turned into bold.

Table 17.2. SMA limits types and parameters

Limit type Parameters Note
Order limits • Security Id

• Security

• Price limit up

• Price limit down

• Max order quantity

• Max order value

• Max market order quantity

• Max market order value

• Max order values today

• Current order value

This limit might be set
with the dialog.

"Current order value" field
is filled automatically
with Trading System
data.

Max. security positions • Trading account

• Security Id

• Security

• Buy Limit

• Sell Limit

• Planned Buy

• Planned Sell

• Buy Limit (net)

• Sell Limit (net)

• Planned Buy (net)

• Planned Sell (net)

This limit might be set
with the dialog.

"Planned Buy" and
"Planned Sell" fields are
filled automatically with
Taring System values.

Max. money positions • Trading account

• Buy Limit

This limit might be set
with the dialog.
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Limit type Parameters Note
• Sell Limit

• Planned Buy

• Planned Sell

"Planned Buy" and
"Planned Sell" fields are
filled automatically with
Taring System values.

Client code limits • Client code This limit might be set
with client's Personal
Cabinet

List of boards • Board Id

• Board

This limit might be set
with the dialog.

List of security codes • Security Id

• Security

This limit might be set
with client's Personal
Cabinet

List of securities • Board Id

• Board

• Security Id

• Security

This limit might be set
with the dialog.

Change password for firm admin
Firm administrator has option to manage firm users passwords.

To open the dialog,process the following:

Select Change password command in the "Users" table conext menu.

Table 17.3. Elements of the "Change password" dialog

Field Description
Trader Choose Name and Identifier of a trader who is requred to change

password from the drop-down list.

Password Enter the new password

Show password Set the flag to show symbols of the password

Force password change at next
login

Set the flag to force user change password to their own at next login
to the trading system.

Yes Accept changes of user password and close the dialog.
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Field Description
Close Cancel all changes and close the dialog.

Order Validation

Setting Up Order Validation Parameters

To define custom condition of pre-entry order validation do one of the following:

• select the following commands sequentially in the top menu: Tools > Order Validation Parameters >
Setup;

• select the Add/Load item in the popup menu of the Order Validation Parameters table

Table 17.4. Elements of the "Order Validation Parameters Setup" dialog

Element Description
Board Trading Board name.

Security Security name.

Set for all securities on the board Order validation parameters will be applied to all the securities
available on selected trading board, except ones with individually
configured validation parameters already specified. If option is enabled
together and datasets mechanism is activated then order validation
parameters will be applied for securities specified in the dataset only.

"Specified:" table Table contains parameters specified for the selected security and
trading board. To edit one of the parameters click the corresponding
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Element Description
row in the table, then validation parameter specifications will be
displayed in the "Setup parameter" group of fields.

Delete Delete the selected row from the "Specified" table.

Delete All Delete all parameters specified for security and trading board from the
"Specified" table.

"Setup parameter" group of fields Edit the specification of selected parameter

Parameter Order parameter to control.

Price - control price value for order entry and algo-packet entry

Lots - control lots quantity in an order

Amount - control order amount expressed in lot currency

Value - control order value expressed in conjugated currency

Parameters available for TWAP orders only:

Lots TWAP - control lots quantity in an algo-packet

Amount TWAP - control algo-packet amount expressed in lot currency

Value TWAP - control algo-packet value expressed in conjugated
currency

Validation type Validation type available for the selected parameter.

Value Value the deviation is calculated from. Not applicable for RANGE, MIN
and MAX validation types.

Deviation, % Deviation (percentage value). Not applicable for RANGE, MIN and
MAX validation types.

Minimum Minimum value for RANGE and MIN validation types.

Maximum Maximum value for RANGE and MAX validation types.

Modify existing parameters Apply settings to securities even for securities with individually
configured validation parameters already specified. This option may
be enabled only in case "Set for all securities on the board" flag is set.

Prohibit breach of the limit If the option is activated then submitting an order that breaches the
specified limit will be prohibited. If this option is disabled, such order
will require additional confirmation but still may be submitted.

High importance In case user attempts to breach the limit, "warning" window will be
displayed.

Apply Apply validation parameter and add the corresponding row to the
"Specified" table.

Load from file Load order validation parameters from the text file. To save order
validation settings to file open the "Order Validation Parameters" table,
and select the following commands sequentially in the top menu Data
Save > File.

Please note that this action requires "Column headers: Identifier"
option in the terminal settings on the Tables tab, and "Use field
ordering of current window" disabled.

Load automatically Load order validation settings from the file specified automatically at
terminal startup.
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Element Description
Close Close the dialog window. All the parameters displayed in the

"Specified" table will be saved, but parameter specification displayed
in the "Setup parameter" group of fields will be lost.

Contents of "Board" and "Security" lists may be limited using "Datasets" mechanism.

After pressing the Set button the parameter will be added to the Order Validation Parameters table.

Order Validation Parameters Table

The Order Validation Parameters table lists all the custom conditions that will be checked on order pre-
entry. These parameters are set up using the Order Validation Parameters Setup dialog.

To open the table select the following commands sequentially in the top menu Tools > Order Validation
Parameters > View.

It is possible to export this table to file (Data > Save > File) in order to load all the parameters next time,
because these settings are not saved. Note: this action requires "Column headers: Identifier" option in the
terminal settings on the Tables tab.

Table 17.5. "Order Validation Parameters" table columns description

Column Description
Board Trading board name.

Security Security for which the order validation parameter is specified.

Parameter Validated parameter.

Validation type Validation type for the selected parameter.

Value Value the deviation is calculated from.

Deviation, % Deviation from Value specified (percentage value).

Minimum Minimum parameter value.

Maximum Maximum parameter value.

Board Id* Trading board identifier

Importance* In case user attempts to breach the limit, "warning" window will be
displayed.

Prohibit breach If the option is activated then submitting an order that breaches the
specified limit will be prohibited. If this option is disabled, such order
will require additional confirmation but still may be submitted.

Security Identifier of the security for which the order validation parameter is
specified.

Administrative Order Validation

Common description

Terminal provides an ability to manage order validation parameters administratively for one or multiple
users. This can be used to set different types of validation for orders submitted by traders, for example
maximim price deviation to market price, or maximum allowed number of lots in the order. Administrative
datasets management is also provided.

Order validation settings are stored in the validation.csv file.

Typical scenario of validation.csv usage::
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1. at connection to the Trading System terminal loads settings from validation.csv, after successful
parameters loading an information pop-up window is shown;

2. changes made using Order Validation Parameters dialog, are stored in RAM of the computer and not
being written to file until the end of the connection session;

3. at the end of the session program writes new configuration to validation.csv .

Creating validation.csv

Creating validation.csv (for later use as administrative source of order validation settings) can be performed
in two ways:

• using terminal GUI: Order Validation Parameters Setup dialog (Tools > Order Validation Parameters >
Setup), then export Order Validation Parameters (Tools > Order Validation Parameters > View) table
content to validation.csv file (Data > Save > File), that should be copied to the shared resource;

• manually: format and description of the file are presented below;

validation.csv file format

  
SECBOARD;SECCODE;PARAMETER;VALIDATION;VALUE;PERCENT;MINIMUM;MAXIMUM;
URGENT;PROHIBITBREACH
CETS;EUR000TODTOM;PRICE;MKTPRICE;;10,00;;;N;N
CETS;EUR000TODTOM;QTY;MAX;;;;300;Y;Y
CETS;GBPRUB_TOD;PRICE;RANGE;;;92,0000;94,0000;N;N

Elements of validation.csv

Parameter Description
SECBOARD Trading board identifier.

SECCODE Security identifier.

PARAMETER Order parameter to control:

PRICE - Price

QTY - Quantity (number of lots)

VALUE - Value

VALIDATION Validation type:

[space] - no validation

WAPRICE - to weighted-average price

PREVWAPRICE - to previous price

LAST - to last price

MKTPRICE - to market price

VALUE - to value

EXCHANGEVAL - to exchange value

RANGE - Range

MIN - Minimum
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Parameter Description
MAX - Maximum.

VALUE Value the deviation is calculated from. Not applicable for RANGE, MIN
and MAX validation types.

PERCENT Deviation (percentage value). Not applicable for RANGE, MIN and
MAX validation types.

MINIMUM Minimum value for RANGE and MIN validation types.

MAXIMUM Maximum value for RANGE and MAX validation types.

URGENT High importance. "Y" - yes, "N" - no. In case user attempts to breach
the limit, "warning" window will be displayed.

PROHIBITBREACH Prohibit breach of the limit. "Y" - yes, "N" - no. If the option is activated
then submitting an order that breaches the specified limit will be
prohibited. If this option is disabled, such order will require additional
confirmation but still may be submitted.

Prohibition of validation.csv modification on traders' side

To prohibit modification and disabling order validation settings on traders' side, the validation.csv file should
be read-only for traders. Also a full path to this resource must be specified in the Windows Registry on
traders' computers (description is given further).

If corresponding changes are made to Windows Registry on trader's computer, in case terminal can not
load validation.csv by any reason, the user session with the trading system will be aborted.

In case validation.csv is loaded successfully, user has read-only access to the Order Validation Parameters)
contents.

Sharing validation.csv

validation.csv may be located:

• on local machine, in the folder that is read-only for trader - terminal supports LFS-formatted paths, for
example " C:\AnyFolder\validation.csv ";

• on shared resource, that is read-only for trader - shared folders and smb-resources should be named as: "
\\Server\SharedFolder ". Terminal supports UNC-formatted paths, and also Long UNC for 64-bit version.

Two scenarios of access to configuration file are provided:

• shared file for all users* - single source of datasets settings for multiple users. In that case file can be
located in arbitrary folder, for example " \\Server\SharedFolder\validation.csv ".

• individual file for a particular user* - separate subfolders with names corresponding to User IDs are
required. In that case the full path to data sets configuration file would be as follows: " \\Server
\SharedFolder\[MoexUserId]\validation.csv ".

* Note: the term "user" refers to User ID in the ASTS Trading System, but not Windows User ID.

Necessary changes in Windows Registry on trader's computer

Administrative order validation management requires some changes in Windows Registry on traders'
computers that should be performed by user with administrative privileges. Specific values should be added
to the following Registry branch:

HKEY_LOCAL_MACHINE\SOFTWARE\MICEX\Trade Currency\

Note: Trader should not have administrative rights on computer and ability to change this Registry branch.

The following keys and values should be added:
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• ValidationPathOverride - REG_SZ - path to the folder, for example " \\Server\SharedFolder ", containing
either common validation.csv file for all users or individual subfolders for different users (name of the
individual folder should not be specified in this value).

If the value is specified user cannot longer modify order validation parameters himself and terminal will
not operate in case validation.csv is missing on the specified location. If not specified - user will have an
ability to change order validation settings himself;

• ValidationPathIsShared - REG_DWORD - "Shared Validation Settings" flag. Possible values are "1" (use
shared validation.csv in specified folder for all users) or "0" (use individual files from subfolders named
as User IDs). .

Example 1:

            ValidationPathOverride=\\Server\SharedFolder
            ValidationPathIsShared=1
        

Settings will be loaded from " \\Server\SharedFolder\validation.csv " for all users.

Example 2:

            ValidationPathOverride=H:\SharedFolder
            ValidationPathIsShared=0
        

Settings will be loaded from individual files located in subfolders with names equal to User IDs
in the Trading System, for example H:\SharedFolder\[MoexUserId1]\validation.csv or H:\SharedFolder
\[MoexUserId2]\validation.csv .

Signals
The notification system can display signals on the following events:

• incoming message;

• alerts;

• errors in dynamic export procedure;

• negotiated deal order received;

• breach of market-maker's liabilities;

• program update is available.

All signals appear on the "Signals" toolbar:

When any of the above listed events occurs then the toolbar begins to blink with red. The button on the
toolbar displays the number of unread messages:

Click the toolbar to open the table realted to the particular event.

Click the arrow on the right side of the toolbar to show the full list of events and their counters. Click any
event to open the related table.
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Alerts

Setting Up Alerts

To add an alert for some event concerning the Securities table select the Alerts > Setup Alert command in
the Tools menu or the popup menu of the Alert Manager or Securities table.

When there is an alert for a security then the following symbol will be displayed near the security name: .

Alert settings are active when the "Check condition" checkbox in its properties is set.

When certain parameter in the Security table matches some of the alerts then a corresponding alert record
appears in the Alert Log and the signal toolbar starts to blink. If the "Interrupt me and show an information
message" checkbox in alert settings is set then the message will pop up.

Table 17.6. Elements of the "Setup Alert" dialog

Element Description
Board Trading board for the security.

Security Name of the security, the alert is set for.
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Element Description
Parameter Select the parameter of the security that will be monitored. Current

value of the selected parameter is displayed to the right of the drop-
down list. Click this value to use it as a condition.

Becomes Condition type and value.

Fire event The alert will be displayed every time the event occurs or only once.

Interrupt me and show an
information message

By default (unchecked) alert message is added to the "Alert log" table
and the toolbar blinks with red. If checked - user's workflow will be
interrupted with the alert message.

Check condition Set the flag to activate monitoring procedure and alert for the time
interval specified ("from" and "to" fields).

Alert name Custom name for the alert.

Contents of the "Board" and "Security" drop-down lists may be limited using "Data sets" mechanism.

Alert Manager

The Alert Manager table lists all the alerts defined by the user.

To open this table select the Alerts > Alert Manager item in the Tools menu.

Table 17.7. "Alert Manager" table columns description

Column Description
Security Security, the alert is set for.

Board Trading board for the security.

Parameter Parameter that is monitored.

Relation Parameter value comparison condition to the reference value.

Value 1 Reference value.

Value 2 Second reference value (for "between" checks only).

Fire mode Alert is displayed every time the event occurs or only once.

Importance Importance (interrupt) status of the alert.

Enabled Alert enabled/disabled.

Start Time Start of the time interval during which the parameter is monitored.

Stop Time End of the time interval during which the parameter is monitored.

Is Active Parameter is currently monitored (current time is between Start and
Stop time).

Name Alert's name.

Alert Log

The Alert Log table lists all the events when alerts have been triggered.

To open this table select the Alerts -> Alert Log item in the Tools menu or in the popup menu of the Alert
Manager table.

Table 17.8. "Alert Log" table columns description

Column Description
Importance Importance (interrupt) status of the alert.
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Column Description
Time Time of the alert.

Security Security, the alert is set for.

Board Trading board for the security.

Reason Parameter the alert was displayed for.

Name Alert's name

Instant Messaging

Sending Messages

To send a message to another trader of own firm or to all the traders of other firm select the following
commands sequentially in the top menu Action > Send Message.

Table 17.9. Elements of the "Send Message" dialog

Element Description
All Send message to all the traders of all Exchanges. Option availability

depends on user's permissions.

Exchange's Firms Identifier of the Exchange. Message will be delivered to all traders
of the particular Exchange. Option availability depends on user's
permissions.

Group of Firms Send message to several firms. Option availability depends on user's
permissions.

Firm Identifier of the firm. Message will be deliverd to all traders of the firm
specified.

User Message will be deliverd to particular user.

Auto word wrap Automatic word wrapping in the message text area.

Message text 256 symbols maximum allowed.

Urgent/Important Urgent/Important message will be displayed as a pop-up window to
the recipient.

Viewing Messages

The Messages table lists all the incoming and outgoing user's messages.

To open the table select Table > Messages in the top menu.

Table 17.10. "Messages" table columns description

Column Description
In/Out Incoming or outgoing message.

Importance Urgent/Important message indicator.

Time Time when the message was dispatched.

From User identifier of the message sender.

Text Text of the message.

To all Message is addressed to all traders of all Exchanges.

To user User Id of the message recipient.

To firm Firm Id of the message recipient.



Tools and Additional Functions 19.09.2025

188

Column Description
To firms of exchange Id of the regional Exchange the message is addressed to.

Firm Id * Identifier of the firm.

Columns marked with * are hidden by default.

Viewing messages

Double click the corresponding line in the "Messages" table to view the message text. Such a window pops
up automatically when the incoming message with the urgency flag is received.

Table 17.11. "Message" window elements

Element Description
Window title: Message - X/Y X - sequential number of the message (line in the "Messages" table).

Y - total number of incoming and outgoing messages in the table.

From Message sender ID.

To Message recipient ID.

Sent / Received Time when the message was sent/received.

Wrap wordss Automatic word wrapping in the message text area.

Back Open the previous message.

Next Open the next message.

Reply Send the reply to the message sender.

Forward Send this message to the other recipient.

Close Close the dialog.

MOEX Chat Client

The interface of the MOEX chat client is available in Russian only.

Activation and connection

1. Select the Connect item in the Chat menu of the main menu.

2. When connecting for the first time or if the Chat client enabled box on the Chat tab of the  Options
window is not checked, the activation dialog will be displayed. Press the Yes button.

3. The MOEX chat functions are available after registration or login to the MOEX web services. The
authorization dialog will be displayed. Please enter your MOEX Passport authorization data in the User
and Password fields.
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The authorization data provided with the "Use specific login/password" option in the ISS tab of the
Options window can be used by the terminal.

Data Export

Error Messages

To copy Error Messsage content to the clipboard press Ctrl+C. This function can be used when contacting
the Support Team.

Save Table Data

Save to file

To save the contents of a table use Save -> File command in the Data menu or press Ctrl+S. The standard
"Save File" dialog will appear.

Specify the location and file name, select one of the file formats and click "Save".

File formats for table data export:

• CSV (comma-separated) - *.csv

• Text files (tab-separated) - *.txt

• XML files - *.xml

• DBF (dBASE III) - *.dbf

• Microsoft Excel workbook - *.xls

Copy to clipboard

To copy the whole open table to the clipboard select the Save -> Clipboard command in the Data menu
or press Shift+Ctrl+C.
s

Dynamic Data Export

Export Setup

To create a procedure for dynamic data export to database or Excel select the Data -> Dynamic Export -
> New Export command in the main menu or the New Export command in the popup menu of the Export
Manager table.
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Export setup is designed as a step-by-step wizard. On the first step select a table to export and the export
type. The following steps will differ depending on the chosen type of export procedure.

Two types of export are supported:

• ADO (Active Data Objects) should be used to export data to any database management system which
has a driver installed on the local PC. Standard ODBC driver is also supported.

• DDE (Dynamic Data Exchange) should be used to export data to Microsoft Excel or to DDE servers.

Besides support of export to DDE server, the program itself can function as a DDE server to provide other
applications with access to market data inside this trader terminal.

When selecting ADO export:

First select connection source - either an existing data link file (.udl or .dsn) or specify a custom connection
string.
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On the next step select the destination table in the database and specify the mapping between local table
fields and fields in the database. Based on the type and names of fields in the database the program tries
to guess some of the mapping. Key fields are displayed in bold font and they must have a mapping to the
database. Mapping of other fields is optional.

Note: it is not recommended to use reserved words of the DBMS while exporting as column names in the
destination table.

When selecting DDE export:
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First select the recipient application: Microsoft Excel or external DDE server. When exporting to Excel enter
or select file name and/or sheet name. If no file name is given then every time the export starts a new file
will be created. If no sheet name is given while the file name has been indicated then every time the export
starts a new sheet will be added. For DDE server appropriate service and topic names should be specified.
Select table fields that should be exported and reorder them if needed. This dialog also contains additional
options such as server timeout, column caption settings (do not export, export IDs, export names) and the
checkbox to add an empty row to the Excel sheet.

Notes on the export to Excel:

• each sheet can contain only one table;

• export cannot start when there is any dialog box open in Excel or if any cell is being edited;

• do not edit sheets that are used for export, link to data from other sheets instead;

• if group names are used in Excel and the range of these groups breaks when new data is exported then
use the "Add empty row" option; also use this option in case cells that are referenced from other sheets
keep shifting.

After clicking Next the confirmation dialog will be shown. It also provides several additional options:

• Auto start export - automatically start dynamic export after connecting to the Trading System.

• Start delay, sec - auto start delay. Default value: 60 sec.

• Start export now - start dynamic export immediately after pressing Finish button.

All the configured export procedures can be accessed, reconfigured, disabled or deleted from the Export
Manager table using the table's popup menu or commands from the Data -> Dynamic Export menu. All the
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events concerning the dynamic export such as export start, stop or error are stored in the Export Log table.
When an export error occurs, a notification appears on the signal toolbar.

Developing own DDE servers

Besides support of the standard connection and disconnection functions the DDE server must support the
following transactions:

а) XTYP_POKE. The item name (hsz2) will contain a string with data range in MS Excel
format: RaCb:RyCz, where a <= y and they are both inside the 1..n range where n - the total
number of rows; b <= z and they are both inside the 1..m range where m - number of fields
being exported. Data (hdata) is delivered in XlTable format, see: http://digital.ni.com/public.nsf/
ad0f282819902a1986256f79005462b1/88cfa6094f6b5030862566fa002279e0/.

б) XTYP_EXECUTE. The server may also receive the following commands (hdata):DeleteAll - delete all the
previously received data; DeleteRow(x) and InsertRow(x) - delete or insert row inside the (1..n) range.

Export Manager

The Export Manager table lists all the configured export procedures and allows users to reconfigure, pause,
stop or delete them using the popup menu or commands from the Data -> Dynamic Export menu.

To open the table select the Data -> Dynamic Export -> Export Manager item in the main menu.

Table 17.12. "Export Manager" table columns description

Column Description
Number Indentification number of the export procedure.

Autostart "Yes" - export procedure is sutomatically started after connecting to
the Trading System.

Delay Export autostart delay.

Status Current export status

Type Type of the export: ADO or DDE.

Source Source table.

Target Receiver application.

Comments Information on current export status or error message.

Updated Time of the last data transfer from Source to Target.

Export Log

All the events concerning the dynamic export such as export start, stop or error are stored in the Export
Log table. When an export error occurs, a notification appears on the signal toolbar.

To open the table select the Data -> Dynamic Export -> Export Log item in the main menu.

Access from other programs to market data

Besides the dynamic export from this program into other applications, in program options it is possible
to enable the program to function as a DDE Server. That means that other applications such as technical
analysis software of MS Excel will be able to access data in the Securities table.

To connect to this DDE server use the following parameters:

• service name: MXCurrency
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• topic: field ID in the Securities table; to find this ID either use the dynamic export wizard or save the table
data to file with IDs as captions;

• item: BoardID.SecurityID - these values can be found in the Securities and Boards tables.

For example, the following formula will insert the last trade rate for EUR/RUB TOD into MS Excel
=MXCurrency|Last!CETS.EUR_RUB__TOD.

Quick Search in Tables

The quick search function helps to find values in particular columns of long tables.

To start searching, open a table, go to any cell in the required column and start typing the symbols to look
for. The table will scroll to the first matching value. Search in case insensitive.

The search dialog box can be also called from the main menu using the Data -> Find command.

Security Finder

To find a security enter a part of its name, ID or registration number in the search field which default location
is in the top-right or bottom-right corner of the program window.

To show or hide this search field use the View -> Toolbars -> Security Finder menu item.

After pressing the  button or hitting Enter a list of matching securities will appear.

Click a security to open a table with listing of this security on different trading boards. When connection
to the informational and statistical server is enabled in program settings then the search will be performed
on all the available financial markets.

Print Table

To print any table select the Print item in the Data menu or press Ctrl+P. The print preview window will
open first.

Tables are printed according to their current layout on the screen, including the column width and filters
applied.

List of Open Windows

To view the full list of open tables and switch to any of them use the Go to Window command in the Windows
menu or press Alt+0.
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Use the drop-down list to display windows from a particular sheet or all the open windows. Type text in the
search field to filter the list.

Double click any window to go to it.

Transaction Log

The Transaction Log table lists all the transactions that have been sent by the program to the Trading
System since the beginning of the trading session.

To open this table select the Transaction Log item in the Session menu.

Transactions that have failed or returned an error are highlighted in red.

Table 17.13. "Transaction Log" table columns description

Column Description
# Record number

Sent Time when transsaction was submitted to the Trading System.

Action Transaction description.

Parameters Transaction parameters.

Execution time Transaction execution time (microsecond).

Status Execution status:

+ – success
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Column Description
! – failed.

Trading System Reply Trading System Reply message.

Double click a transaction to view its parameters. Title background of the Transaction Parameters dialog
for orders corresponds to the order direction: green for buy orders and red - for sell orders.

Change Password

To change the user password in the Trading System select the Change Password command in the Session
menu.

Table 17.14. Elements of "Change Password" form

Element Description
Current Password Current User's Passport

New Password Enter the new password.

Repeat Password Repeat the password to avoid misprints.

Show password Set the flag to see characters of the password.

Attention! Check the current keyboard layout and the state of the Caps Lock key when entering the
password.

Connection Information

To view details about the current connection to the Trading  and Clearing System select the Connection
Info item in the Session menu.

The Connection Information dialog box shows the connection method (through private network over
the Internet, or over MOEX VPN), Gateway server name and security details. When connection uses an
electronic digital signature then the Server Certificate button will be available to view the server and client
certificates.

Press the Show Options button to view the server IP address, traffic details and mtesrl.dll version.

To open the folder with log files for current user press the Show Log.... The button is displayed in case of
the "Turn on logging" flag was set during the connecting to the Trading System.

Options

To access the program options select the Options item in the Tools menu or press Ctrl+O.

To copy/paste the connection settings, use the buttons in the right corner of the Options dialog box:
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The Options dialog window consists of several tabs.

Connection Tab

The Connection tab of the options window contains the network and connection settings.

If the terminal version implements independent connection to Trading and Clearind system, the tab
contains two forms for Trading System and Clearing System network settings.

Separate tabs on the Connection tab contain connection settings to the following services: Algorithmic
trading and Request for Stream auctions processing.
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Table 17.15. Elements of the "Connection" tab

Element Description
Active profile Select connection profile to view its settings below. Connection

profiles allow user to store different sets of parameters and can be
used, for example, to quickly switch between production and test
environments.

Modify Edit selected connection profile.

Add Add new connection profile.

Delete Delete selected connection profile.

Synchronize local PC time with
trading system

Local PC time will be synchronized with Tradin System time at each
successful connection.

Table 17.16. Elements of the "Trading System" tab

Element Description

Direct connection via TSMR:

Broadcast List of networks addresses (bridges) where searching for available
access servers (gateways) will be performed.

Server Trading System server identifier. Note: this field is case-sensitive.

Service Trading System TCP and UDP services name.
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Element Description
Preferred gateway (network)
address

Address of the Trading System network (bridge) where search for
available access servers (gateways) will be performed first.

Internet connection:

Host list List of access servers (gateways) for connecting to the Trading
System.

Server ID >Trading System server identifier. Note: this field is case-sensitive.

Request connection confirmation Additional confirmation required for Internet connection.

Secure connection, "Validata"
profile

Use secure connection with digital signature for data transfer. Select
"Validata" profile in the drop-down list. Two additional flags are
available for secure connection: "Use LDAP certificate stores" and
"Keep secret key in memory after program exits".

Using Vallidata, your connection has "channel encryption" provided by
Validata or TLS1.2 (OpenSSL) encryption enabled dy default.

Secure connection If the flag is set, connection channel has TLS1.2 (OpenSSL) encryption
enabled.

Table 17.17. Elements of the "Clearing System" tab

Element Description

Direct connection via TSMR:

Broadcast List of networks addresses (bridges) where searching for available
access servers (gateways) will be performed.

Server Trading System server identifier. Note: this field is case-sensitive.

Service Trading System TCP and UDP services name.

Preferred gateway (network)
address

Address of the Trading System network (bridge) where search for
available access servers (gateways) will be performed first.

Internet connection:

Host list List of access servers (gateways) for connecting to the Trading
System.

Server ID >Trading System server identifier. Note: this field is case-sensitive.

Tools Tab

The Tools tab of the options window contains the general program settings.
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Table 17.18. Elements of the "Tools" tab

Field Description
Application language Language of the user interface. Changing the language requires

application restart.

Show Login dialog at program
startup

Show "Authentication in the Trading System" dialog at application
startup.

Request quit confirmation Show confirmation dialog a attempt to close the application.

Show in main window caption Select parameters to be displayed in the main window caption. "Up"
and "Down" buttons can be used to customize their order.

Monitor gateway delays In case of gateway delays from the trading system core, the
appropriate information including gateway IP-address and value of
time lag would be shown in main window statusbar.

View Tab

The View tab of the options window contains the interface customization settings.
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Table 17.19. Elements of the "View" tab

Element Description
Background color Background color for the workspace.

Keep windows inside Prohibit dragging windows outside main program window.

Snap to grid Snap tables to workspace grid.

Grid size Specify the preferable grid size. This option can be enabled only if
"Snap to grid" mode is turned on.

Snap to borders Tables will stick to main window borders when being resized or moved.

Snap to neighbors Tables will stick to each other when being resized or moved

Snap distance Specify horizontal and vertical distance from which tables will stick to
borders. This option can be enabled only if "Snap to borders" mode is
turned on

Colors "Colors" panel can be used to select preferable fonts and colors for
different interface elements.

Actions Tab

The Actions tab of the options window contains settings for the order entry dialog.
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Table 17.20. Elements of the "Actions" tab

Element Description
Request confirmation before
transaction execution

Show confirmation dialog with transaction parameters before actual
submitting it to the Trading System.

Show successful transaction
execution results

After the transaction is successfuly processed by the Trading System,
the appropriate message will be shown.

Non-modal transaction dialogs Non-modal order entry dialog windows let user work with tables,
menus and other interface elements while dialog is opened. However
the dialog window will still be located at the top of all other interface
elements.

Allow multiple transaction dialogs
at one time

If non-modal mode for transaction dialogs is activated, this option
allows opening additional order entry forms (five copies maximum)
without closing previous.

Blend inactive transaction dialogs Select a transparency rate for inactive transaction dialog windows.
This option can be enabled only when non-modal mode for transaction
dialogs is active.

Show firm name before identifier
in firm list

"Counterparty" field in the "Enter Negdeal" dialog will containt firm
name (instead of identifier) and use it as sorting criterea in the
selection list.
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Element Description
Take the total quantity of the
best quotes when entering from
orderbook

If this option is enabled, "Lots" field of the order entry dialog (if it was
envoked from orderbook) will contain total quantity of selected and
best quotes.

Use "Num pad +" and "Num pad -"
to change price

Use "Num pad +" and "Num pad -" to respectively increase and
decrease price for one step in the order entry dialogs regardless of the
cursor position. Hold "Ctrl" or "Shift" to change the price for 10 or 100
steps respectively.

Use "Space" to toggle order
direction (buy/sell)

"Space" key can be used to change the order direction in active order
entry dialog regardless of the cursor position.

Show thousand separators in
numeric fields

Divide numbers into groups of digits.

Close dialog after successful order
entry

Close order entry dialog right after the order has been successfuly
accepted by the Trading System. Entering new order requires
reopening the form.

Tables Tab

The Tables tab of the options window contains the settings that influence the display and storage of data
in all the tables.
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Table 17.21. Elements of the "Tables" tab

Field Description
Table refresh rate Interval between requests to the server, sec.

Highlight changes in securities and
indices for:

Specify the duration of rows color highlight in "Securities" and
"Indexes" tables, that occurs when price of the last trade has been
changed.

Show "Table" menu without
subitems

Set the flag if you prefer all items of the "Table" menu to be presented
in a single list. If unchecked, menu items will be grouped to the
submenus according to their content: Exchange tables, Firm tables,
Positions .

Column headers Select the type of values to be used as column header in case of
exporting table contents to file: full text caption or column identifier.
This option doesn't affect copying to the clipboard: in that case full
captions are always used.

Use field ordering of current
window

If the flag is set, only visible columns in their exact order will be
exported to file or copied to clipboard. If unchecked, all available
columns will be included.

Display reference columns as Select the type of values to be used for cells that refer to other tables
(boards, securities, partners) in case of export: name, code or both.

Export CMA compatible data
according to version

Select the appropriate version of CMA Terminal for correct data export
to *.txt or *.dbf.

Enable DDE server Enabling this option lets external applications, such as MS Excel and
Technical Analysis Systems, request the data from "Securities" table
in real-time

Show actions in context menus for
tables

Include transactional commands (order entry and withdrawal) to the
context menus of tables (right-click on table content).

Cache tables loaded from the
Trading System

If this option is enabled, after exiting the program all the data will be
saved to the special files on the hard drive to avoid re-download at next
connection. Please note that sensitive information on own trades and
positions will also be cached.

Signals Tab

The Signals tab of the options window contains settings for notifications.
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Table 17.22. Elements of the "Signals" tab

Element Description
Interrupt when urgent message
received

If the flag is set in case of receiving an urgent message the dialog
window with its content will be displayed on the top of all other
windows. If the option is deactivated new messages will only be shown
in statusbar.

Enable sounds Turn on sound notifications. By default "exclamination" sound from the
Operatin System settings will be used. Additional buttons to the right
of the field can be used to choose own sound, reject own selection and
return to default, and play the selected sound.

Flash application button in the
taskbar when application is
inactive

If application is inactive the corresponding button on the Operating
System taskbar will start flashing in case of receiving a notification.

Repeat signals when reconnected All the received notification signals will be repeated at each reconnect
to the Trading System.

"Signal events" panel Select types of events for which notifications will be given.

Hot Keys Tab

The Hot Keys tab of the options window allows users to define own hot keys for any action.
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Table 17.23. Element of the "Hot Keys" tab

Element Description
Commands Select the needed menu from drop-down list and then choose a

command to assign a Hot key.

Hot key Activate this field by setting a cursor and then press preferable
Hot key ot key combination. If that hot key is already in use the
corresponding alert will be shown. Is's not recommended to use
standard combinations of Operating Systems such as "Ctrl+F4", "Alt
+F4", "Ctrl+C" and so on.

Assign Assign Hot key to the selected command. The assignment will be
finally performed after clicking Ok and closing the Options form.

Clear Delete key assignment for the selected command. The unassignment
will be finally performed after clicking Ok and closing the Options form.

Reset All Hot Keys Reject all changes and restore default Hot keys configuration.

Information Server (ISS) Tab

The Information Server (ISS) tab of the options window contains settings for connection to the online
Informational and Statistical Server that is used to load all the historical market data as well as current data
from other markets.
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To "News feed" and "Historical data" functions process properly, make sure that there is network access to
http://iss.moex.com (80 port) and https://passport.moex.com (443 port).

Table 17.24. Elements of the "Information Server" tab

Element Description
Download historical data Establish connection to the web-server for downloading historical data

and performing search for securities on other markets.

Anonymous work with ISS Terminal will connect to ISS without any authorization. INn that case
historical data won't be available.

Automatic authorization Authorization will be performed automatically based on the data from
the Trading System. This method is recommended for most situations.

Use specific login/password This option requires entering user identifier and password and
provided just for possible abnormal cases.

Refresh interval Interval between requests to the server, sec.

Limit download speed Download speed will be limited to the specified value (kb/s).

Restart Connection In case of permanent errors during operation with web-server,
program will stop attempts to re-establish the connection. Use this
button to try manually restart the connection to ISS.

Use caching Enable caching of downloaded data to prevent its re-download at
future requests.
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Adv.Options Tab

The Advanced Options tab of the options window contains additional settings that are more specific for
particular versions of the program and are less frequently used then other settings.

Table 17.25. Elements of the "Advanced Options" tab

Field Description
Dual (both Buy and Sell) order
dialogs

Order entry dialogs will contain controls and for both Buy and Sell
orders. Orders of both directions can be submitted simultaneously.

Show Lots before Price "Lots" field will be located before "Price" in Dual order entry dialogs.

Leave accepted and rejected
negdeals in "Received negdeals"
table

Negdeals will remain in the "Received negdeals" table after their
acceptance or rejection.

Add client code to "Broker
reference" field

"Broker reference" field of the order will contain client code specified
in the order entry dialog.

Lock window when inactive If the turbo mode [55] is turned on, оrderbook window will be locked
after inactivity in specified amount of time.

Turn off turbo mode The Turbo option will be automatically turned off after specified
amount of time.

Highlight user's orderbooks
instead of firm's ones

If option is active, records in an Orderbook table are highlited for orders
from current user. If option is inactive (default) records about orders
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Field Description
from user's firm are highlighted. To activate highlight changes, logout
and then login to the Trading system.

NCC

Go to "NCC integration module" > "Activation and establishing the connection section.
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Appendix A. Hot keys
Default keyboard shortcuts are listed in the table below. Custom shortcuts can be assigned in the Options
Menu.

Keyboard shortcut Action Conditions
Ctrl+A Select all. The Board Selection dialog or table

with ability of selecting multiple
rows is opened.

Ctrl or Shift + Mouse Wheel or UP/
DOWN arrow keys

Increase or decrease Price or
Quantity of lots by 10 or 100
points.

Price or Quantity entry field in
Order Entry window is active.

"+" and "-" keys on a numerical
keyboard,

Ctrl + "+"/"-",

Shift + "+"/"-"

Increase or decrease Price or
Quantity by 1, 10 or 100 points.

Order Entry window is opened
and function is allowed in the
application options.

"H" (hundred), "T" (thousand)and
"M" (million) keys

Insert "00", "000" or "000 000". Price or Quantity entry field in the
Order Entry window is active.

Ctrl+Tab Change order direction: buy or sell. Alternative Order Entry window is
opened.

Space Change order direction: buy or sell. Order Entry window is opened
and function is allowed in the
application options.

Ctrl+R Repeat Last Order parameters. Order Entry window is opened.

Shift + mouse click on table icon on
the toolbar or item in "Table" menu

Open additional instance of table. No dialogs are active.

Ctrl+N Open a copy of the current table. Any table is active.

Esc. Close dialog and restore the order,
withdrawn for editing.

Edit Order window is active.

Ctrl+Shift+Space Switch Data Sets on or off. No dialogs are active.

Ctrl+G Show the quick filter window. Any table is opened for which
filters are applicable.

Ctrl+H Cancel filter. Any table is opened and filter is
applied.

F1 Display help information for the
current table or dialog.

Always available.

F2 Enter Order. No dialogs are active.

F3 Enter Negdeal/OTC Negdeal
Order.

No dialogs are active.

F4 Enter SWAP order. No dialogs are active.

F5 Refresh the contents of table. "Trading Accounts" table is active.

F6 Enter Negdeal SWAP Order. No dialogs are active.

F11 Switch between Fullscreen and
Windowed mode.

No dialogs are active.

Ctrl+Space Apply a filter to the table. Table with at least one configured
filter is active.
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Keyboard shortcut Action Conditions
Ctrl+F Open Quick Search dialog. Table with at least one entry is

active.

Ctrl+O Options. No dialogs are active.

Ctrl+B Setup Bookmarks. No dialogs are active.

Alt+Left/Right arrow key Go to the previous or next tab. No dialogs are active.

Alt+(1-9) digit key Go to the tab with corresponding
number.

No dialogs are active.

Alt+Home Go to the first tab. No dialogs are active.

Alt+End Go to the last tab. No dialogs are active.

Alt+Backspace Go to the previously active tab. No dialogs are active.

Ctrl+C Copy the contents of the active
cell to the clipboard.

Any table is active.

Ctrl+Shift+C Copy the contents of the active
table to the clipboard.

Any table is active.

Ctrl+S Export the contents of the table to
the file

Any table is active.

Ctrl+W Fit the width of columns according
to the longest value in the column.

Any table is active.

Ctrl+F2 Order Packet Entry dialog No dialogs are active.

Shift+Ctrl+F2 Add Existing Orders to the Packet. Table with Orders or Negdeal
Orders is active.

Del Withdraw a selected order or
reject a received negdeal.

Active order is selected.

Alt+0 List of Open Windows. No dialogs are active.

Ctrl+P Open Print Preview window. Any table is active.
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Appendix B. Toolbar
Icon Action

Enter Order,

Accept a received Negdeal Order

Enter Negdeal / OTC Negdeal

Edit selected Order

Withdraw selected order,

reject a received negdeal

Send a message

Trading boards

Description of securities

Securities

Best Negdeals

Orderbook/Negdealbook

All Trades Chart

Trade Time

Firms

All Trades

Exchange Turnover

Orders

Sent Negdeals / OTC Negdeals

Received Negdeals

All Trades

Trading Without Full Pre-funding Limits for Bank Accounts

Positions by Limits

Positions by Assets

Positions by Securities

Liabilities and Claims for Assets

Trading Accounts

Messages

Users



File format for Order Packet 19.09.2025

214

Appendix C. File format for Order Packet
Order packet is stored as a plain text file of the following format:

• *.CSV - parameters are devided by separator symbol (depends on OS settings, usually "," for American
Windows versions and ";" for European Windows version);

• *.TXT - parameters are devided by "tab".

Decimals separator symbol also depends on OS locale settings. Required file encoding is windows-1251.

First line of the file contains the set of parameters names (in any order), each other line refers to one
order with parameters values specified correspondingly. It's recommended to specify all the parameters
described below for each type of the order to ensure the file validity.

For example, to upload the packet with the following regular orders:

• EURRUB_TOM; buy; 10 lots; price 41,3013; Trading Account: MB0001700082; Client code: 33317; order
type: limit order; Good till Cancel, Do not split price; Lifetime - 10 minutes

• USDRUB_TOD; sell; 13 lots; order type: market order; trading account: MB0001788888

the file content should be as follows:

    SECCODE;SECBOARD;BUYSELL;PRICE;QUANTITY;HIDDEN;MKTLIMIT;SPLITFLAG;IMMCANCEL;
    PRICEYIELDENTERTYPE;LIFETIME;TRDACCFIRMID;ACCOUNT;CLIENTCODE;BROKERREF
    EUR_RUB__TOM;CETS;B;41,3013;10;;L;S; ;P;;MB0001700000;MB0001700082;33317;
    USD000000TOD;CETS;S;;13;;M;;;;;MB0001780000;MB0001788888;;
    

If one of the parameters specified in the first line is insignificant for one of the orders, then the separator
symbol of the next parameter should be inserted right after the separator of the insignificant one in the line
corresponding to the particular order (see HIDDEN parameter in the example above).

Please note that empty value (no symbol) is not equal to [space] value (" "): see IMMCANCEL parameter
in the example above.

If the last value in the line is an empty value it still requires a separator symbol before it (see BROKERREF
parameter in the example above).

Parameters for regular orders

Parameter Length Description
SECCODE 12 Security identifier. Please refer to the "Securities"

table.

SECBOARD 4 Trading board identifier. Please refer to the "Boards"
table.

BUYSELL 1 Order direction:

• B - buy

• S - sell

PRICE 9 Exchange rate.

QUANTITY 16 Quantity of securities expressed in lots.

HIDDEN 16 Hidden lots volume.

MKTLIMIT 1 Order type:
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Parameter Length Description
• L - limit order

• M - market order

SPLITFLAG 1 Price split flag:

• O - Do not split

• S - Split

IMMCANCEL 1 Remainder processing mode:

• [space] - Put into queue (Good till cancel)

• N - Immediately or cancel

• W - Withdraw the remainder

PRICEYIELDENTERTYPE1 Price calculation:

• P - entered price

• W - weighted-average price

LIFETIME 6 Order lifetime.

TRDACCFIRMID 12 Firm ID for trading account.

ACCOUNT 12 Trading account identifier.

CLIENTCODE 12 Client code.

BROKERREF 20 Broker reference: additional information entered
by the trading firm (usually - [client code]/[client
instruction number]).

SWAP orders parameters

Parameter Length Description
SECCODE 12 Security identifier. Please refer to the "Securities"

table.

SECBOARD 4 Trading board identifier. Please refer to the "Boards"
table.

BUYSELL 1 Order direction:

• B - buy

• S - sell

PRICE 9 Exchange rate.

QUANTITY 16 Quantity of securities expressed in lots.

LIFETIME 6 Order lifetime.

TRDACCFIRMID 12 Firm ID for trading account.

ACCOUNT 12 Trading account identifier.

CLIENTCODE 12 Client code.

BROKERREF 20 Broker reference: additional information entered
by the trading firm (usually - [client code]/[client
instruction number]).
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Parameters for Negdeals / OTC negdeals

Parameter Length Description
ACCEPTEDORDERNO12 Number of accepted order, in case the packet of

counter-orders is entered.

SECCODE 12 Security identifier. Please refer to the "Securities"
table.

SECBOARD 4 Trading board identifier. Please refer to the "Boards"
table.

BUYSELL 1 Order direction:

• B - buy

• S - sell

CPFIRMID 12 Identifier of counterparty firm the negdeal is
addressed to.

PRICE 9 Exchange rate.

QUANTITY 16 Quantity of securities expressed in lots.

SETTLECODE 12 Settlement code for this order.

TRDACCFIRMID 12 Firm ID for trading account.

ACCOUNT 12 Trading account identifier.

CLIENTCODE 12 Client code.

BROKERREF 20 Broker reference: additional information entered
by the trading firm (usually - [client code]/[client
instruction number]).

MATCHREF 10 Matching reference is used for unique coincidence
of two counter negdeal orders.

Parameters for SWAP Negdeals

Parameter Length Description
ACCEPTEDORDERNO12 Number of accepted order, in case the packet of

counter-orders is entered.

SECCODE 12 Security identifier. Please refer to the "Securities"
table.

SECBOARD 4 Trading board identifier. Please refer to the "Boards"
table.

BUYSELL 1 Order direction:

• B - buy

• S - sell

CPFIRMID 12 Identifier of counterparty firm the negdeal is
addressed to.

PRICE 9 Exchange rate.

BASEPRICE 9 Base exchange rate for the security.

QUANTITY 16 Quantity of securities expressed in lots.

TRDACCFIRMID 12 Firm ID for trading account.

ACCOUNT 12 Trading account identifier.
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Parameter Length Description
SETTLECODE 12 Settlement code for this order.

CLIENTCODE 12 Client code.

BROKERREF 20 Broker reference: additional information entered
by the trading firm (usually - [client code]/[client
instruction number]).

MATCHREF 10 Matching reference is used for unique coincidence
of two counter negdeal orders.

Parameters for messages packet

Availability of this feature depends on user role.

Parameter Length Description
URGENCY 1 "U" for urgent messages that interrupt users' work or

[empty] for regular messages.

TOALL 1 The message is addr to all users.

USERIDTO 12 User of the firm message is addressed to.

FIRMIDTO 12 Identifier of the firm message is addressed to.

EXCHANGE 4 Identifier of the Exchange in case message should be
send to all its firms.

MESSAGE 256 Message content. Use double quotes for messages
consisting of multiple lines.

Only one of USERIDTO, FIRMIDTO or EXCHANGE fields should be filled. In case none of these fields is filled
then message will be addressed to all firms on all exhanges.
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Appendix D. Common datasets xml file
format
Please note: in order to manage datasets administratively, file name datasets.xml is required. Saving and
loading datasets configuration via terminal user interface may be performed with arbitrary file name and
path.

Example of datasets xml file structure:

<?xml version="1.0" encoding="windows-1251"?>
<datasets>
  <Set Id="Secs">
    <Lists>        
      <List Board="BRDA" Exclude="1.">
        <Id>SECA</Id>
        ...
        <Id>SECM</Id>       
      </List>      

      <List Board="BRDN" Exclude="0">
        <Id>SECN</Id>
        ...
        <Id>SECZ</Id> 
      </List>      
    </Lists>
    <Defaults>
      <Default Board="BRDA">SECA</Default>
      <Default Board="BRDN">SECN</Default>
    </Defaults>    
  </Set>
    

  <Set Id="Firms">
    <Lists>
      <List Board="BRDA" Exclude=0>
        <Id>MoexFirmId1</Id>
        ...
        <Id>MoexFirmIdN</Id>
      </List>
    </Lists>
    <Defaults>
      <Default Board="BRDA">MoexFirmId1</Default>
    </Defaults>  
  </Set>
  

 
  <Set Id="SettleCodes"/>
  <Set Id="TrdAccs"/>
  

  
  <Set Id="ClientCodes"/>
  <Set Id="BrokerRefs" FileName="C:\...\BrokerRef1.csv>
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  <Set Id="MatchRefs"/>
  <Set Id="CpTrdAccs"/

  
</datasets> 

Table D.1. Elements of datasets.xml

Node/attribute Description

<?xml version="1.0" encoding="windows-1251"?>File encoding.

<datasets> Head node of the data sets configuration file.

  <Set Id="NNN">  Node with information on data sets for one of the
following IDs:

• "Secs" - Securities;

• "Firms" - Counterparties;

• SettleCodes" - Settlement codes;

• "TrdAccs" - Trading accounts;

• "ClientCodes" - Clients*;

• BrokerRefs" - Broker reference*;

• "MatchRefs" - Match reference;

• "CpTrdAccs" - Counterparty trading accounts.

If any Set would not contain values use the following
format " <Set Id="NNN"/> ".

* ClientCodes and BrokerRefs are mutually
exclusive. Only one of them should be used at one
time.

    <Lists>  "Lists" node may contain multiple "List" subnodes
for different trading boards. There are two
possible methods of forming a list: "including" and
"excluding" (see below).

      <List Board="..." Exclude="..">
        ...
      </List>      

     <List Board="..." Exclude="..">
        ...       
      </List>  
      
     <List Board="..." Exclude="..">
        ...       
      </List>      
      

List of included/excluded values for a specified
trading board.

Board="..." - Identifier of the Trading Board, for
which the list of included/excluded values is defined.

Exclude="..." - Method of list formation. Possible
values are "0" and "1".

• Exclude="0" - "including" method. Only values
specified in nested nodes " <Id>...</Id> " will be
available to the user. Corresponds to unchecked
flag "Automatically add new records to data set" in
the Edit Data Set dialog..

• Exclude="1" - "excluding" method. All values from
the Trading System will be available to the user,
except ones specified in the nested nodes "
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Node/attribute Description
<Id>...</Id> ". All the new values (e.g. securities,
firms ...) that appear in the Trading System will
be also available to the user, if they are not
specified in the nested ID nodes. , они будут
доступны пользователю, если не были указаны.
Corresponds to activated option "Automatically
add new records to data set" in the Edit Data Set
dialog.

        <Id>...</Id>
        ...
        <Id>...</Id>       
      

Values included into the list.

Type of the value depends on data set type (<Set
Id="NNN">).

• for "Secs" - Security ID;

• for "Firms" - Firm ID;

• for "SettleCodes" - Settlement code;

• for "TrdAccs" - Trading account identifier;

• for "ClientCodes"* - Client code assigned by
Broker;

• for "BrokerRefs"* - Path to file**
with Broker Reference in the following
format: <Set Id="BrokerRefs" FileName="C:\...
\BrokerRef1.txt"/>;

• for "MatchRefs" - Path to file** with Match
Reference in the following format: <Set
Id="MatchRefs" FileName="C:\...\MatchRef1.txt"/
>;

• for "CpTrdAccs" - Path to file** with
Counterparty trading accounts in the following
format: <Set Id="CpTrdAccs" FileName="C:\...
\CpTrdAcc1.txt"/>.

* ClientCodes and BrokerRefs are mutually
exclusive. Only one of them should be used at one
time.

** Description of the file format is given in Appendix.

      </List>
    </Lists>  
  

Closing tags.

    <Defaults>
      <Default Board="BRDA">...</Default>
      <Default Board="BRDN">...</Default>
    </Defaults>  
  

Element with default values for the particular "Set
Id".

Applicable for all "Set Id" except Counterparty
Trading Account (CpTrdAccs) and Broker reference
(BrokerRefs).

Please note: if default value is specified it will be used
even if data sets are switched off.
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Node/attribute Description

 
  </Set>
<datasets>  
  

Closing tags.
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Appendix E. Dataset file format
(BrokerRef, MatchRef)
Required file encoding is windows-1251. If trading board is not specified than dataset settings affect all the
trading boards available for the user. MICEX Trade Currency native dataset file format is described below.
CMA terminals dataset file format is also supported.

Broker reference (BrokerRef)

BrokerRef files are used for mapping trading accounts to clients and broker references for a specific trading
board. If trading board is not specified than dataset settings affect all the trading boards available for the
user. Broker reference may be specified by an arbitrary value text. Client may be specified by the actual
Client Code or by an arbitrary value value.

Each line refers to one broker reference containing parameters values separated with separator symbol
(depends on OS settings, usually "," for American Windows versions and ";" for European Windows version)
or tab: board_id,trading_account,client,BrokerRef.

Example: 
EQBR;N01-00000N01;client1;brokerref0
EQOB;N01-00000N01;client1;brokerref0
;N01-00000N02;client2;brokerref2
RPMA;N01-00000N03;client3;brokerref1
EQBR;N01-00000N03;client3;brokerref1
PSOB;N01-00000N04;client4;brokerref3
RPMA;N01-00000N04;client4;brokerref3

When BrokerRef file is loaded and datasets mechanism is activated then order entry dialogs workflow is
as follows:

First select Trading account in the "Trd. account" drop-down list. Client codes available for the selected
trading account will be displayed in the "Client" drop-down list. When the particular client code is selected
then available broker references will be displayed in the "BrokerRef" list.

Type the client code with a keyboard through the "Client" list. Trading account will be loaded accordingly
to the client code specified. Then available broker references will be displayed in the "BrokerRef" list.

Matching reference (MatchRef)

Matching references may be used for unique coincidence of two counter-orders.

Each line refers to one MatchRef containing parameters values devided by the separator symbol (depends
on OS settings, usually "," for American Windows versions and ";" for European Windows version) or tab:
board_id;MatchRef

Example: 
CETS;MatchRef0
;MatchRef1
TRAN;MatchRef2
CETS;MatchRef3
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Appendix F. Exporting table content
Required file encoding is windows-1251. Decimals separator symbol depends on OS locale settings.

*.CSV (separator symbol depends on OS settings)

First line of the file contains columns' identifiers or names (may be configured in the program options on
the Tables tab) devided by separator symbol. Each of the following lines refers to one row of the table
containing values devided by separator symbol.

*.TXT (separated by "tab")

First line of the file contains columns' identifiers or names (may be configured in the program options on
the Tables tab) separated by "tab". Each of the following lines refers to one of the table's rows with values
separated by "tab".

*.XML table

XML-file with the following structure:

<?xml version="1.0" encoding="windows-1251"?>
<records>
  <record>
    <columnID_1>value</columnID_1>
    <columnID_2>value</columnID_2>
    ...
    <columnID_n>value</columnID_n>
  </record>
  <record>
    <columnID_1>value</columnID_1>
    <columnID_2>value</columnID_2>
    ...
    <columnID_n>value</columnID_n>
  </record>
</records>

record node contains data on one table row, where columnID_1 ... columnID_n - columns identifiers, value
- actual cell value.

dBASE III (*.dbf)

dBASE III database file format.

Microsoft Excel Book (*.xls)

Microsoft Excel Book format.

CMA-compatible *.TXT file

Each line refers to one row of the table containing values devided by separotor symbol (depends on OS
settings). The actual order of values for each table is determined by CMA specifications. Version of CMA
compatible data format may be configured in the program options on the Tables tab.

CMA-compatible *.DBF file

dBASE III database file format compatible with CMA terminals. Version of CMA compatible data format
may be configured in the program options on the Tables tab.
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Appendix G. Order validation control
Required file encoding is windows-1251. Decimals separator symbol depends on OS locale settings.

*.CSV (separator symbol depends on OS settings)

First line of the file contains columns' identifiers devided by separator symbol (depends on OS settings,
usually "," for American Windows versions and ";" for European Windows version), each of the following
lines refers to one row of the table containing values devided by corresponding separator symbol.

*.TXT (separated by "tab")

First line of the file contains columns' identifiers separated by "tab". Each of the following lines refers to
one of the table's rows with values separated by "tab".

Parameter Description
SECBOARD Trading board identifier.

SECCODE Security identifier.

PARAMETER Order parameter to control:

PRICE - Price

QTY - Quantity (number of lots)

AMOUNT - Amount, in lot
currency

VALUE - Value, in conjugated
currency

TWAP order parameter to control:

PRICE - Price

QTY_ALGO - TWAP Quantity
(number of lots)

AMOUNT_ALGO - TWAP Amount,
in lot currency

VALUE_ALGO - TWAP Value, in
conjugated currency

VALIDATION Validation type:

[space] - no validation

WAPRICE - to weighted-average
price

PREVWAPRICE - to previous price

LAST - to last price

MKTPRICE - to market price

VALUE - to value
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Parameter Description
EXCHANGEVAL - to exchange
value

RANGE - Range

MIN - Minimum

MAX - Maximum.

VALUE Value the deviation is calculated
from. Not applicable for RANGE,
MIN and MAX validation types.

PERCENT Deviation (percentage value). Not
applicable for RANGE, MIN and
MAX validation types.

MINIMUM Minimum value for RANGE and
MIN validation types.

MAXIMUM Maximum value for RANGE and
MAX validation types.

URGENT High importance. "Y" - yes, "N" -
no. In case user attempts to breach
the limit, "warning" window will be
displayed.

PROHIBITBREACHProhibit breach of the limit. "Y"
- yes, "N" - no. If the option is
activated then submitting an order
that breaches the specified limit
will be prohibited. If this option is
disabled, such order will require
additional confirmation but still
may be submitted.


