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Chapter 1. About MOEX Trade Agro Auction

MOEX Trade Agro Auction is an all-purpose terminal for participation in commodity auctions on the on-
exchange commodity market.

Key functional features of MOEX Trade Agro Auction:

• Direct access to trading.

• Real-time monitoring of agricultural commodity trading on the National Mercantile Exchange (NAMEX),
including tracking of transactions in individual commodity assets.

• Buying and selling commodities at auctions.

• Optimised methods of entering orders both by hotkeys and from various tables with value substitution.

• Viewing positions of own orders in the auction and orders of competitors.

• Viewing the register of participant's obligations under transactions.

• Opportunity to improve own orders in the auction.

• Opportunity to track the start, duration and end of the auction.

Main service features:

• Dynamic export to MS Excel and databases.

• Hot keys and mouse-oriented controls for quick order entry.

• Flexible filtration and sorting options, table templates.

• Many options for desktop layout customization, including the creation of several virtual desktops.

• Instant messaging with other trading participants.

• Alerts system.

• Option to choose interface language.

• Auto-update.

• Technical support by Moscow Exchange staff.
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Chapter 2. What's new

("+" - new feature; "о" - modified feature of behavior; "-" - removed functionality; "!" - bug fix)

Version 3.23.09

+ The terminal provides trading with international participants. Different units (tonnes, kilograms, litres)
can be used to measure commodity. Calculations can be made, and prices and volumes can be specified in
foreign currencies. Columns "Price currency”, "Unit of measure” and "Cross rate to rub" have been added
to the "Mini-sessions" table.

+ Added indication of changes in the auction volume before the auction starts in the "Order queue" window.

Version 3.23.02

+ The table "History of change of the starting price" was added to the terminal to track the time of change
of the starting price throughout the auction.

+ Button  was added to the "Starting price" field of the "Order queue" window to call the table "History
of change of the starting price".

o The terminal no longer restricts the entry of orders with the price worse than the starting price. In this
case the price in the order entry form will be highlighted in red and the warning "Your price is worse than the
starting price" will be displayed. Orders with a price worse than the starting price cannot win the auction.

o The "Service" tab of the "Parameters" window is displayed.

Version 3.22.10

o Password length at login and password change is limited to eight characters.

+ An option has been added to display the entered password in the field when registering in the system
and changing the password.

+ Added "Firms" table.

o An option has been added for auctions with several customers.

Version 3.21.30

+ Autocorrection of order prices has been added.

+ An option to hold auctions with auto prolongation has been added.

+ Added "Mini-session schedule" button to the auction details panel in the "Order queue" window, which
calls the table with the schedule.

Version 3.21.20.

+ Added tools for participation in commodity auctions.
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Chapter 3. Installation and update

System requirements

Recommended system configuration:

• CPU: Intel Core or compatible, 1,4 GHz or higher;

• RAM: 2 GB;

• HDD: 1 GB free drive space;

• screen resolution: 1280х1024 or higher, 32-bit color;

• keyboard, mouse;

• network bandwidth: 128 kbps per every terminal;

• OS: Microsoft Windows 7 / 8 / 10, Windows Server 2008 / 2012 / 2016;

• Microsoft Internet Explorer 9 or higher.

Installation

MOEX Trade Agro Auction installation procedure involves the following steps:

1. Save the  moex-agroauction-x64-version_number.exe  file to the local drive.

2. Double-click the file in Explorer to launch the installation wizard. Choose the installation type: for all users
(requires administrator rights) or for current user only.

Click Next to proceed to the next step.

3. The second dialog offers the selection of the program installation interface language (the language of
the program interface can be selected in program options).
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Choose the language and click OK.

4.

Default installation folders for the program are:

• for all users - Program Files\MOEX\Trade Agro Auction

• for current user - Users\User Name\AppData\Local\Programs\MOEX\Trade Agro Auction

If older version of the terminal was previously installed, the existing folder will be suggested. Modify, if
needed, the installation path or press Browse... to select a folder. Click Next to confirm.
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5.

Enter or select folder name for the Start menu, or mark the checkbox to skip the group creation. Click
Next to proceed to the next step.

6. Set additional tasks to be done during the installation.
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7.

Select the connection method: over the Internet (Moscow Exchange Production server. Click Next to
continue.
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8.

Review the settings and click Install to start the actual program installation.
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9.

Click Finish to close the installation wizard.

Update

Program checks for updates automatically every time it connects to the Trading System. For stability
purposes and in order to have access to all the market features, it is highly recommended to install all the
suggested updates.

Admission to connect

In order to be able to connect to the production environment it is essential to have an appropriate technical
access to the Trading System via the Internet and to be admitted to Organised Trading on National
Mercantile Exchange.

Support and Sales

Technical support is available on working days from 9:00 to 19:00 Moscow time.

• In case of any issues with the software, please contact our Support team:

Phone: +7 (495) 733-95-07

• To purchase additional license for the trader terminal or any other Moscow Exchange software, please
contact our Sales team:

Phone: +7 (495) 363-32-32, extention 3377

• Any questions related to Moscow Exchange software can be addressed to:



Installation and update

11

e-mail: help@moex.com [mailto:help@moex.com?subject=MOEX Trade Support]

mailto:help@moex.com?subject=MOEX Trade Support
mailto:help@moex.com?subject=MOEX Trade Support
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Chapter 4. Logging in to the commodity auction system

Login

After launching the terminal, the Login window appears.

To login in the trading system:

1. Enter the user ID (representative of the Trading Member) in the User ID field or select a previously used
ID from the drop-down list.

Example:

Q0003003

2. Enter in the Password field the password assigned to the user.

Example:

xc6G4suM

3. Click OK to login under the specified ID and password.

Be careful when entering the password. In the dialog box, the password characters are displayed with
dots . Switching between lowercase and uppercase letters, as well as the current language (English or
Russian) when entering the password may result in entering an incorrect password and denial of login. If
the password is entered incorrectly three times in a row, the User ID will be temporarily blocked.

If the login window is not displayed when starting the terminal, select the Login command in the Session
menu of the main menu at the top of the terminal window.

If you need to connect to the Trading System different from the one selected when installing the

programme, click the Show Parameters button and then click the icon to enter the login parameters
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received from the Exchange (or close the dialogue window and select the Parameters command from the
Service menu of the main menu).

Click Show Parameters to display additional parameters:

• Log in - select a profile with login parameters.

•  - open the dialogue box for configuring profiles and login parameters.

•  - remove the selected user from the list and erase its settings.

• Do not use saved data - reload the contents of all tables from the Trading System. By default, when
restarting the workplace during a trading session, all data are loaded from the local cache. This parameter
is used in emergency situations to reload all the information from the Trading System.

• Do not restore the desktop - open the workplace without opening any tables. It is used in case there is a
need to boot without restoring the settings or in case the settings are damaged.

• Enable logging - it is recommended to use this option in case of problems when logging in to the Trading
System.

To display the help information on registration in the Trading System (this page), click the button with a
question mark.

If the connection was successful, the main desktop of the programme will be loaded with the windows
Order Queue, Orders, Trades, Mini-Sessions and Messages. In the upper part of the terminal window there
will be the main menu with the commands Session, View, Action, Table, Tools, Data, Window, Help.

The first login

If you have received a user ID and are logging in for the first time:

1. Run the terminal. The Login window will appear.

2. Fill in the User ID field.

3. Fill in the Password field with the password received together with the ID.

4. Press Yes.

5. A message will appear asking you to set the password.

6. Click Change Password Now and set your password.

The password has an expiry date. To reset the password, see Password Expiry Date.

Password expiry date

The password has an expiry date, after which a new password must be created and set.
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If a password is about to expire:

1. You will receive a notification when you log in with an expiring password.

2. To prevent your password from becoming outdated, click Change Password Now and proceed to the
password change procedure.

3. After changing the password, you are automatically logged in to the trading system. The programme
desktop opens.

If your password has expired:

1. If you log in with an outdated password, you will receive a warning message.

You will now need to change your password to log in.

2. Click Change Password Now and proceed to the password change procedure.

3. After changing your password, enter your username and new password in the Login window to log in
to the trading system.

Blocking in case of incorrect password entry

If you have entered the password incorrectly in the Login window, you will receive a message with an login
error:

Click Close, return to the Login window and fill in the Password field correctly.

If you have entered an incorrect password three times in a row, you will receive a message about blocking
your ID for 15 minutes:
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During this time, all attempts to log in with your user ID will fail:

Wait 15 minutes and try again to enter the correct password in the Password field of the Login window.

If the password is lost, contact the Technical Support Service help@moex.com to learn about the procedure
for restoring the password.

Program update

If the new version of the program is ready for installation from the Trading system server, the auto-update
dialog window will appear after the successful user authentication.

If the user doesn't have enough rights on a local machine, updated components will be downloaded to the
temporary directory, but won't be installed. After that, the installation should be performed by the user
with the administrative rights, by executing the Install MOEX Trade Agro Auction command, located in the
Start - Programs - MOEX - MOEX Trade Agro Auction - Tools menu of the operating system.

To rollback the last update and downgrade to the previous version, execute the Rollback MOEX Trade Agro
Auction updates command, located in the Start - Programs - MOEX - MOEX Trade Agro Auction - Tools
menu of the operating system.

Table 4.1. Buttons of the dialogue window for loading a new version

Button Assignment
Show parameters Show a list of all updated files with their last update date, size and

checksum.

Download Download all updates to your computer and, if you have sufficient user
rights on the local machine, install the updates.

Do not download Do not download updates and continue logging in the Trading System.

Cancel Do not download updates and stop logging in the Trading System.
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Chapter 5. User Interface and its Customization

The program user interface consists of the following main areas:

Area Description

 Title
The window title includes trader's name or ID and his role
(permissions).

 Main menu
The main menu contains all the commands to work with the program
grouped by type of operations.

 Toolbar
The customizable toolbar contains icons for quick access to the most
popular commands.

 Desktop
The desktop is the place to organize and keep open tables.

 Bookmarks
The bookmarks allow users to create several virtual desktops and
quickly switch between them.

 Statusbar
The statusbar shows the time set on the Trading System server and
the connection status.

 Signal panel
The signal panel displays notifications on important events such as
receipt of a negdeal order or a message, breach of the market-maker's
liabilities, etc.

 Find panel
The security finder panel can be used to search for securities by their
name or ID.

Main Menu

The main menu contains all the commands to work with the program. Menu items are organized by type
of operations into the following groups:

• Session

• View

• Action

• Table

• Query

• Tools

• Data

• Window

• Help

The main menu can be detached and moved as a floating window into other areas of the program interface.
To detach the menu drag the vertical dotted line on its left side.

Some items in the Table menu are placed into submenus. In the program options it is possible to switch
this grouping off to display the menu contents as the one long list.



User Interface and
its Customization

17

Toolbar

The customizable toolbar contains icons for quick access to actions and tables.

If some action cannot be performed then its icon is grayed-out. For example, in order to be able to open an
orderbook it is required to open the Securities [30] table and to select a security in it.

The main part of the toolbar consists of the three independent panels: Actions, Exchange tables and Firm
tables. Actions that can be called from the first panel depend on the currently active table. For example
the Orderbook/Negdealbook button will open the Orderbook/Negdealbook table that corresponds to the
currently selected security.

Any toolbar can be detached and moved as a floating window into other areas of the program interface. To
detach the toolbar drag the vertical dotted line on its left side.

To show or hide any toolbar select its name from the Toolbars submenu of the View menu. It is also possible
to right-click any toolbar to show the list of available toolbars and change their visibility.

To customize toolbars select the Customize item in the toolbar popup menu or in the Toolbars submenu
of the View menu;

Table 5.1. Elements of the Customize Toolbars dialog

Element Description
List of toolbars The full list of toolbars with checkboxes to switch their visibility.

Create Crate a new toolbar.

Rename Rename the selected toolbar. Only toolbars that have been manually
created can be renamed.

Delete Delete the selected toolbar. Only toolbars that have been manually
created can be deleted.

Reset Revert changes made to the selected toolbar.

Large images Display large icons on the toolbar.

Commands The full list of commands from the program main menu. Any command
can be added to the toolbar. If a command does not have an icon then
it will be displayed as text.

List in the right frame List of items and separators on the selected toolbar.

Select Add a selected command to the selected toolbar.

Remove Remove a selected command (or commands) from the selected
toolbar.

Insert separator Add a group separator to the toolbar.

Move selected commands to the beginning of the toolbar. Items can
be also dragged with the mouse.

Move selected commands one position up.

Move selected commands one position down.



User Interface and
its Customization

18

Element Description
Move selected commands to the end of the toolbar.

Bookmarks
In order to work conveniently with many tables it is possible to distribute them between several virtual
desktops (sheets) and to switch between these sheets using bookmarks.

To switch between sheets click the bookmark or press Alt+left/right arrow key or Alt+digit key.

To move a table to another virtual desktop do one of the following:

• right-click the table window title and select Move to Sheet -> Sheet name;

• select the Move to Sheet -> Sheet name command in the Window menu;

• use the sheet setup dialog as described below.

It is possible to detach the bookmarks panel and move it as a floating window into other areas of the program
interface. To detach the panel drag the vertical dotted line on its left side. The panel can be switched on
or off through the View menu.

To customize sheets and move tables between them press the  button on the bookmarks toolbar or select
the Setup Sheets item in the Tools menu or use the Ctrl+B hotkey.

"Sheets" list on the left side of the dialog window contains names of configured virtual desktops. Drag and
drop list items to set the needed bookmarks order. Tables attached to the selected sheet are displayed on
the right side of the dialog window. One or several tables can be easily moved from one sheet to another by
dragging the corresponding item from the tables list to the preferred sheet in the "Sheets list". Check the
"On top of all sheets" box to add the particular table to all the virtual desktops.

Use Add, Delete or Modify buttons to manage sheets.

"Add/Edit Sheet" dialog provides an ability to set the sheet icon that will be displayed next to its name on
the bookmarks panel. The drop-down list contains standard terminals icons.

To upload a custom image please use the "..." button on the right side of the dialog window. Suitable file
formats are: gif, jpeg, jpg, png, bmp, tif, tiff, ico, emf, wmf. Selected image will be automatically scaled to
16 х 16 px.

Statusbar
Program statusbar displays the connection status time on the Trading System server and the connection
status.

It is possible to detach the status and move it as a floating window into other areas of the program interface.
To detach the statusbar drag the vertical dotted line on its left side. The statusbar can be switched on or
off through the View menu.

Table customization
All the tables have the standard Windows design, but in order to offer users more options to flexibly
customize their desktop the windows behavior has been slightly altered as described in subchapters below.

Each table keeps its own settings. If several copies of one table have been opened then the settings of the
last closed table will be saved. In order to save several sets of settings for any table, these settings can be
saved as templates.
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Several copies of one table

In order to open additional copies of a table do one of the following:

• click the table icon on the toolbar or its name in the Table menu while holding the Ctrl key;

• press Ctrl+N to create a copy of the active table;

• right-click the table window title and select New window;

• select the New Window command in the Window menu.

Symbols in column headers and table titles

Besides the table name the title may contain the following symbols:

• The first number shows the total number of rows. Not displayed for orderbooks, because the orderbook
depth is fixed (and can be limited in table preferences).

• * means that the table filter has been applied.

• Orderbook title includes security and board names.

• The number after the semicolon shows the number of the table when several copies are open.

Column headers my contain the following symbols:

•  – column is sorted in ascending order;

•  – column is sorted in descending order;

•  or  and a number – sorting order when several columns are sorted;

• darker column header background and the funnel icon indicate that the filter on this column is switched
on.

Table headers

Besides the standard placement on the top of the table it is also possible to rotate the title to place it on the
left side in order to free up some additional vertical space for table rows. To move the title use the Window
Header -> Left/Top commands in the title popup menu.

In order to minimize the window title select the Window Header -> Tiny command in the title popup window.

To change all the table visualization settings it is also possible to use the table properties dialog.

Column setup

The following table lists the customization actions that can be performed using mouse or popup menu of
the column headers:

Action Menu item Mouse
Sorting rows Sort Ascending Click header continuously. Hold

the Ctrl to sort by several columns.
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Action Menu item Mouse
Sort Descending

Do not Sort

Hide column Hide Column Drag the column header outside
the table and drop it there.

Change column width - Drag the right column border.

Adjust column width by the length
of the longest value.

Adjust columns (will be applied to
the whole table)

Double click the right column
border (will be applied to one
column).

Change column order Setup Columns Drag column header.

Fit all columns to the visible area of
the table

Fit All Columns -

Wrap column headers Wrap Words -

Hide column titles Collapse Header -

To change various column settings it is also possible to use the table properties dialog.

Moving and Resizing Tables

Any table can be moved by dragging its title and resized by dragging any of its borders.

In order to help users utilize their desktop space most efficiently, table will automatically snap to other
tables and borders when moved or resized. This behavior as well as the snap distance can be changed in
the program options.

Automatic table arrangement

To automatically arrange tables on the desktop select one of the following commands in the Arrange
Windows submenu of the Window menu:

• Tile

• Cascade

• Custom

Table Properties

To open the table properties select the Properties item in the Window menu or in the table's popup menu.

These properties are individual for every table, but the color settings can be applied to other tables through
templates.

Appearance Tab

The Appearance tab of the table properties dialog allows users to set up options related to the table design,
including colors.

Table 5.2. Elements of the "Appearance" tab

Element Description
"Title" frame
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Element Description
Show title Uncheck the box to hide the window title, including "Close", "Minimize"

and "Maximize" buttons.

Top Title on the top of the window. This command can also been executed
from the window title context menu (double click the window title).

Left Title on the left of the window. This command can also been executed
from the window title context menu (double click the window title).

Tiny Minimize the window title. This command can also been executed from
the window title context menu (double click the window title).

"Column headers" frame
Show headers Uncheck the box to hide column headers. Disabling this option will

cause context menu, changing column width and sorting unavailability.

Collapse Minimize the column header. This command can also been executed
from the column header context menu (double click the column
header).

Word wrap Check the box to activate word wrap. This command can also been
executed from the column header context menu (double click the
column header).

Fit columns to width Optimize columns width to window size. This command can also been
executed from the column header context menu (double click the
column header).

"Table" frame
Indicator column Activate this option to add an indicator column, pointing to the active

row, to the left of the table.

Highlight focused row Highlight the whole row, when selecting the cell. The selected cell will
be highlighted with the alernative color.

Horizontal grid Horizontal lines between table rows.

Vertical grid Vertical lines between table columns.

Icons and colors in cells Enable cells coloring and graphical elements (for example for Order
Status).

Highlight every ... row Check the box to activate highlighting and specify the needed interval.

"Fonts and colors" frame
List of elements Select the element to customize font and color for.

Color Select standard or custom color for selected element.

Font Select font, style and size for selected element.

Click the Ok button to confirm changes and close the dialog window. Click the Apply button to confirm
changes and leave the dialog window opened. Changes will be saved for all tabs of the dialog window. Save
Settings as Template and Load... are used for saving and loading settings from the templates.

Columns Tab

The Columns tab of the table properties dialog allows users to configure the visible set and order of table
fields.
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Table 5.3. Buttons of the "Columns" tab

Button Description
Select Add selected available columns to the table. This operation also can

be performed by siply dragging selected columns from the left list to
the right one.

Remove Remove selected columns from the table. This operation also can be
performed by siply dragging selected columns from the right list to the
left one, or without calling the dialog window at all: by dragging the
needed column header outside the table.

Select All Add all available columns to the table.

Remove All Remove all columns from the table.

Reset Restore the default columns configuration.

Move selected fields to the top of the list.

Move selected fields up the list. This operation also can be performed
by siply dragging selected fields to the needed position, or without
calling the dialog window at all: by dragging the needed column header
to the needed position.

Move selected fields down the list. This operation also can be
performed by siply dragging selected fields to the needed position,
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Button Description
or without calling the dialog window at all: by dragging the needed
column header to the needed position.

Move selected fields to the end of the list.

Fixed Check the box to move the column to the top of the list and make it
visible while horizontal scrolling the table.

To select multiple separate fields, click them, holding the Ctrl key. To select the sequentially arranged fields,
click the first field, and then the last one, holding the Shift key.

Click the Ok button to confirm changes and close the dialog window. Click the Apply button to confirm
changes and leave the dialog window opened. Changes will be saved for all tabs of the dialog window. Save
Settings as Template and Load... are used for saving and loading settings from the templates.

Context Menu Tab
The Context Menu tab of the table properties dialog allows users to define the default action for double-
click from the list of commands available in the table popup menu.

Table 5.4. Buttons of the "Context Menu" tab

Button Description
Set as Default Use the selected item as default.
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Button Description
No Default Item Do not use the selected item as default. Disables the execution of the

command by double click or pressing "Enter" button.

Reset to Initial State Restore default setting of the context menu.

Click the Ok button to confirm changes and close the dialog window. Click the Apply button to confirm
changes and leave the dialog window opened. Changes will be saved for all tabs of the dialog window. Save
Settings as Template and Load... are used for saving and loading settings from the templates.

Orderbook Tab
The Orderbook tab of the table properties dialog allows users to customize the layout of orderbooks as well
as to add additional indicators to the table header and footer .

Orderbook tab is visible only when table properties dialog is evoked from orderbook/quotebook table. For
quick access to this dialog use the Setup Quotes command of the orderbook popup menu.

Table 5.5. Buttons of the "Orderbook" tab

Button Description
"Display mode" frame
Classic Traditional orderbook. Buy and Sell rates are located in the central

column, quantity is shown to the left and to the right of it.
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Button Description
Alternative Quantity and rates are shown in separate columns, both Buy and Sell.

Simple Buy and Sell rates and quantity are grouped in columns. Direction for
each order is shown in the separate column.

"Additional settings" frame
Highlight buy/sell areas Check the box to color the orderbook background. By deafault: green

for Buy orders, red for sell orders.

Show sell orders on top Sell orders will be shown on the top of the orderbook window.

Keep best quotes always visible Check the box to keep best Buy and Sell quotes visible when quotes
are updated or window is resized.

Keep stable depth Check the box to constantly show a number of rows, equal to
orderbook depth.

Click the Ok button to confirm changes and close the dialog window. Click the Apply button to confirm
changes and leave the dialog window opened. Changes will be saved for all tabs of the dialog window. Save
Settings as Template and Load... are used for saving and loading settings from the templates.

Sorting

To sort table data by any column either click its header one or two times or select a corresponding item in
the column header popup menu (Sort Ascending, Sort Descending, Do not Sort).

To sort by several columns at the same time, click their headers while holding the Ctrl key.

Symbols in column headers:

•  – sort ascending;

•  – sort descending;

•  – sort order when sorting by several columns simultaneously.

Templates

The layout of every table can be saved as a template in order to apply it later to other tables of the same type.

To save the current layout select the Templates - Save item in the table popup menu.
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To apply layout to the open table, select its name in the Templates submenu of the popup menu.

To edit templates select the Templates - Setup item in the table popup menu.

Filter

To set up the data filter right-click inside the table grid and select one of the following items:

Popup menu entry Action
Filter Open the complex filter dialog.

Column Filter Show the quick filter window. Not available for orderbooks.

Filter Active Apply or disable the last configured or loaded filter.
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Popup menu entry Action
Filters Show the list of filters and commands to save or edit filters.

The first three items are also available from the Data menu.

Quick Filters

Besides the actions described above, in order to open the quick filter window it is also possible to move the

mouse pointer to the column header and click the  icon that will appear.

The quick filter appearance and behavior depend on the data type in the column.

The quick filter for lists shows the full list of available values. Mark the checkboxes near the required values.
Use the checkbox near the "Selected" item to mark/unmark all the values.

Filter for numerical values contains comparison conditions and the field for a value to compare the cell data
with.

One more type is the date filter which opens a standard date selection dialog:

All the quick filter windows contain the following buttons:

•  - switch if applicable to another filter form (for example, between list selection or value selection);
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•  - cancel filter;

•  - open the complex filter dialog;

Securities Drag-and-Drop

It is possible to drag securities from the Securities table into any of the following tables to open information
about that particular security:

• chart;

• orderbook;

Full Screen Mode

To switch between the normal and the full screen mode select the Full Screen Item in the View menu or
press the F11 key.

Saving and Migrating Settings

To save all the user settings select the Save Desktop item in the Tools menu.

User settings can be saved to a file in order to migrate all the settings to another PC.

Table 5.6. Elements of the "Save Desktop" dialog

Element Description
Existing settings List of existing settings sets. Select one of the records to save it to file,

rename, delete or overwrite the settings.
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Element Description
Save to File Save the selected settings to file in order to migrate all the settings to

another PC or share it with another user.

Rename Rename the selected settings set.

Delete Delete the selected settings set.

Save Save current desktop settings.

Close Close the dialog window.

Desktop name Text field to enter the setting set name.

To load the previously saved user settings select the Load Desktop item in the Tools menu.

Table 5.7. Elements of the "Load Desktop" dialog

Element Description
Existing settings List of existing settings sets. Select one of the records to rename,

delete or load the settings.

Load from File Import settings from the previously saved file.

Samples Load one of the sample desktop layouts.

Rename Rename the selected settings set.

Delete Delete the selected settings set.

Load Load the selected desktop layout.

Close Close the dialog window.
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Chapter 6. Participating in the auction

Mini-Sessions
The table Mini-sessions contains: the order of Mini-Sessions during the trading session, parameters of Mini-
Sessions, start and end times of the auctions, auction results. If you do not see this table on the desktop,
select the Mini-Sessions command from the Table menu.

To enable the Queue of Orders in the Auction, select the session record for the auction in the Mini-Sessions
and double-click to open the window.

Table 6.1. Columns of the Mini-Sessions table

Column name Description
Mini-session # Number of Mini-session

Auction owner name Auction initiator firm

Commodity Commodity identifier

Price currency Mini-session settlement currency

Cross rate of auction currency to
rub.

Cross rate to auction currency to rub valid for the day

Unit of measurement Unit of measurement

Kg

L

t

Delivery basis Delivery basis

Status Flag: "Trading operations allowed/not allowed"

Mini session status The state in which the lot is being placed:

Cancelled - Аукцион отменен,

Cancelled by owner - Заказчик отменил аукцион до его начала,

Successful - Аукцион состоялся,
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Column name Description
In progress - Проходят торги в аукционе,

Waiting - Ожидание начала торгов,

Closed - Прием заявок завершен.

Start time Start time

End time End time

Auto-prolongation Specifies if auction automatic prolongation is on

Auto-prolongation end time The time after which the auction cannot be automatically prolonged.

Lot size (in units of measurement) Quantity of securities in one regular lot.

Auction volume, lots Number of lots available in the auction

Maximum price Maximum trade price today

Starting price in price currency per
unit

The value of the starting price of the auction in the currency of the
auction price per unit.

Automatic price improvement Automatic price improvement Y - Yes N - No

Minimum price Minimum trade price today

Number of trades Number of trades today

Volume today (in units of
measurement)

Quantity of the commodity asset sold today, in tonnes.

Trading volume (in currency units) The volume of transactions made today on a commodity asset on the
basis of delivery, expressed in units of currency

Direction Auction direction

Auction stop time Auction stop time

Initial auction volume, lots* Number of lots available in the auction at the start of the day

Lots in firm's orders* Total number of lots in active orders, placed on the auction by the firm

Value today, rub* The volume of transactions made today on a commodity asset on the
basis of delivery, expressed in rubles

WA price* Weighted average price calculated for the auction held. The ratio of
the volume of transactions at the auction to the quantity of sold
commodity asset in commodity units.

Columns marked with * are hidden by default.

To call the context menu, right-click on the table row.

Command Description
Order Queue Open the Order Queue dialogue box with an option to enter your own

orders.

Copy Cell Copy the cell content to the clipboard.

Filter Open the filter setting dialog.

Column Filter Set filtration parameters for the active column.

Filter Active Allow the filtration for the table.

Filters Operations with filters available for the table.

Templates Operations with templates available for the table.

Properties Open the table properties window.
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Order Queue
The Order Queue window shows trading performance in the course of the commodity auction. This window
is the main operation window for the Trading Member in the course of trading.

The window is used for viewing the auction parameters set by the Customer, entering and changing an
order, tracking the position of own orders in the order queue of other Trading Members and tracking the
duration of the Mini-Session. To enable this window, one can select the Order Queue command in the

Tables menu.  Order Queue.

The price algorithm, with improvement or without improvement, is displayed among the auction
parameters: Price improvement indicator is displayed in the Starting Price field of the Order Queue window
and in the Mini-Sessions window, in the Automatic Price Improvement field.

In the auction without improvement, the starting price does not change until the end of the auction.

In the auction with Automatic Price Improvement, the starting price changes over time in favour of the
member if the total volume of orders from members is less than the volume set by the customer. You can
wait until the price improves to enter an order at a more favourable price. When the price improves, the
value in the Starting Price field flashes and a ticker appears to inform you of the change.

To find out the history of changes in the starting price in the auction, you should press the button . Start
Price History table with the list of events and time of initial price change will be opened.
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Before the start of the auction, the customer can change the auction volume only to reduce the initial
number of lots. If you are waiting for trading to start by opening the "Order Queue" for an auction that has
not yet started, you may notice that as the auction volume decreases, the value in the "Quantity, lots" field
flashes and a ticker appears to inform you of this change.

Exclamation mark  in the field Quantity, Lots means that the customer has preliminarily reduced the
volume of the auction.

 

In the middle part of the window the remaining time in the format H:MM:SS until the end of the auction and
the auction progress indicator are displayed. Any events during the auction, such as moments of increasing
the starting price or moments of extending the auction time, are displayed as notches on the scale.

To find out which event is indicated by which notch, move the cursor over it. A tooltip will appear on the
screen.

In the middle part of the window the remaining time in the format H:MM:SS until the end of the auction and
the auction progress indicator are displayed. Any events during the auction, such as moments of increasing
the starting price or moments of extending the auction time, are displayed as notches on the scale.

To find out which event is indicated by which notch, move the cursor over it. A tooltip will appear on the
screen.
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Users can participate in automatically extended auctions. If the auction schedule has a grey area at the
end, auto-extension will take place during the auction. If the order was submitted at a better price than
those entered before or the volume was increased at the current best price, the auction will be extended for
a fixed time, Increment (e.g. one minute). The automatic extension (prolongation) event can be repeated
several times during an auction. The values of the Extension Decision Period and Increment parameters are
known to the auction customer.

To view the table with the timetable of events in the auction, click 

The field displaying the queue of orders in the auction is divided into two sectors:

• green (the best orders in the auction at the time with the comment "The order is winning" or "The order
is winning partially");

• red (orders in this zone are not the best orders at the time, with the comment: "The order is not winning").

The order submitted by the user is highlighted in the queue in bold; the time of entry and the name of the
firm are indicated.

To call the context menu, right-click on the table row.

Command Description
Enter New Order Open the dialogue box for order entry using the parameters of the

current auction.

Edit Price or Quantity Open a dialogue box to replace your own order

Follow active auction If this flag is set, the window will always show the current auction, and
completed auctions will be hidden

Copy Cell Copy the cell content to the clipboard.

Filter Open the filter setting dialog.

Column Filter Set filtration parameters for the active column.

Filter Active Allow the filtration for the table.

Filters Operations with filters available for the table.

Templates Operations with templates available for the table.

Properties Open the table properties window.

Mini-Session Schedule

The Mini-Session Schedule table displays a list of events for an individual auction, both completed and
future, and their times.
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To open the Mini-Session Schedule table, perform one of the following actions:

• select the auction, and then select the Mini-Session Schedule command in the Table menu of the main
menu;

• click the Mini-Session Schedule button on the auction parameters panel in the Order Queue window.

Table 6.2. Columns of the Mini-Session Schedule table

Column name Description
Time Time the event is scheduled to execute at

Event Event type

Break end,

Trading/auto-prolongation end,

Main session end/prolongation,

Break start,

Auction confirmation,

Trading start,

Start price change.

Status Event status - flag showing whether the event has already happened
or not:

Active,

Blocked,

Carried out,

Deleted.

Delivery basis Delivery basis for the commodity in the auction, method of delivery

Security* Security ID

Security ID* Security ID

Board ID* The ID of the auction mode for which the event is defined.

Board* ID of a trading board the event is concerned with

Commodity Name of the commodity in the auction.

Columns marked with * are hidden by default.

To call the context menu, right-click on the table row.

Command Description
Copy Cell Copy the cell content to the clipboard.

Filter Open the filter setting dialog.

Column Filter Set filtration parameters for the active column.

Filter Active Allow the filtration for the table.

Filters Operations with filters available for the table.

Templates Operations with templates available for the table.
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Command Description
Properties Open the table properties window.

Start price history

The table "Start price history" contains the list of events of change of the starting price in an individual
auction with the time, as well as the old and new value of the starting price of the auction. By default, the
events in the table are sorted from earlier to later.

To open the "Start price history" table, do one of the following:

• Select the desired auction, and then select the Start price history command from the Table menu of the
main menu.

• Click the button  in the Starting price field on the Auction Parameters panel in the Order Queue window.

If the button is not displayed in the Starting price field, it means that the initial price has not changed
since the beginning of the auction.

Table 6.3. Columns of the "Start price history" table

Column name Description
Time The time at which the starting price was changed.

New starting price in currency of
price per unit

New starting price in currency of auction price per unit pf
measurement

Previous starting price in currency
of price per unit

Previous starting price in currency of auction price per unit pf
measurement

Delivery basis* Delivery basis for the commodity in the auction, method of delivery

Security* Auction number.

Security ID* Auction ID.

Board* Name of the auction mode for which the price change event occurred.

Commodity* Name of commodity.

User ID* ID of the user

Columns marked with * are hidden by default.

To call the context menu, right-click on the table row.

Command Description
Copy Cell Copy the cell content to the clipboard.

Filter Open the filter setting dialog.

Column Filter Set filtration parameters for the active column.

Filter Active Allow the filtration for the table.

Filters Operations with filters available for the table.

Templates Operations with templates available for the table.

Properties Open the table properties window.

Entering auction order

Trading is run in a unilateral auction format.
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A participant can submit orders in the Seller's Auction and offers in the Buyer's Auction. The sequence of
actions to participate in the auction is the same for both buying and selling.

The background of the auction in the Order Queue window and the background of the order entry windows
show the direction of orders in the auction:

• green - for bids;

• red - for offers.

To take part in the auction, it is necessary to:

1. Open the Order Queue window and wait for the auction to start;

2. Find out the starting price of the auction and watch it improve if this is the auction with automatic
improvement;

3. Input your order (see instructions below);

4. Follow the position of your order in the queue (in the Comment field you will see the entry Your order is
winning or Your order is not winning);

5. If necessary, change your order in the auction: increase the number of lots or make the price more
favourable for the auction provider (see instructions below);

6. If necessary, make an additional order, not exceeding the total number of lots in the auction;

7. Monitor the position of competitors' orders and the end time of the auction;

8. If the order is satisfied in full or partially, view information about the transaction in the table Trades.

Information about submitted orders is shown in the Orders table.

To enter an order:

1. Select the current auction in the Mini-Sessions window and right-click on its entry;

2. Open the current auction window by selecting the Order Queue command from the drop-down menu;
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3. Click the Enter New Order button above the order queue area;

4. The order entry window will open, it will contain the parameters of the current auction.
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5. Specify the Number of Lots.

6. Specify the price in the Price per unit field.

7. If necessary, set the Autocorrect order price flag. Autocorrection is necessary to keep your order at the
level of the best in the auction. If during the auction your order wins partially or does not win, its price
will be automatically adjusted by the auction price step so that it is fully winning again.

You can allow Auto correction of order price in the Parameters window on the Special Settings tab.

8. To limit changes in the price of your order, set the Autocorrection limit price parameter. Then the
adjustment will not cause your order to be above the limit price (if you place a buy order) or below the
limit price (if you place a sell order).

To enter the maximum number of lots available, click on the Maximum value above the Number of Lots
field. To the right of the Number of Lots field, the number of units (tonnes, kilograms, litres) that can be
sold under your order is displayed.

To enter the best available order price, click on the Max value above the Price per unit field. The total volume
of your order in the currency of the auction price is displayed to the right of the Price per unit field.
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You need to confirm the order in the next dialogue box:

If all the parameters of the order are correct, click Yes.

If the order is accepted by the trading system, a registration message will appear.
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Please note Before confirming the order, please carefully check the price and quantity of
commodity.Members cannot cancel orders already in the auction.

Entering a replacement order

Members can change (amend) orders entered. Amending an order cancels a previously submitted order
(the original order is removed, see Status in the Orders window).

To change your own order in the auction:

1. Select the current auction in the Mini-Sessions window and right-click on its entry;

2. Open the current auction window by selecting the Order Queue command from the drop-down menu;
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3. Click the Edit Price or Quantity button above the order queue area;

4. The Amend Auction Order window will open:
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5. Specify the Number of Lots.

6. Specify the price in the Price per unit field.

7. You can change the autocorrection parameters by enabling or disabling the Autocorrect order price
parameter.

8. Specify a value in the Autocorrection limit price field if autocorrection is enabled.

9. Click the Enter Order button.

You need to confirm the new order in the next dialogue box.
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If all the parameters of the order are correct, click Yes.

If the order is accepted by the trading system, a order acceptance message will appear.

If only the Autocorrection parameters have been changed, the confirmation window will look as follows:

And a message will appear indicating that the new autocorrection parameters have been accepted:
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Order Criteria
Please note: an order is not accepted by the trading system in the following cases:

• The total number of lots in the Member's orders exceeds the number of auction lots;

• The auction has ended;

• The parameters of the substituting order do not differ from the parameters of the original order;
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• The quantity of units of the commodity in the substituting order is less than the previously specified
quantity;

• The price of the substituting order is worse (lower for the seller's auction and higher for the buyer's
auction) than the previously specified price;

Entering Number of Lots exceeding the upper limit of the auction results in the maximum permissible
quantity value being automatically inserted.

When entering a price lower than the initial auction price, the initial price is automatically substituted in the
Price per unit field.

The order price is changed in multiples of the minimum price step set in the auction.

If the entered price is very different from the initial auction price, the order will be accepted by the system
with a warning notice.

Order with autocorrection will be accepted by the system after a warning, if the entered limit price is very
different from the initial auction price.
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Chapter 7. Viewing Member's data

Orders

The Orders table contains the list of orders submitted by the Trading Member for the current trading day.

To open the table, perform one of the following actions:

• select the Orders command in the Table menu of the main menu;

• press the button  on the toolbar.

Table 7.1. The columns of the Orders table

Column name Description
Order # Order ID in the Trading System

Time Time when the order was registered by the Trading System

Status Order status:

Mini-session # Number of Mini-session

Commodity Commodity name

Delivery basis Delivery basis

Direction Quote direction: buy or sell

Price in price currency per unit Order price value, expressed in price currency per unit

Lots Quantity, expressed in lots

Amount, units Amount, units

Value (in currency units) Order value, expressed in units of currency

Lots left Volume of unmatched part of an order, expressed in lots. Additionally,
the field shows the percentage of lots left value to the full amount.
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Column name Description

Balance, units Balance of the unfilled portion of the order in units of measurement.

Commission, rub. Trade commission, in Rubles

User ID ID of the user who has entered the order

Update time* Time when the order was updated last time (matched, cancelled)

Amended order number* ID of the order that was replaced by the given order

Value, rub.* Order size in RUB Calculated based on the rouble to price currency
exchange rate set by the Bank of Russia for that trading day.

Autocorrection limit price* Autocorrection limit price set by the Participant.

Columns marked with * are hidden by default.

To call the context menu, right-click on the table row.

Command Description
Order Queue Open the Order Queue dialogue box with an option to enter your own

orders.

Copy Cell Copy the cell content to the clipboard.

Filter Open the filter setting dialog.

Column Filter Set filtration parameters for the active column.

Filter Active Allow the filtration for the table.

Filters Operations with filters available for the table.

Templates Operations with templates available for the table.

Properties Open the table properties window.

Trades

The table "Trades" contains all own trades executed by representatives of the Trading Member on the
Commodity Market since the beginning of the trading session.

A record of the trade appears if your order in the auction won in completely or partially, and the status in
the table Orders is displayed as  + (Filled).
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To open the Trades table, perform one of the following actions:

• select the Trades command in the Table menu of the main menu;

• press the button  on the toolbar.

Table 7.2. The columns of the Trades table

Column name Description
Trade number in the Trading System

Time Time when the trade was registered by the Trading System

Mini-session # Number of Mini-session

Commodity Commodity name

Delivery basis Delivery basis

Direction Quote direction: buy or sell

Price in price currency per unit Exchange rate of the currency instrument

Lots Trade volume, expressed in lots

Amount, units Trade amount, expressed in units

Value (in currency units) Trade value, expressed in the currency of settlement

Commission, rub. Trade commission, in Rubles

User ID ID of the user who concluded the trade

Counterparty Counterparty firm name

Counterparty ID Counterparty firm identifier

Order # Number of order from which the trade originates
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Column name Description
Value, rub. Trade size in RUB Calculated based on the rouble to price currency

exchange rate set by the Bank of Russia for that trading day.

Columns marked with * are hidden by default.

To call the context menu, right-click on the table row.

Command Description
Copy Cell Copy the cell content to the clipboard.

Filter Open the filter setting dialog.

Column Filter Set filtration parameters for the active column.

Filter Active Allow the filtration for the table.

Filters Operations with filters available for the table.

Templates Operations with templates available for the table.

Properties Open the table properties window.

"Users" table

The "Users” table contains the list of registered user IDs of representatives of the Trading Member on the
Commodity Market.

To open the table, perform one of the following actions:

• select the Users command in the Table menu of the main menu;

• click  on the toolbar.

Table 7.3. Table columns

Column name Description
User ID User ID of the Trading Member

User name User name of the Trading Member

Status User status:

[empty] – Trading operations allowed

= – Trading operations not allowed.

Active The user activity sign indicates that the user is currently logged in to
the Trading System.

User type User type of the Trading Member Technical Administrator, Exchange
Broker, Clearing Centre Specialist, Trading Member, Firm Manager,
Firm Observer, Bank of Russia Observer.

Gateway IP address of the gateway.

Workstation IP address of the user's PC.

Context menu commands

To call the context menu, right-click on the table row.

Command Description
Copy Cell Copy the cell content to the clipboard.
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Command Description
Filter Open the filter setting dialog.

Column Filter Set filtration parameters for the active column.

Filter Active Allow the filtration for the table.

Filters Operations with filters available for the table.

Templates Operations with templates available for the table.

Properties Open the table properties window.
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Chapter 8. Actions by auction owner

All actions with auctions and parameters can be performed only before the start of an auction. If an auction
is cancelled, completed or has already started, you will receive an error message if you try to modify the
auction and its parameters.

Desktop of the auction owner

• Own mini-sessions

To ensure that only auctions where your firm is a customer are displayed in the Mini-Session Schedule,

use the filter. Click on the icon  in the "Auction owner name" column and select your firm name or code
from the drop-down list.

To enable the Queue of Orders in the Auction, select the session record for the auction in the Mini-
Sessions and double-click to open the window.

• "Order Queue" window for the customer

You cannot submit orders in an auction commissioned by your firm. The buttons to enter an order and
change the price or quantity will not be available.

In the order field, you can see the orders of the members who are winning your auction:
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Click the value in the Quantity, lots field to change the volume of the auction before the auction starts.

Click the value in the Starting Price field to change the starting price of the auction before it starts.

Click the button  to see how the starting price has changed.

• Table "Orders"

The table contains information about orders placed on behalf of the firm on the basis of past auctions.
The display of the "Orders" table for the Auction owner coincides with the display for the participant of
the auction.

The order status in the "Status" column is displayed only as  + (Matched).

To view orders for a specific auction, use the filter on the "Mini-session #" column. Click on the icon 
and enter the mini-session number in the field.

• Table "Trades"

The table contains information about the trades concluded following the auctions. The display of the
table coincides with the display for the participant of the auction.

The fields "Counterparty" and "Counterparty ID" specify the auction participant firm with which the trade
was concluded.

To view trades for a specific auction, use the filter on the "Mini-session #" column. Click on the icon 
and enter the mini-session number in the field.
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Changing the starting price

You can change the starting price of the auction before it starts. The starting price cannot be changed if
it is the auction with automatic improvement of the starting price. This parameter can be checked in the
"Mini-Session Schedule” table in the "Automatic Price Improvement" column.

To change the starting price of an auction:

1. Select the entry you need in the "Mini-Session Schedule" table, invoke the context menu with the left
mouse button and select Change starting price. The "Change auction starting price" form will open.

The background of the dialogue box of changing parameters corresponds to the direction of the auction:

• green - for bids;

• red - for offers.

2. Set the value you need in the New auction starting price field and click Yes.

3. Confirm the change of auction parameters in the following dialogue box.
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4. A message will appear indicating that the change was successful.

Changing the auction volume

Before the start of the auction, the customer can only change the volume of the auction in such a way that
the volume does not exceed the initial volume set in the parameters. The first change in volume can only
be downward.

To change the volume of the auction:

1. Select the record you need in the "Mini-sessions" table, invoke the context menu with the left mouse
button and select Change Auction Volume. The Change Auction Volume form will open.

The background of the dialogue box of changing parameters corresponds to the direction of the auction:

• green - for bids;

• red - for offers.
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2. Set the desired new volume value in the Auction volume, lots field and click Yes.

3. Confirm the change of auction parameters in the following dialogue box.

4. A message will appear indicating that the change was successful.

Auction cancellation

To cancel an auction:

The status in the "Order Queue" window will change to Auction is cancelled by the owner.

1. Select the entry you need in the "Mini-Session Schedule" table, invoke the context menu with the left
mouse button and select Cancel the auction. The "Confirmation" form will open
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2. If you are ready to cancel the auction, tick the "I confirm the action" checkbox. The Yes button will then
become active. Click the Yes button to cancel the auction.

Please note You must carefully check the parameters of the auction to be cancelled and confirm your
action.You cannot restore a cancelled auction in the schedule.
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Chapter 9. Market summary

All Trades table

The "All Trades" table contains anonymised (without specifying the parties) information about all trades
concluded on the market since the beginning of the trading session.

To open the "All Trades" table, perform one of the following actions:

• select the All Trades command in the Table menu of the main menu;

• click the button  on the toolbar.

Table 9.1. The columns of the All Trades table

Column name Description
Trade # Trade number in the Trading System

Time Time when the trade was registered by the Trading System

Mini-session # Number of Mini-session

Commodity Commodity

Delivery basis Delivery basis

Direction The direction of the application initiating the conclusion of the
transaction

Price in price currency per unit Trade price In price currency per unit of measurement

Lots Trade volume, expressed in lots

Amount, units The volume of the trade in unit of measurement of the commodity.

Volume, units of currency Trade value, expressed in the currency of settlement

Value, rub.* Trade value, expressed in rubles. Calculated based on the rouble to
price currency exchange rate set by the Bank of Russia for that trading
day.

Columns marked with * are hidden by default.

Context menu commands

To call the context menu, right-click on the table row.

Command Description
Copy Cell Copy the cell content to the clipboard.

Filter Open the filter setting dialog.

Column Filter Set filtration parameters for the active column.

Filter Active Allow the filtration for the table.

Filters Operations with filters available for the table.

Templates Operations with templates available for the table.

Properties Open the table properties window.

"Firms" table

The "Firms" table provides a list of firms (dealers and customers) registered to participate in auctions in
the agricultural commodity market.
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To open the table, perform one of the following actions:

• select the Firms command in the Table menu of the main menu;

•
click  on the toolbar.

Table 9.2. Table columns

Column name Description
Firm code The Firm ID of the Trading Member

Firm Abbreviated name of the trading member

TIN Taxpayer Identification Number

Status Status:

[blanc] - transactions allowed

= - transactions are prohibited.

VAT payer Indication of whether the firm is a value added tax payer.

Yes - it is a tax payer

[blank] - it is not.

Active users The number of firm users currently logged in to the trading system.

Firm type Type of the Trading Member Firm (Agricultural Commodity Market
Participant) or Customer.

Context menu commands

To call the context menu, right-click on the table row.

Command Description
Copy Cell Copy the cell content to the clipboard.

Filter Open the filter setting dialog.

Column Filter Set filtration parameters for the active column.

Filter Active Allow the filtration for the table.

Filters Operations with filters available for the table.

Templates Operations with templates available for the table.

Properties Open the table properties window.
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Chapter 10. Tools and Additional Functions

Signals

The notification system can display signals on the following events:

All signals appear on the "Signals" toolbar:

When any of the above listed events occurs then the toolbar begins to blink with red. The button on the
toolbar displays the number of unread messages:

Click the toolbar to open the table realted to the particular event.

Click the arrow on the right side of the toolbar to show the full list of events and their counters. Click any
event to open the related table.

Instant Messaging

Sending Messages

To send a message to another trader of own firm or to all the traders of other firm select the following
commands sequentially in the top menu Send Message.

Table 10.1. Elements of the "Send Message" dialog

Element Description
All Send message to all the traders of all Exchanges. Option availability

depends on user's permissions.

Exchange's Firms Identifier of the Exchange. Message will be delivered to all traders
of the particular Exchange. Option availability depends on user's
permissions.

Group of Firms Send message to several firms. Option availability depends on user's
permissions.

Firm Identifier of the firm. Message will be deliverd to all traders of the firm
specified.

User Message will be deliverd to particular user.

Auto word wrap Automatic word wrapping in the message text area.

Message text 256 symbols maximum allowed.

Urgent/Important Urgent/Important message will be displayed as a pop-up window to
the recipient.

Viewing Messages

The Messages table lists all the incoming and outgoing user's messages.

To open the table select Table > Messages in the top menu.



Tools and Additional Functions

61

Table 10.2. "Messages" table columns description

Column Description
In/Out Incoming or outgoing message.

Importance Urgent/Important message indicator.

Time Time when the message was dispatched.

From User identifier of the message sender.

Text Text of the message.

To all Message is addressed to all traders of all Exchanges.

To user User Id of the message recipient.

To firm Firm Id of the message recipient.

To firms of exchange Id of the regional Exchange the message is addressed to.

Firm Id * Identifier of the firm.

Columns marked with * are hidden by default.

Viewing messages

Double click the corresponding line in the "Messages" table to view the message text. Such a window pops
up automatically when the incoming message with the urgency flag is received.

Table 10.3. "Message" window elements

Element Description
Window title: Message - X/Y X - sequential number of the message (line in the "Messages" table).

Y - total number of incoming and outgoing messages in the table.

From Message sender ID.

To Message recipient ID.

Sent / Received Time when the message was sent/received.

Wrap wordss Automatic word wrapping in the message text area.

Back Open the previous message.

Next Open the next message.

Reply Send the reply to the message sender.

Forward Send this message to the other recipient.

Close Close the dialog.

Data Export

Error Messages

To copy Error Messsage content to the clipboard press Ctrl+C. This function can be used when contacting
the Support Team.

Save Table Data

Save to file

To save the contents of a table use Save -> File command in the Data menu or press Ctrl+S. The standard
"Save File" dialog will appear.
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Specify the location and file name, select one of the file formats and click "Save".

File formats for table data export:

• CSV (comma-separated) - *.csv

• Text files (tab-separated) - *.txt

• XML files - *.xml

• DBF (dBASE III) - *.dbf

• Microsoft Excel workbook - *.xls

Copy to clipboard

To copy the whole open table to the clipboard select the Save -> Clipboard command in the Data menu
or press Shift+Ctrl+C.
s

Dynamic Data Export

Export Setup

To create a procedure for dynamic data export to database or Excel select the Data -> Dynamic Export -
> New Export command in the main menu or the New Export command in the popup menu of the Export
Manager table.

Export setup is designed as a step-by-step wizard. On the first step select a table to export and the export
type. The following steps will differ depending on the chosen type of export procedure.

Two types of export are supported:

• ADO (Active Data Objects) should be used to export data to any database management system which
has a driver installed on the local PC. Standard ODBC driver is also supported.

• DDE (Dynamic Data Exchange) should be used to export data to Microsoft Excel or to DDE servers.

When selecting ADO export:

First select connection source - either an existing data link file (.udl or .dsn) or specify a custom connection
string.

On the next step select the destination table in the database and specify the mapping between local table
fields and fields in the database. Based on the type and names of fields in the database the program tries
to guess some of the mapping. Key fields are displayed in bold font and they must have a mapping to the
database. Mapping of other fields is optional.

Note: it is not recommended to use reserved words of the DBMS while exporting as column names in the
destination table.

When selecting DDE export:

First select the recipient application: Microsoft Excel or external DDE server. When exporting to Excel enter
or select file name and/or sheet name. If no file name is given then every time the export starts a new file
will be created. If no sheet name is given while the file name has been indicated then every time the export
starts a new sheet will be added. For DDE server appropriate service and topic names should be specified.
Select table fields that should be exported and reorder them if needed. This dialog also contains additional
options such as server timeout, column caption settings (do not export, export IDs, export names) and the
checkbox to add an empty row to the Excel sheet.
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Notes on the export to Excel:

• each sheet can contain only one table;

• export cannot start when there is any dialog box open in Excel or if any cell is being edited;

• do not edit sheets that are used for export, link to data from other sheets instead;

• if group names are used in Excel and the range of these groups breaks when new data is exported then
use the "Add empty row" option; also use this option in case cells that are referenced from other sheets
keep shifting.

After clicking Next the confirmation dialog will be shown. It also provides several additional options:

• Auto start export - automatically start dynamic export after connecting to the Trading System.

• Start delay, sec - auto start delay. Default value: 60 sec.

• Start export now - start dynamic export immediately after pressing Finish button.

All the configured export procedures can be accessed, reconfigured, disabled or deleted from the Export
Manager table using the table's popup menu or commands from the Data -> Dynamic Export menu. All the
events concerning the dynamic export such as export start, stop or error are stored in the Export Log table.
When an export error occurs, a notification appears on the signal toolbar.

Developing own DDE servers

Besides support of the standard connection and disconnection functions the DDE server must support the
following transactions:

а) XTYP_POKE. The item name (hsz2) will contain a string with data range in MS Excel
format: RaCb:RyCz, where a <= y and they are both inside the 1..n range where n - the total
number of rows; b <= z and they are both inside the 1..m range where m - number of fields
being exported. Data (hdata) is delivered in XlTable format, see: http://digital.ni.com/public.nsf/
ad0f282819902a1986256f79005462b1/88cfa6094f6b5030862566fa002279e0/.

б) XTYP_EXECUTE. The server may also receive the following commands (hdata):DeleteAll - delete all the
previously received data; DeleteRow(x) and InsertRow(x) - delete or insert row inside the (1..n) range.

Export Manager
The Export Manager table lists all the configured export procedures and allows users to reconfigure, pause,
stop or delete them using the popup menu or commands from the Data -> Dynamic Export menu.

To open the table select the Data -> Dynamic Export -> Export Manager item in the main menu.

Table 10.4. "Export Manager" table columns description

Column Description
Number Indentification number of the export procedure.

Autostart "Yes" - export procedure is sutomatically started after connecting to
the Trading System.

Delay Export autostart delay.

Status Current export status

Type Type of the export: ADO or DDE.

Source Source table.

Target Receiver application.
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Column Description
Comments Information on current export status or error message.

Updated Time of the last data transfer from Source to Target.

Export Log
All the events concerning the dynamic export such as export start, stop or error are stored in the Export
Log table. When an export error occurs, a notification appears on the signal toolbar.

To open the table select the Data -> Dynamic Export -> Export Log item in the main menu.

Print Table
To print any table select the Print item in the Data menu or press Ctrl+P. The print preview window will
open first.

Tables are printed according to their current layout on the screen, including the column width and filters
applied.

List of Open Windows
To view the full list of open tables and switch to any of them use the Go to Window command in the Windows
menu or press Alt+0.

Use the drop-down list to display windows from a particular sheet or all the open windows. Type text in the
search field to filter the list.

Double click any window to go to it.

Transaction Log
The Transaction Log table lists all the transactions that have been sent by the program to the Trading
System since the beginning of the trading session.

To open this table select the Transaction Log item in the Session menu.

Transactions that have failed or returned an error are highlighted in red.

Table 10.5. "Transaction Log" table columns description

Column Description
# Record number

Sent Time when transsaction was submitted to the Trading System.

Action Transaction description.

Parameters Transaction parameters.

Execution time Transaction execution time (microsecond).

Status Execution status:

+ – success

! – failed.

Trading System Reply Trading System Reply message.

Double click a transaction to view its parameters. Title background of the Transaction Parameters dialog
for orders corresponds to the order direction: green for buy orders and red - for sell orders.
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Password Reset

To set a new user password when you log in for the first time, or to replace an expired password:

1. Enter your current password or the most recent outdated password in the Current Password field;

2. Make up a password and fill in the New Password field;

3. Enter the new password again in the Repeat Password field to avoid mistakes;

4. Press Yes.

5. If all requirements are met, a message about successful password change will appear.

When changing the password, the password security requirements must be observed:

The length of the new password is strictly eight characters. A longer password is not allowed. If you try to
enter a shorter password, an error message will be displayed.

The new password must not contain 4 or more consecutive identical characters, e.g. combinations of 2222
or AAAA.

The password must contain at least three of the four character categories:

• Latin uppercase letters a to z

• Latin capital letters A to Z

• Numerals from 0 to 9

• Special or non-alphabetic characters, e.g. !, @, %, + (except # and =)

Examples of suitable strong passwords:

vGKu3l1x

capital and lowercase Latin letters, numbers are used;
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&dghy29a

capital and lowercase Latin letters, digits and a special character are used;

KGtx!C<p

uppercase and lowercase Latin letters, special characters are used.

It is not allowed to reuse old passwords. You will receive an error message.

If you encounter an error message when setting a new password, refer to Error Messages and Warnings
When Resetting Your Password.

Error messages and warnings when changing the password

• The new password is too short.

Make up a password that is 8 characters long.

• The password does not have all the required characters.

Make up a password that contains letters in different cases, numbers, and special characters as shown
in the example [65].

• There are many repeated characters in the password.

Make up a password that excludes combinations such as 2222 or AAAA.

• An error was made when entering characters in the Current Password field.
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Enter the correct current password or the last of the old passwords.

• The new password matches one of the previous passwords.

Make up a password that has not been used before.

• The passwords entered in the New Password and Repeat Password fields do not match.

Fill in the bottom two fields with the same password.

Connection Information

To view details about the current connection to the Trading System select the Connection Info item in the
Session menu.

The Connection Information dialog box shows the connection method (through private network or over the
Internet), Gateway server name and security details. When connection uses an electronic digital signature
then the Server Certificate button will be available to view the server and client certificates.

Press the Show Options button to view the server IP address, traffic details and mtesrl.dll version.

To open the folder with log files for current user press the Show Log.... The button is displayed in case of
the "Turn on logging" flag was set during the connecting to the Trading System.

Options

To access the program options select the Options item in the Tools menu or press Ctrl+O.

The Options dialog window consists of several tabs.
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Connection Tab

The Connection tab of the options window contains the network and connection settings.

Table 10.6. Elements of the "Connection" tab

Element Description
Active profile Select connection profile to view its settings below. Connection

profiles allow user to store different sets of parameters and can be
used, for example, to quickly switch between production and test
environments.

Modify Edit selected connection profile.

Add Add new connection profile.

Delete Delete selected connection profile.

Synchronize local PC time with
trading system

Local PC time will be synchronized with Tradin System time at each
successful connection.

Table 10.7. Elements of the "Trading System" tab

Element Description

Direct connection via TSMR:
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Element Description
Broadcast List of networks addresses (bridges) where searching for available

access servers (gateways) will be performed.

Server Trading System server identifier. Note: this field is case-sensitive.

Service Trading System TCP and UDP services name.

Preferred gateway (network)
address

Address of the Trading System network (bridge) where search for
available access servers (gateways) will be performed first.

Internet connection:

Host list List of access servers (gateways) for connecting to the Trading
System.

Server ID >Trading System server identifier. Note: this field is case-sensitive.

Request connection confirmation Additional confirmation required for Internet connection.

Adv.Options Tab. Price autocorrection

To enable price autocorrection option in Order entry dialog, select the Options item in the Tools menu or
press Ctrl+O. Then go to the "Adv.options" tab.
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Table 10.8. Elements of the "Advanced Options" tab

Field Description
Allow auction order's price
autocorrection

If this flag is checked, autocorrection of Order Prices and Limit
autocorrection Price at order entry.

What is autocorrection

autocorrection is necessary to keep your order at the level of the best in the auction. If during the auction
your order wins partially or does not win, its price will be automatically adjusted by a multiple of the auction
price step so that it is fully winning again. The price can change until it reaches the limit price.

For example, you have entered an order into the auction at the starting auction price of RUB 15,800 per
tonne and set the limit price at RUB 16,200 per tonne.

Once the order is placed in the queue, a continuous price level check is started:
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• Is the order winning the auction totally? The price is not affected in any way.

• Is the order winning partially or loses? A new price is calculated. Your order in the queue is outbid by a
new order at RUB 15,850 per tonne. To totally win again, the price is adjusted to RUB 15,900 per tonne.

• Is the new price higher than the autocorrection limit price? The order moves to the calculated new price
level. If the order stops winning again, the price will change further until it reaches the limit price or until
the auction ends.

• Has the adjustment price limit already been reached? The order remains at the current level and does not
fall below RUB 16,200 per tonne.

Thus, the autocorrection maintains your order in the auction at a level at which the order totally wins.

Table 10.9.

During the auction, the autocorrection can be disabled. Then the price
will no longer change and the order will remain at the price level that
was set at the time of deactivation.

During the auction, you can change the limit price of autocorrection,
as well as the main parameters of the order.

Tools Tab

The Tools tab of the options window contains the general program settings.

Table 10.10. Elements of the "Tools" tab

Field Description
Application language Language of the user interface. Changing the language requires

application restart.

Show Login dialog at program
startup

Show "Authentication in the Trading System" dialog at application
startup.

Request quit confirmation Show confirmation dialog a attempt to close the application.

Show in main window caption Select parameters to be displayed in the main window caption. "Up"
and "Down" buttons can be used to customize their order.


